Pinebook pro - How to remember volume between startups?

Hi,

Sorry for posting about such a trivial issue that is covered in dozens of posts here, on stackoverflow or on several forums.

I just cannot get alsamixer to remember the volume level of my sound card (the Headphone level of the soundcard, not the alsa Master level).

What I know:

  • alsactl store returns alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists but I think I could use it in the past
  • alsactl restore sets a level of 28 and I cannot change this with alsactl store
  • sudo alsactl store works just fine
  • sudo alsactl restore restores whatever level I set with sudo alsactl store

When rebooting, the level is always reset to 0.
I tried launching alsactl store with a script, both with .config/autostart and with Plasma's autostart but the sound level is always 0 at startup. I makes me crazy not to be able to do something so simple.

do you have a setting in alsamixer for Auto-Mute Mode set to Enabled ?
that setting may be muting headphones when system is booted, suggest change it to Disabled if headphones are kept plugged in

sudo is required with alsactl to access the default configuration file /var/lib/alsa/asound.state

but if a configuration file is created in user home folder:

alsactl -f /home/$USER/.config/asound.state store

alsactl can be used in a script without sudo

alsactl -f /home/$USER/.config/asound.state restore

No sorry. I use a pinebook pro, thus the features might be limited.

Your fix works to use alsactl without sudo. However it still isn't automatic.

i would expect most of ALSA to function the same on any other system, but there may be limitations due to the audio codec

suggest get full ALSA information to see if ALSA is functioning normally

sudo alsa-info.sh --upload

and paste the link here for data uploaded to alsa-project

Wow, didn't know about this!

http://alsa-project.org/db/?f=bf8dea14483fa661580ca72b77ce96c35a30725d

i do not think i can help you any further on this
maybe someone more familiar with this hardware can help

ALSA controls for this audio codec are totally different to more usual audio codec
there is no auto-mute mode option, or other similar controls that i recognise

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by