Pinebook Pro - WiFi not working

Hello Manjaro Team and Community,

This is my first post in the forum. I'm new to Linux world and Manjaro. I'm a new Pinebook Pro owner and having issues connecting the WiFi. After the latest pacman update my home WiFi was not getting connected. I tried downgrading the wifi firmware but that didn't work. Eventually I had to reinstall Manjaro 20.4 to connect my WiFi.

With version 20.4 I had lot of new updates available but I knew the wifi will not work if I update it. When I tried installing selected app updates I ran into nss:/use/lib/p11-kit-trust.so exist in file system error. To fix this I had to go to root user per suggestion on the forum to fix that issue. But when I did that I got upgraded to latest Manjaro version 20.6. Which means when I restarted my laptop it won't connect my home WiFi again. I don't want to reinstall Manjaro 20.4 all over again on my Pinebook Pro.

Is there an alternative? I cannot connect to WiFi via my phone hotspot either. In other words not internet connectivity on my laptop whatsoever. Please help!

Thanks,

Ashwin

once you check this site you'll find a search function at the top right position, and yes it works :shushing_face:

search for "pinebook wifi" you'll get results like this:

1 Like

Probably no need for a reboot on the last set .. most likely just needs

systemctl restart NetworkManager

I know about the privacy switch, If you read my post you will see that the WiFi stopped working after the latest update.

Tried restarting using the command but not luck, it won't connect my WiFi. From what I've read it's a wifi firmware bug.

you tried to enable/disable wifi with F11 and the Pine-Button ? Is the LED flashing two times or three times ?

If you downgraded the firmware and that didn't fix things, then it is unlikely that it is a firmware issue.

It could have been a kernel revision, or an update to any one of dozens of Network related packages that broke your networking.

You could try running this command to narrow down the suspect packages:

cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa\|vnc" | grep -v "head\|nvidia"  | tail -n 30

Can you clarify what you mean by “not connect”?

Is the WiFi device not recognized by the system? Does it not show any available WiFi SSIDs? Does it show the SSIDs but not authenticate/connect to your home network?

What was the command you used as root to fix this?

Are you on the stable branch?

System info would be appreciated: inxi -Fxxxz

I never had an issue with WiFi not connecting when I got my Pinebook Pro in the June batch. The issue started after I updated the latest Manjaro updates. The WiFi search still shows my WiFi network, when I click of connect it keeps asking to enter my password and then there is a circular motion on the wifi icon and then it says it can't connect my WiFi network. It won't connect my phone hotspot either. Also 3 blinks for turning on and 2 blinks for turning off the WiFi via privacy switch. Currently the firmware for WiFi is latest and no way to downgrade it as there is not internet connectivity on my Pinebook Pro. Sorry for late response, just woke up.

the youtube video explained it. you have to activate it (2 blinkings) and then reboot to get the changes active. without reboot the changes are not active

The privacy switch only comes into picture if the WiFi network connection doesn't show up, in my case I can see them but when I attempt to connect it, it doesn't connect my WiFi. Will try using the privacy switch and see if it helps.

Hello yousukemat,
When I say it won't connect means im able to see my WiFi SSID and other around me but when I try connecting mine it doesn't authenticate. I'm on the stable branch. Here is the command I used for the update via root.
pacman -Syu --overwrite /usr/lib*/p11-kit-trust.so

I had the similar issue after the last update (20.06). I tried to connect to my home network which it had not connected to in about 30 days, and it would just cycle trying to connect never able to grab an IP. I tried to give it a static IP and that did not work on my 5GHz network but when I switched to the 2.4GHz network it did allow me to connect. Try setting a static IP and using 2.4GHz and see if that works, just to see if you can connect.
(Side note, it worked fine on my work network, and grabbed an IP right away (but again selected the 2.4GHz network...but that maybe signal related))

Have you tried different settings on your wifi router to try to narrow down what the issue may be, such as:

  1. temporarily removing the wifi password from your network to see if it's an authentication issue.
  2. changing the wifi network to broadcast in only 2.4Ghz and only in 5Ghz
  3. turning on bluetooth on your PBP
  4. trying to connect to other wifi networks

Hi, I'm having the similar problem as well. Just got my Pinebook Pro that had 20.04 installed and I was able to connect to my 5Ghz WiFi network. However after updating to 20.06 I wasn't able to connect to my 5Ghz network (the antenna is about 10 feet away) but I could connect to my 2.4Ghz network. Since I was still able to connect to my 2.4Ghz network I haven't bothered to try to fix it.

Sometimes wifi adapters have trouble connecting on the 5 GHz band if using one of the higher channels that is automatically assigned. Sometimes setting a fixed channel of 40 or below in your router will allow it to connect. Sometimes dropping the bandwidth to 40 in the router settings also helps.

Doing as you suggested worked; my Pinebook Pro now can connect to my 5Ghz WiFi network.

1 Like

Glad to hear that helped.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by