Plasma 5.18 bugs

Yeah this is without a doubt related to theming but changing themes does not help - some elements are darkened anyway - just more or less. The only affected place as far as I can tell now is Network Manager's settings.
I'm getting absolutely lost :dizzy_face:

UPD: Oh I get it now. Looks like it depends on plasma theme. Thing is, I like dark Plasma themes, but I prefer light colors for windows. When both windows and plasma elements are dark, there's no issues, just as when both are light. But with the dark/light mix this problem occurs.

At least now I'm glad that I recolored all Materia themes including dark ones -- using it now :smile:

1 Like

So, has anyone tried it yet? I mean a mix of light color scheme and dark plasma theme. It may be my case only though (if you guys/gals won't face this issue). Question is, should I report it?

I have the same problem as you do,
For me, I use Materia as a global theme but I force latte-dock (systray) to use Materia-Dark (both kvantum and color scheme)



1 Like

Ah, it's reported already.


I've seen it now with Breath2 but I'm running KDE Neon right now, checked it and the issue isn't present, maybe already fixed? The ISO I'm running was compiled this morning. I cannot recreate it with Breeze Light as per the bug report either.


Yep, looks fixed to me with 5.18.3

What still happens though is notification sounds are permanently muted until you install PulseAudio Volume Control and un-mute them with that. Then you can bring them up to 100%.

When using Desktop as Folder View the Mouse Actions Vertical-Scroll is not working, but it works in Desktop mode where the Left-Button is not working. I'm one of those (maybe few) that likes to use
Left-Button, Vertical-Scroll, Middle-Button and Right-Button and right now none of the Layouts gives me that possibility ... :unamused:

1 Like

Yeah I can confirm that the scroll doesn't work with folder view anymore.

1 Like

Even worse now, out of nowhere, when i right click on a Widget in the Panel is unlocking the Panel and brings me to those settings of Customize Layout, while it used to invoke the options for that particular widget only, and everything was locked. Now i understand why people complained about that Lock feature.

Maybe it's because of the recent qt update?
I don't remember having these issues before.

Very possible to be due the Qt5 update. We will see the days that come if something gets fixed. In April 11th we will probably get the new KDE Framework 5.69 and in May the KDE Plasma 5.18.5
I was hoping that such trivial regressions will not be present, but as i was testing also the GIT version:
all the widgets are off, no applications have title bars, can't be closed once opened. Panel look is off and all their interaction dialog are shifted their place and remain on screen ... It happens with all themes.


1 Like

It still does for me

It came out of nowhere for me, and i can't figure out what changed.
Found it. I added this in ~/.config/plasma-org.kde.plasma.desktop-appletsrc


Logged out and back in and now the right click is normal in the panel widgets. Quite strange it got missing.

Got it.
2020-04-03 update happened to fukup my plasma shortcuts- what i noticed just this morning. It happened not initially after the update, i even had some reboots in between.
I re-made those, then the next update appeared so it didn't bother to post about it.

But even the entry:
and this should not happen in home directory.

Now i'm comparing 3 files: one that is on the system, a backup and an older backup. All different, oddly, as i never change anything over time after i do my initial tweaks. Hmmm...

That happens if you change and revert back the application laucher iirc.
Unfortunately i'm semi-educated at best. :slight_smile:

RANT - The developers to my mind still don't fully comprehend how this UI element locking policy change VERY BADLY affects accessibility. They have stated they won't fix this issue until 5.19 if at all and ONLY if new bugs are filed for plasmashell and panel separately because they will have to re-code how they work too. The far simpler option would be to reverse the policy changes but apparently that also isn't possible without breakages or conflicting with the 'new' policy.

IF they had to live with the issue themselves they'd understand and see where they'd majorly screwed up.

How are new or existing users with palsy, Parkinson's or essential tremor supposed to know and be able to enter terminal commands to lock everything down which was possible before with a single click in the UI?

I won't go into the technicalities of how this remains an issue here because they were already explained in detail and essentially outright dismissed on bugzilla.

Apparently if I want this fixed I have to file a new bug for something they have already dismissed off-hand in a bug report about this eaaxcat function? I REALLY cannot be arsed now and if you or any other developers can't see why then what's the point anyway?

@Pointedstick as you probably worked out already I am pissed off to put it politely as possible because you clearly still don't see the full picture despite it being explained to you VERY clearly when you asked what the issue was.

I get it's difficult to put right in a point release but it should never have been released in this form without due diligence of such issues in the first place. This may seem unduly harsh to you but it really is not, it is fair and constructive criticism of the Project's planning and decision making process. To re-emphasise I am not trying to insult anyone here before you go on the defensive again.

How can you put it right? PLEASE take this under your own wing and file those separate bug reports yourself based on all the information I already posted to the bug thread.


At this rate i fear maybe the Devs might next take away our ability to have separate widgets & wallpapers per VD, forcing us to instead co-opt the unsatisfactory Activities paradigm to do that.

Oh, wait...

1 Like

I also face the same by the recent update..hope it will be fixed soon..notifications are off !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by