Plex setup help

I've downloaded Plex to see if I would like to continue using it in my transition to Linux. The problem is that Plex is unable to access any files in the library's I set up. I've tried moving the files from my external drive to the desktop but after pointing Plex to the new location it still can't read it.

After some looking this up for a while I'm sure it has something to do with the Plex group needing the proper permissions to read the files, however I'm unsure on how to do this.

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies... I.E. Can you be more specific as to which exact commands you've run to install Plex, which configurations you've made, ...

:wink: :+1: :innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

I've updated my profile to include some more information.

To install Plex I followed the instructions here:
I installed the plex-media-server and ran these commands:

  • sudo systemctl enable plexmediaserver.service
  • sudo systemctl start plexmediaserver.service

I opened Plex to created a new library and added the folder /run/media/insomnious/G-Drive/Media/TV
After scanning the library was still empty. I did some browsing and found this post:Emby permission setting

I tried to adapt the command for my situation: setfacl -m g:plex:r-x /run/media/insomnious/G-Drive/Media/TV, but the library still comes up empty.
I should also note that my media is stored on an external drive.

  Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=2a7938b8-3de8-407d-b744-1be0a7ac46fa rw quiet 
  resume=/dev/mapper/luks-0a6544c6-5c1f-4f54-89ee-46ef4e7dd01d apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Dell product: XPS 8700 v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Dell model: 0KWVT8 v: A02 serial: <filter> UEFI: Dell v: A11 
  date: 07/09/2015 
  Topology: Quad Core model: Intel Core i7-4770 bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 54295 
  Speed: 898 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 898 2: 898 
  3: 898 4: 898 5: 899 6: 899 7: 898 8: 898 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1c82 
  Display: x11 server: X.Org 1.20.7 driver: nouveau unloaded: modesetting 
  alternate: fbdev,nv,vesa resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: NV137 v: 4.3 Mesa 19.3.4 direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.4.22-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Dell 
  driver: ath9k v: kernel port: d000 bus ID: 04:00.0 chip ID: 168c:0032 
  IF: wlp4s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros Bluetooth USB Host Controller type: USB 
  driver: btusb bus ID: 2-13:7 chip ID: 0cf3:e004 serial: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Local Storage: total: 5.46 TiB used: 2.09 TiB (38.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC47 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A02 scheme: GPT 
  ID-3: /dev/sdg type: USB model: G-DRIVE mobile USB size: 3.64 TiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 2206 
  scheme: GPT 
  ID-1: / raw size: 931.21 GiB size: 915.60 GiB (98.32%) 
  used: 54.36 GiB (5.9%) fs: ext4 dev: /dev/dm-0 
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 29 C 
  Fan Speeds (RPM): N/A 
  Processes: 245 Uptime: 48m Memory: 15.59 GiB used: 2.38 GiB (15.3%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 
  running in: xfce4-terminal inxi: 3.0.37

Much better. :slight_smile:

  1. What are the contents of the files in /etc/systemd/system/plexmediaserver.service.d/?
  2. What is the reason you're you're not mounting G-Drive in fstab or systemd?
  3. What is the output of sudo find / -iname plexmediaserver.service -print 2>/dev/null
  4. Output of netstat --listen | grep 32400

No screenshots please? Use the same system as the inxi output to provide information...

  1. I could not find plexmediaserver.service.d in the system folder

  2. Mounting drives is on my to do list of things to learn. It's been working so far so I assumed I could hold off on it.

  1. bash: netstat: command not found
  1. OK, what is the content of $PLEX_HOME/Library/Application Support/Plex Media Server/ then?
  2. Put the mount in fstab first: if you reboot your computer even once without the media drive present, plex is going to give unpredictable results. We'll make it an automount later.
  3. What are the contents of /usr/lib/systemd/system/plexmediaserver.service ?
  4. My apologies: netstat has been deprecated, please give me the output to ss --listening | grep 32400

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by