Plymouth boot screen not showing after install

I've just installed the Plymouth boot screen on Manjaro 19.0.0 running kernel 5.5

I added splash to /etc/default/grub and ran sudo mkinitcpio -p linux55

But when booting there is no splash screen.

I get this in journalctl:

Feb 21 13:39:46 systemd[1]: Started Show Plymouth Boot Screen.
Feb 21 13:39:46 systemd[1]: Received SIGRTMIN+20 from PID 408 (plymouthd).
Feb 21 13:39:46 systemd[1]: Starting Show Plymouth Boot Screen...

And alot more messages, all successfull.

The theme in /etc/plymouth/plymouthd.conf is: manjaro-logo
which is installed.

Rest of config file is:
ShowDelay=0
DeviceTimeout=8

Have I missed something?

see this
https://wiki.archlinux.org/index.php/Plymouth

you have also have to
add plymouth in HOOKS in /etc/mkinitcpio.conf
and rebuild img kernels & modules

I added both HOOKS="base udev plymouth..."

and

MODULES="nvidia"

to /etc/mkinitcpio.conf

and added

quiet splash loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0 ...

to /etc/default/grub

and ran mkinitcpio -p linux55

But still I only get the normal text boot screen.

[edit]

If I try to run plymouthd && plymouth --show-splash in a text login, it shows the gnome login screen and crashes my system.

Leave only quiet splash, no loglevel, logpriority and cursor related stuff is needed. Then do sudo update-grub and reboot.

Running update-grub did remove the text boot screen.
Now I have my normal BIOS boot screen,
but changing the Plymouth theme and running
mkinitcpio doesn't change anything.

you should install
plymouth-git from aur

I am running plymouth-git from AUR.

I just tested plymouthd && plymouth --show-splash while logged in via text console 2 and having stopped gdm.service.

This produces the correct splash screen on text console 1,
but not when booting.

check your plymouth theme
and change it to bgrt
then see if that shows

I don't know what you mean by checking my theme?

The themes are freshly installed from pacman and I change with
sudo plymouth-set-default-theme -R bgrt

No matter which theme I select the boot screen is my BIOS background image without any kind of animations.

[edit] but the change is present when I run plymouthd && plymouth --show-splash from text console

install grub-vanilla

I'm not really comfortable replacing my boot loader.

Whats the difference between grub and grub-vanilla?

I've installed Manjaro in a VM and installed plymouth-git and grub-vanilla and did all the config files.

There still is no splash screen when booting up.
However when I shutdown/reboot the running system I get the splash screen.

Correct. Just install grub-vanilla without changing /etc/default/grub won't do.
Comment out GRUB_TIMEOUT_STYLE= and do update-grub.

As for your plymouth, I won't get further into it, but if you had boot-splash before, you will need to uninstall and disable bootsplash-systemd and at HOOKS line in /etc/mkinitcpio.conf, there is no bootsplash. Then only plymouth will work (assuming plymouth is set up properly at HOOKS and at grub). Reminder - I won't go more into plymouth or boot splash.

I wasn't aware of bootsplash-systemd

I've installed this instead of plymouth and now have a working boot-splash screen.

1 Like

i guess you have a laptop with hybrid gpu
intel+nvidia
if you had added i915
as module the plymouth would have shown

I have only this: MODULES=(crc32c_intel), but plymouth animation works nevertheless.
It's not the first time I see someone having trouble getting plymouth to work and I still don't get it what is the reason for that. However, I have a custom i915.conf in /etc/modprobe.d:

options i915 enable_fbc=1
options i915 enable_guc=2
options i915 fastboot=1

Maybe that is it, or at least a thing that makes i915 be included anyway?

It's a workstation PC with nvidia GPU.

I did try to add nvidia to MODULES but it didn't change anything.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by