Plymouth issues

Thanks for the detailed reply.
I'm in a worse situation now.
Thought it was resolved after uninstalling then reinstalling Plymouth, but the same problem reoccurred (kicking me out to a spinning circle on a black background).

What I then did:
sudo pacman -R plymouth
sudo systemctl list-units --type=service
sudo systemctl disable plymouth-start.service
sudo systemctl disable lightdm-plymouth.service
sudo systemctl enable lightdm.service
sudo pacman -Syyu
sudo update-grub

What I didn't do:
1. Remove plymouth hook from /etc/mkinitcpio.conf (For disk encryption users should plymouth-encrypt to encrypt)
2. Regenerate the initramfs for your kernel with sudo mkinitcpio -p linux
3. Remove the word splash & quiet from the Grub command line options via editing /etc/default/grub

Mainly because I don't know how to edit conf files from a command line without a GUI, so I thought I'd just try without and if it doesn't work I'll then do that.

Now when I reboot I can't get into any command line at all.
I get grub - hit enter to boot.
I get to a black screen with Manjaro in the bottom right corner then no progress.
Any key combination of ctrls alts and F keys only gets me to a screen showing
boot stuck
I have no idea what to do from here now, as I can't get into a terminal.
Any advice?
Thanks.

Edit 1:
Booted into live usb and removed the word plymouth from mkinitcpio.conf
No change, boot still fails.

Edit 2:
I temp edited grub at boot and removed the words quiet and splash and it booted successfully.
I noticed when it booted a message flashed by about running early hook Plymouth, so I still have some work to do somewhere.

Edit 3:
ran command
sudo mkinitcpio -p linux
result was

/usr/bin/mkinitcpio: line 265: /etc/mkinitcpio.d/linux.preset: No such file or directory
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux.preset'

removed words quiet and splash from etc/default/grub

ran command
sudo update-grub

Success!
Booting now works and straight onto desktop :grinning:
Still gives a message at start
Running early hooks [Plymouth]
So I should try and eliminate that somehow.

Edit 4:

Ran
sudo mkinitcpio -p linux54

Returned

==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.39-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
cannot open file ko
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.39-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
cannot open file ko
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
==> Image generation successful

Ran
sudo update-grub

Success!
Boots straight into desktop and gives zero messages about Plymouth when booting :grinning: :grin:

Prior to removal of Plymouth, had you installed the 11 may 2020 updates at all? From your post above, you appeared to have done so already and were suffering the Plymouth issue as a result.

I did say you had to remove the hooks and rebuild initramfs before the next update . But you went ahead with

sudo pacman -Syyu

Before sorting out the hooks and initramfs.

Does that mean you had not actually updated prior to trying to remove Plymouth?

Did your syyu command install any kernel updates at all?

In my post and the link I provided , not gebri's , removal of Plymouth comes last. I sorted out the hooks and the dm service , etc , made sure I could reboot into graphical session, before removing Plymouth .

After you edit mkinitcpio.conf, you have to regenerate initramfs.

Depending on what your kernels are, the command is

sudo mkinitcpio -p linux419

You have to append the number of your kernels after "linux"

Based on the update to your post, you'll need to sort out the hooks portion in due course.

1 Like

I updated everything before removing Plymouth.
Usually I have a quick look at the release msg posted on here to see if there are any huge issues, and leave the update a few days if so.
I probably didn't check very carefully this time.
Also the known issues section on Plymouth is a bit scant.
It basically says to just remove Plymouth, without all the other associated steps.

If for some reason you updated already and now have issues, login to a TTY and disable Plymouth:
Ctrl + Alt + F3 and login
sudo pacman -R plymouth
you may want to check if the wanted display manager still works and enable its service if needed.

I'll edit that once I get this sorted properly.

At least you got it sorted.

My first research reference was the arch wiki for Plymouth (and enabling/disabling services). The order of the steps I take follow that.

But of course, their usual kernels are named just linux and linux-lts.

So the mkinitcpio command has different kernel nomenclature for manjaro.

We are working to update plymouth for systemd 245 series so a removal is not needed. Stay tuned.

Here is the solution.
Huge thanks to Wongs for the assistance and helping me reach the solution.

DO NOT update before resolving issues with Plymouth FIRST

If however you have updated and are now struggling to boot into a GUI desktop, login to a TTY (ctrl-F2) and follow these steps:

  1. Remove plymouth hook from
    /etc/mkinitcpio.conf
    (For disk encryption users should plymouth-encrypt to encrypt)
    -delete the word Plymouth from the 'hook' section of that config file
    -use a command line interface text editor or boot a live USB and edit the conf file that way

  2. Regenerate the initramfs for your kernel with
    sudo mkinitcpio -p linux<version>
    Example:
    sudo mkinitcpio -p linux54
    The number comes from the kernel you are running, in my case 5.4.39-1

  3. Remove the word splash & quiet from the Grub command line options via editing
    /etc/default/grub
    -use a command line interface text editor or boot a live USB and edit the conf file that way

  4. Update Grub config file with
    sudo update-grub

  5. Disable any Plymouth related services
    sudo systemctl disable plymouth-start.service
    sudo systemctl disable lightdm-plymouth.service

  6. Enable lightdm related service
    sudo systemctl enable lightdm.service

  7. Uninstall Plymouth
    sudo pacman -R plymouth
    -if there is a dependent Plymouth theme that blocks Plymouth uninstallation then uninstall the theme too

  8. Restart PC
    sudo reboot

5 Likes

This saved my day. Thank you!

1 Like

On points 5 and 6. I think I am using sddm because I am using kde. How can I find out and what are the corresponding commands?

for sddm

  • Disable any Plymouth related services
    sudo systemctl disable plymouth-start.service
    sudo systemctl disable sddm-plymouth.service
  • Enable sddm related service
    sudo systemctl enable sddm.service
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by