Polkit.. is it just me ...

I recently installed the awesome community edition of manjaro (18.0) and found that the polkit isn't functioning. I am not sure if it just me, but I found that mate-polkit was installed and not running???

For those who want to have polkit I suggest removing mate-polkit and installing polkit-gnome and adding the following line to your .xinitrc

# awesome is kept as default

# PolKit
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

Of course, if you know of a better way of implementing polkit let me and others know!


@Thanos_Apostolou is mate polkit added to the autostart file? Does this if clause actually run? It looks weird

if (command -v /usr/lib/mate-polkit/polkit-mate-authentication-agent-1 && ! pgrep polkit-mate-aut) ; then
    /usr/lib/mate-polkit/polkit-mate-authentication-agent-1 &


Yeah this clause does work (although the command -v probably is not needed). However I've noticed that sometimes the autorun script doesn't work after the 1st boot after installation.

@damasu have you tried rebooting at least once after you installed manjaro awesome edition and see if polkit is running properly?

I placed it in my autostart config now.


Well i tried after rebooting several times. The package for polkit-mate wasn't installed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by