polybar accendently removed in manjaro openbox

I remember playing around with the systemctl command when the polybar dissapeard.
Now i cant get to to appear again correctly.
If I enter the command from the ~/.config/ob-autostart/config file
"polybar -c ~/.config/polybar/config openbox-bar 1 *"
I get the Output unrecognized argument "1". So when I removed the 1 and the * from the command the polybar appeared.
But now the WIN key does not work which opens the menu when you click on the manjaro logo in the upper left corner.
Beside from that everything works normal. I can use shortcuts and the Programms are working fine also the usage for the CPU and RAM gets updated.

When I edit the ~/.config/ob-autostart/config file and edit the line for the polybar from
("polybar","polybar -c ~./config/polybar/config openbox-bar","1","*") to
("polybar","polybar -c ~./config/polybar/config openbox-bar")
the polybar still does not show up after reboot.

Thank you for Help.

Well - tagging your issue with xfce is not helpful :slight_smile: maybe you should have tagged it with openbox.

Well - if you have the openbox config package installed you can find the original files in /etc/skel/.config/openbox

The current default autostart for openbox is

### use arandr to set screen preference
### save as ~/.screenlayout/dual-head.sh
### and uncomment next line
### ------------------------------------
### alt. use the xfce monitor setup from system settings control panel
#~/.screenlayout/dual-head.sh

### Required for xfce settings to work
sleep 0.5; xfsettingsd &

### compositor
sleep 1; manjaro-compositor --start &

### launch thunar in daemon mode for faster startup
### comment if you would rather use pcmanfm
#thunar --daemon &

### use desktop icons and pcmanfm as wallpaper manager
### uncomment next line and comment nitrogen below
#pcmanfm --desktop &

### no desktop icons use nitrogen as wallpaper manager
### uncomment next line and comment pcmanfm above
sleep 1; nitrogen --restore &

sleep 1; polybar -c ~/.config/polybar/config openbox-bar &
sleep 1; manjaro-tint2-session &

### launch conky
manjaro-conky-session &

### volumeicon
sleep 1; volumeicon &

## skippy windowswitcher
skippy-xd --config ~/.config/skippy-xd/skippy-xd.rc --start-daemon &

## super key for menu
xcape -e 'Super_L=Alt_L|F1' &

### PolicyKit authentication
/usr/bin/lxpolkit &

### Localize user system folders
xdg-user-dirs-gtk-update &

### enable numlock
### uncomment next line
#numlockx &

Thank you linux-aarhus,

I added "sleep 1; polybar -c ~/.config/polybar/config openbox-bar &" to my "~/.config/openbox/autostart" and removed the line about polybar in my "~/.config/ob-autostart/config" file because I do not need to launch it twice.

The polybar shows now up after reboot and works (Thank you!).

But the WIN key still does not work. I can click on the Logo and the Menu does show up. So is that a Programm wich gets launched or do I have to configure polybar somehow?

Thank you for your quick response!

I think you are looking for this

Thanks alot for your Help!!

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by