Pop shell testing

I'm planning to add pop-shell at some point to Manjaro gnome edition. It looks very promising. However, it isn't quite stable yet, and the git repo gets updates daily. Developers react to issues very quickly and they have people working full time on this. I'm using the extension daily and try to decide when it is mature enough to package for Manjaro.
Does anybody want to help with this?

The extension can be found in AUR (gnome-shell-extension-pop-shell-git) and the git repo is here:


Wayland or X? In wayland it kills my theme, the default theme is shown instead.

I've been wanting to try this extension for a while now, thanks for providing an excuse to do so. :nerd_face:

On X, everything appears to work great.

My experinece on Wayland, however, was even worse than @xircon described: it locked up my system completely, I had to REISUB to restart.

The extension doesn't always do things exactly the way I would want, but I haven't seen anything in it I would call a bug. The usefulness of tiled windows on my tiny 13" laptop monitor is limited, but I'll keep it installed for those occasions when side-by-side (or above-and-below) windows are useful. The ability to turn tiling on/off quickly from a panel icon is a handy feature. I notice there's something called "pop-shell-shortcuts" providing more keyboard shortcuts; perhaps it should be considered too; I haven't tried it yet. I've heard that System76 is improving the extension quickly; I would vote "thumbs up" to include it in future Manjaro releases.

On my end the system hangs if i use wayland and pop_shell. On Xorg i can make use of it quite nice with all the 6 Layouts provided by Manjaro. A note is that accessing the settings fro DTD or DTP by right click on them is not opening the particular extension settings window, but that is unrelated to Pop_Shell ...

You can count me in as crash test dummy as i also use it daily. So far it seems to work pretty well on X at least with the default Adwaita dark theme . I'm not a big wayland user so can't say much about that.

How is it possible people are saying Gnome is locked! Long life for i3! :slight_smile:

Who is saying, "Gnome is locked"? What does that mean?

That you can not change it as other DE

I have also wanted to try this extension for a while. Can report that it works well under X; on my Surface Pro 4 it makes the entire system hang when running under Wayland.

I've updated it and re-enabled the extension since it has been officially released on Pop!_OS 20.04. When I try to view all shortcuts, it says I need to install pop-shell-shortcuts. I can't find this on AUR. Does anybody have a workaround?

It needs to be packaged. I'll get around to it.

Looking at the PKGBUILD, it looks like the maintainer has skipped running the rebuild.sh script which modifies the GNOME keyboard shortcuts to align with Pop!_OS shortcuts. I find the Pop!_OS keyboard shortcuts convenient to use with the tiling extension, but I haven't changed mine yet. Have you modified your keyboard shortcuts?

I had, but stopped doing it because I run rebuild.sh daily and it resets the keybindings. I'm not sure if the pop os way of doing the keybindings is the best.

I packaged the keybinding thingy in unstable now. It might need to be modified to reflect the actual bindings.

I'm thinking about setting the keybindings with a toggle in gnome-layout-switcher, and unsetting them when the extension is disabled.

A switcher would be fantastic if possible - there is a lot of muscle memory for the current keybindings that I would be a bit afraid to loose

Thanks, the package works great.

I now uploaded also the package itself.

According to the github issue tracker, Wayland support is planned for the next release. I'll probably wait until then before adding this to gnome-layout-switcher.

I feel that the xorg side is now quite usable.

1 Like

Which repo, unstable?

The extension maintainer also added the dependency on AUR which makes it easy to install. I had to manually download the package you added to the Manjaro unstable repo which means it will not be automatically updated because I'm not on that branch.


Sorry for the super-noob question, but how do you enable it after you've installed it?

Forum kindly sponsored by