Power Saving Issue - Monitor not switching off

Currently in my settings I have my monitor set to switch off after 15 minutes of inactivity. After 15 minutes it appears to work, monitor goes blank for about a few seconds but then it comes back on and this repeats. Ive tried unplugging my mouse & keyboard thinking maybe they are waking it back up but that had no effect. I've done an online search and most of what turned up was resuming issues i.e. monitor stays off. I've also tried changing the times but no luck still the same. I've also tried the force off command and it does go blank for a few seconds but again monitor will come back on. This has been going on for months now. I was hoping an update would have fixed it but no luck there either. Any help is appreciated. Thanks.

System:    Host: sammy-ms7c02 Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0 serial: <root required> 
           UEFI: American Megatrends v: 3.60 date: 04/22/2020 
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86424 
           Speed: 4125 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 4125 2: 2062 3: 2200 4: 2200 5: 2062 6: 2200 7: 2200 
           8: 2200 9: 4125 10: 2062 11: 2062 12: 2201 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
           vendor: Sapphire Limited driver: amdgpu v: kernel bus ID: 28:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting,radeon tty: N/A 
           OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.36.0 5.6.19-2-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.1.3 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 28:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 2a:00.4 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 22:00.0 
           IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: 00:d8:61:ab:62:4f 
Drives:    Local Storage: total: 3.66 TiB used: 345.18 GiB (9.2%) 
           ID-1: /dev/nvme0n1 model: Sabrent size: 953.87 GiB 
           ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
           ID-3: /dev/sdb type: USB vendor: Western Digital model: WD My Passport 0820 size: 931.48 GiB 
Partition: ID-1: / size: 937.60 GiB used: 345.18 GiB (36.8%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 54 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 305 Uptime: 2h 12m Memory: 15.65 GiB used: 3.81 GiB (24.3%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 inxi: 3.0.37

That kernel is EOL. Switch to 5.7 and see if the issue you mention is still present.

Thanks. So I switched to 5.7. Unfortunately the screen will black out for about 10 seconds and come back on. It will continue doing that indefinitely.

Can you please try this and report back if the issue persists?
https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling

Ok. I'm kinda new to linux so please pardon my ignorance on things. I went to the site and did the first part and created a file:

Section "Monitor"
    Identifier "LVDS0"
    Option "DPMS" "true"
EndSection

Section "ServerFlags"
    Option "StandbyTime" "2"
    Option "SuspendTime" "4"
    Option "OffTime" "8"
    Option "BlankTime" "0"
EndSection

Section "ServerLayout"
    Identifier "ServerLayout0"
EndSection

This actually works on the log on screen. About 2 minutes it appears the monitor switches off. I also did a version where just the off time was set to 1 and all others 0 and the monitor switched off after 1 minute. But only on the logon screen.

When I log in the Plasma Power settings appear to take over as It will only try to turn off monitor based on those settings you set through GUI. I set it to 1 minute and it turns off but after 10 seconds monitor comes back on. I also tried quitting psensor because that is the only program I have enabled to run at startup but still same issue. I also tried logging under GNOME but that has the Power Management Disabled and it ignores the settings I put in the file above. However I was able to do the xset dpms force off while logged under GNOME and it did force the monitor off and it stayed off until I woke it up. Unfortunately this same command while logged under PLASMA did momentarily black out the monitor for a few seconds but it came right back on basically same issue as when the power management tries to turn monitor off. Below is the output from xset q:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  600    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/misc,/usr/share/fonts/TTF,built-ins
DPMS (Energy Star):
  Standby: 60    Suspend: 90    Off: 120
  DPMS is Enabled
  Monitor is On

Forum kindly sponsored by