Poweroff doesn't work after install

I've been trying for several days to install Manjaro (and before Ubuntu) on my MSI WS72 portable workstation. Everything seems to go smoothly and OK until we get to switching off the system. It always gets stuck there: the Manjaro desktop screen freezes and the only way to turn it off is by pressing the power button for 8 secs.

I've been going through some other similar topics in this forum and other Internet sources, but after hours of tests and different variations on the installation, I always get to the same.

Some system info:
$ inxi gives: CPU: Quad Core Intel Core i7-6700HQ (-MT MCP-) speed/min/max: 800/800/3500 MHz Kernel: 4.19.13-1-MANJARO x86_64 Up: 5m Mem: 910.2/15913.4 MiB (5.7%) Storage: 1.38 TiB (0.5% used) Procs: 205 Shell: bash 4.4.23 inxi: 3.0.28

THE POSITIVE CLUE :wink:

  1. It always works perfectly well from a Manjaro live session booted from the USB memory. It shuts down properly and all the issues reported following don't happen.

THE NEGATIVE CLUES :wink:

  1. inxi -F freezes the terminal!!! and I have to get the cursor back with ctrl-Z

  2. Also if I run the hardware configuration application, the window freezes before any contents are displayed in it, and when I try to force the window to close it says "kcmshell5" doesn't respond.

  3. I tried adding "force acpi" in certain line of the grub, but after editing the grub file as told on the post, the system freezes when I do the grub update.

  4. I've installed Manjaro in the three available "BIOS" modes: Legacy, UEFI and UEFI-with-CMS and I get the same problems from the installed version (not at the USB live session).

  5. Regarding the NVIDIA graphic device and drivers, I can't change to "non-free" or do anything about this at the hw configuration application because it crashes as I explained. When running the USB live session, in legacy mode if I switch to driver=non_free at the welcome screen, the boot process gets stuck almost at the end of all those boot [OK] lines, but in UEFI mode the non free drivers can be chosen and the live session works well and turns off properly, but after installing it doesn't power off again.

  6. If I create a test user, I get the same problem.


Any idea on what to do ??
Thanks in advance to you all for the work and support in this Manjaro community.

Have you tried to close Firefox first before you poweroff your system? Does the same thing if you reboot?

Can you try switching to a different kernel to see if it improves your situation. Use the Manjaro Settings to install kernel 4.18 or 4.14 LTS and then at grub switch to the different kernels and do some testing.

I think this is probably a key symptom.

It sounds like you have an Optimus laptop so that's also worth reading up about.

Days: close Firefox first before you poweroff your system?

I mostly close all applications before shutting the system down. I had also checked with reboot and "sudo shutdown -h now" from the command line and it always freezes.

Anika200: Can you try switching to a different kernel...

I'm afraid I'm a bit stuck here... I tried to install 4.14 LTS, I'm asked for the password... and in a blink it says "done". But there is no green "Installed" tag and button still shows "Install" instead of "remove". I force the system off, and nothing different happens when I reboot again. Inxi says 4.19, so no kernel changes.
The 4.20 version says "Installed" with the green label, but there is no grub screen when I powerup. How can I have the grub selection screen at powerup?

Indeed it's a nice and powerful laptop, Jonathan. But it's quite annoying not being able to have working properly... I've done a lot of reading and tests. I guess we'll come to a solution somehow...

I forgot the new iso probably uses "silent boot", which I have never used or seen in action but you can find some info to get to grub.
I think you can hit Esc, Shift or F8 at boot.

You may have uninterruptible processes running which can prevent shutting down properly.

You can get a list of all running uninterruptible processes with these commands.

ps -eo 'state,pid,args' | awk '$1 == "D" {print;}'
ps -eo 'state,pid,args' | grep -E '^D'
ps -eo 'state,pid,args' | egrep '^D'

The most likely suspect is however your video drivers.

You may also want to run:

dmesg | grep -i oops

Post any output.

Could you please post:

inxi -Fxxxz

This. The symptoms you are describing are common to issues with video driver issues on hybrid/optimus laptops.

yes, optimus
im familiar with this problem first hand and from helping others. you installed with free drivers because nonfree wouldnt load properly, everything boots fine but any call to the gpu locks everything up (inxi -F will do it, mhwd will do it also. any and all calls to gpu will lock it up).
@SantiMoronho
you have a few options to fix this.

  • easiest being disabling the intel gpu from bios and then install using the proprietary nvidia drivers.
    this option isnt available for all models.

  • you can edit /etc/default/grub and add a kernel parameter,
    sudo nano /etc/default/grub
    modify the following line to look like this exactly, no room for mistake. copy/paste is your friend.

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=\"!Windows 2015\""
then
ctrl+x , then "y" for yes, then enter to save
sudo update-grub
reboot
and instead of logging in to the desktop use ctrl+alt+F1-6 to get a tty terminal.
login with your user/pw
sudo mhwd -R pci video-linux
sudo mhwd -a pci nonfree 0300
(this is to install the intel/nvidia bumblebee drivers.)
reboot and you should be good.

here are some links for PRIME intel/nvidia and Optimus-Manager tutorials that explain how to set up each , the difference and how they work.

decide how you want to move forward and i'd be glad to help.

you can also just do the same thing from the installer by choosing "nonfree" and hitting " e " and adding that kernel parameter to the linux boot line. you will know if it works if it lets you boot to the live desktop. you can also try just acpi_osi=! instead or acpi_osi=! acpi_osi="Windows 2015" try and see which one works .

1 Like

Wuauuuuu dglt, this sounds great!!!

Let me go through it carefully, and lest see what happens. Thanks!!

1 Like

hope it works out, if you need help just drop a @dglt and i'll see what i can do.

Hi again and sorry for all these days with no time to work on this...

I'm afraid dglt, I havn't solved the problem yet. I first tried edditing the grub file and the system freezes after running sudo mhwd -R pci video-linux... I'll try again and report the details (I tried a few days ago, and I think there were some other difficulties on the way).

Now I've tried the installer with "nonfree" driver selection, and again it freezes on the start-up process.
IMG_20190126_003024 !

And this is where it gets stuck.
IMG_20190126_003214

ok, without any real system information it seems a lot like optimus related problems. first and easiest thing you can do is check if you have an option in bios to disable one of the gpu's (not many systems have this option). the other is using kernel parameters which is what i also have to do to boot without issues. to boot with nonfree drivers it can be as simple as adding acpi_osi=! but in the right place.

2 posts back, that image you posted of the grub boot options, you put the parameters in the wrong place. see at the end of the second line the word "quiet" ("quie" because the word is continued on the next line)? erase the word quiet and replace it with:
acpi_osi=! then hit CTRL+X to boot. dont forget to leave a space before and after each parameter.

dont bother with the windows 2015 parameter yet as you might not need it and it has an unforgiving syntax that must be perfect. if acpi_osi=! doesnt do it then go ahead and try both:
acpi_osi=! acpi_osi="Windows 2015"

1 Like

Hi OP,
One of the HP mobile workstations I used has Nvidia Quadro GPU, and it had the same issues as yours: it couldn't power off or reboot properly and froze upon said command lines. The issue had always been the mess with GPU drivers and such.
I am not entirely familiar with the MSI product line, but I'd assume your workstation uses Nvidia Quadro GPU, and it should run with Optimus. Thus you can have a close look at this thread Manjaro freezes mhwd command
This week I did a fresh install on the HP workstation and an MSI GE62 gaming laptop, both with Optimus running. With reference to the above thread, the systems on both worked like charm, so I'd recommend you do a fresh install with the latest stable release.

Hi DJDingo! My MSI WS72 does have and Nvidia Quadro GPU (at least it has a sticker that says so). The Manjaro release is Manjaro 18.0 (Illyria 18.0.2). I think it's the Kde-Plasma edition, and Kernel is 4.19.13-1-MANJARO x86_64 (as inxi repots). I downloaded the USB install package a couple of weeks ago, so I guess I'm already using the latest stable release.

Indeed I'll go through the "Manjaro freezes mhwd command" thread you suggest.

And hi dglp, I'm afraid the acpi_osi=! acpi_osi="Windows 2015" parameters placed instead of the quiet parameter, don't make the install live session run with the "nonfree" drivers. The start-up process freezes at the same point.

I tried first only with acpi_osi=! and after with both acpi_osi parameters with the same result.

This is the last screen
IMG_20190127_133809

And about disabling the GPU at the bios, I can't find any option like that.

Following is a capture of almost all the bios screens, including the system information's.

I wonder if the "Boot mode select" has something to do with this. All these last tests with the start-up parameters were done with the UEFI mode. Before I did some tries with the Legacy and UEFI with CSM modes... I guess for all these settings and tests to get the Optimus system working, the right boot mode is UEFI, isn't it?

Bios

Forum kindly sponsored by