Pre-boot/bios manufacturer splash screen showing after OS user login

My pre-boot/bios manufacturer splash screen appears after the user login screen. It sticks around for maybe a few seconds or so, then the desktop appears as it should. I'm running Gnome. Anyone have an idea of how to stop it appearing?

1 Like

Turn it off in BIOS.

No option to do so.

When I was just checking the BIOS menu, I made note of the instances it displays:

*Manufacturer splash (as usual/expected)
Boot loader menu
Drive decryption
*Manufacturer splash
Manjaro login screen
*Manufacturer splash
Desktop

It also displays after I select to shutdown the system.

I never had this happen on any other OS, Linux or otherwise. Any ideas?

Please post the output of :roll_eyes:
inxi -Fxxxza --no-host
Be sure to use 3 ``` before and after the pasted content so it's easier to read. Or you can highlight the test and click the </> button. Thanks!

Here it is:

System:
  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 
  root=UUID=fe7bed61-f826-4d2b-ad09-5bbaaf1598c5 rw quiet 
  cryptdevice=UUID=f2edf70b-bd30-4d1f-a746-b4c474e810ef:luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef 
  root=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef 
  resume=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef apparmor=1 
  security=apparmor udev.log_priority=3 pci=nommconf 
  Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM 3.32.0 Distro: Manjaro Linux 
Machine:
  Type: Convertible System: Acer product: Spin SP513-52N v: V1.15 
  serial: <filter> 
  Mobo: KBL model: Woody_KL v: V1.15 serial: <filter> UEFI: Insyde v: 1.15 
  date: 04/18/2019 
Battery:
  ID-1: BAT0 charge: 35.1 Wh condition: 40.4/54.2 Wh (74%) volts: 12.5/11.6 
  model: PANASONIC AP15O5L type: Li-ion serial: <filter> status: Discharging 
  Device-1: hid-0003:04F3:2560.0001-battery model: ELAN Touchscreen 
  serial: N/A charge: N/A status: N/A 
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: B4 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 400 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 400 2: 400 
  3: 400 4: 400 5: 400 6: 400 7: 400 8: 400 
  Vulnerabilities: Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Display: x11 server: X.org 1.20.5 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3040 bus ID: 01:00.0 
  chip ID: 168c:003e 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 43.96 GiB (18.4%) 
  ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: A020 scheme: GPT 
Partition:
  ID-1: / raw size: 64.00 GiB size: 62.50 GiB (97.65%) 
  used: 43.91 GiB (70.3%) fs: ext4 dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 44.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 268 Uptime: 21m Memory: 7.70 GiB used: 2.30 GiB (29.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: gnome-terminal inxi: 3.0.36

Hope you can find something in there! Such a bizarre little quirk

1 Like

I don't see anything in your inxi that would give me an indication of an improperly setup kernel params. Not an expert in that however.

I'm not surprised that there is no option. They rip out so much from Laptops for BIOS options. Kind of sucks.

Not a solution and it might happen to quickly but when that screen comes up, can you hit Esc ? Does it go away?

You might also want to post your grub:
cat /etc/default/grub

Perhaps something tweaked the grub config? :woman_shrugging:

slightly teeny tiny bit OT

Took a bit to get back to this thread. I updating ( On testing branch ) and had an.. ahem... issue. :wink:

Here's my grub:

GRUB_DEFAULT="Manjaro Linux"
GRUB_TIMEOUT="0"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=f2edf70b-bd30-4d1f-a746-b4c474e810ef:luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef root=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef resume=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef apparmor=1 security=apparmor udev.log_priority=3 pci=nommconf"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT="false"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK="y"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT="console"

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE="auto"

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX="keep"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
GRUB_ENABLE_CRYPTODISK="y"

GRUB_HIDDEN_TIMEOUT="0"
GRUB_DISABLE_OS_PROBER="true"

I'm using rEFInd boot manager, hence the measures here to hide Grub. Do you think it could be related? In my limited knowledge, it doesn't seem that it would be related (since it's already booted into the OS), but maybe it does to someone wiser on this stuff.

Thanks in advance!

I assume it's just for aesthetic reasons you want it gone? Because I seriously doubt it is delaying your DE loading, it is most certainly loading in the background.

Yeah, mainly for aesthetics. The DE load time is fine. But, ideally, I want it running as it should.. not half-baked or with random oddities. So, I'd rather take care of it, if possible, and avoid potential issues/conflicts.

Then grub and /etc/default/grub has nothing to do with it.
And you should have said so much earlier. :confounded:
What's refind_linux.conf?
If you've modified refind.conf (not refind_linux.conf), tell us what's modified.

If you want to check if the grub you've done in your OS (but not operational) would have these splash screen or not, from an external grub (like our install media boot menu), configfile to your OS grub and boot up (and make sure you've done 'update-grub' !!)

grub> set root=(hdx,y)
grub> configfile /boot/grub/grub.cfg

If the splash screen still appears, it may be your bios setup as was mentioned earlier.
ps: But I think (not certain) that may help.

systemctl status plymouth-quit
systemctl status bootsplash-hide-when-booted
cat /proc/cmdline

Thanks for the input, but couldn't do anything with it...

$ systemctl status plymouth-quit
Unit plymouth-quit.service could not be found.

Also tried with sudo before, but same same.

Should I try installing plymouth?

You should've posted the output of each command to ease our remote diagnosis.

$ systemctl status plymouth-quit
Unit plymouth-quit.service could not be found.

$ systemctl status bootsplash-hide-when-booted
Unit bootsplash-hide-when-booted.service could not be found.

$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=fe7bed61-f826-4d2b-ad09-5bbaaf1598c5 rw quiet cryptdevice=UUID=f2edf70b-bd30-4d1f-a746-b4c474e810ef:luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef root=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef resume=/dev/mapper/luks-f2edf70b-bd30-4d1f-a746-b4c474e810ef apparmor=1 security=apparmor udev.log_priority=3 pci=nommconf

Try removing quiet from your boot options and see how it change the situation. I mean edit grub options in the beginning of the boot (e key to start editing, Ctrl+X to boot).
But in fact it is more related to Gnome session parameters as far as I can tell.

Confirm that you are using rEFInd and not grub to boot?
If using rEFInd, confirm it is not bring up the grub menu before booting? If it is brings up grub menu, confirm this as well.

1 Like

Oh sorry I forgot that you are using rEFInd, I haven't re-read the whole thread.
This makes everything easier, edit your cmdline with TAB key and boot with Enter to see if there's some effect. I guess there won't be logo after gdm anymore but some kind of empty screen. That also would prove there's something wrong with starting of Gnome session.

What is strange is that your /proc/cmdline starts with BOOT_IMAGE=, which is peculiar to Grub, not to rEFInd, but whatever. Maybe you use rEFInd but then start Manjaro with picking Grub, it is possible and seems to be true. So you need to select Manjaro in rEFInd menu and press Enter, and immediately press "Arrow Up" several times for Grub menu to appear. Then edit it.

Cheers, lord! That's all it was. Removed quiet, updated grub, restart and done! Appreciate your time/help :slight_smile:

One more related question... Now that it isn't being hidden with the bootsplash, do you have an idea if there is another way to hide the all that loading text that comes up in between boot menu and login screen? Can I change it to a blank screen, cover it with a plain black background image, or change the text colour to black?

This is not a solution, just a temporary workaround. I suppose you need to add quiet back, but disable some Gnome extensions some of which is likely to be the culprit. How it was, I mean did it happen in case when you logged out and log in without reboot? If so, then you can disable extensions one by one and quickly check to find the faulty one.
Or you can install plymouth-git from AUR in accordance with Arch wiki instructions. It will require plymouth hook in /etc/mkinitcpio.conf andquiet splash boot parameters.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by