Printing not working [and] Can't install new printer either after yesterday's update

Manjaro 18.0.4
Gnome 3.32.2
hplip 3.19.8
cups 2.3.0-3

My previously-installed HP printer, which I had been able to use without issue wouldn't work this morning. I deleted the printer with the intention of re-installing it, but re-installing won't complete.

When I try to re-install via Print Settings, upon clicking Apply on the New Printer/Describe Printer screen, I get There was an error during the CUPS operation: 'server-error-internal-error'

When I try to re-install via HP Device Manager, upon clicking Add Printer on the Setup Device screen, I get Printer queue setup failed. Error: successful-ok-ignored-or-substituted-attributes

sudo systemctl status org.cups.cupsd.service gives me ....

● org.cups.cupsd.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; enabled; vendor preset: disabled)
Active: active (running) since Fri 2019-09-06 10:36:18 EDT; 10min ago
Docs: man:cupsd(8)
Main PID: 597 (cupsd)
Status: "Scheduler is running..."
Tasks: 2 (limit: 4915)
Memory: 53.5M
CGroup: /system.slice/org.cups.cupsd.service
β”œβ”€ 597 /usr/bin/cupsd -l
└─2298 /usr/lib/cups/notifier/dbus dbus://

Sep 06 10:36:18 EVGA-O systemd[1]: Starting CUPS Scheduler...
Sep 06 10:36:18 EVGA-O systemd[1]: Started CUPS Scheduler.

While I've only had Manjaro installed for a couple of weeks or three, I initially had no issues with printing (and hadn't had issues printing for years with Linux distro I was using just before switching to Manjaro). I state this only to clearly say that this is a new issue for me.

I don't know what to check or what to try in order to resolve. Thoughts?

2 Likes

Hello there!

What printer do you have?

Hey. Thanks.

HP Officejet Pro 7740

(My other computer still has my previous Linux distro installed and it is printing without issue. I mention only to rule out an issue with the printer itself.)

That's weird, maybe try following this? https://unix.stackexchange.com/questions/359531/installing-hp-printer-driver-for-arch-linux

Ok. Thanks for your time. Still not working.

I tried the sudo hp-setup -i which resulted in the same error that the hplip gui gave me. error: Printer queue setup failed. Error : successful-ok-ignored-or-substituted-attributes

Also from that page/link, I tried in the browser localhost:631/admin. I end up with an error message saying, Unable to add printer. Unable to copy PPD file. So perhaps that's a little more information. I don't personally know what to do with it though.

Having the same issue on Manjaro KDE with HP Desktjet 2620.
Printing always worked until last stable update (2019-09-05).

I also tried to remove and re-add the printer in hplip, but getting this error there:
image

I'm in the lp and sys group and it worked in the past using hp-setup (from hplip). Problem seems new only with latest stable update.

1 Like

you could manually put the ppd of your printer in

/usr/share/ppd/HP

& install via add printer through ppd for now

same for you @Bleuzen

The ppd is already in this directory.
I also tried to copy it to another place (in my home dir for now) and select manually this file during printer setup. Same error.

:thinking: not sure what's going on there... sorry

(I made original post on this thread.)

At HOME, I just installed my HP OfficeJet Pro 8710.
Everything went as it always had. Installed just fine without issue or any out-of-the-ordinary action.

When I get back to the OFFICE, I'll try installing the HP OfficeJet Pro 7740 again and see if anything has changed. (Naturally, I'll post here what happens.)

(The only package that got updated after I gave up installing the HP at the office, and installing the printer today at home, was qt5ct went from .040-1 > 0.41-1, and I wouldn't expect that would have fixed anything since even Terminal-based printer installation at the office failed with same error mssg.)

(I went to /usr/share/ppd/HP just to check. hp-officejet_pro_7740_series.ppd.gz has the identical ownership and permissions as hp-officejet_pro_8710.ppd.gz.)

Have you tried re-installing cups & starting service afterwards? This has helped here

Thank you. ... Yes, I tried re-installing cups yesterday, as well as re-installing hplip. Nothing changed. (Yesterday I also downgraded hplip. Didn't help. So I went back to current hplip.)

I did NOT try re-installing cups-filters though, nor libcups.

I will try re-installing those 2 packages as well, however I'm going to wait until making another attempt with the OFFICE printer. If it still doesn't work, then I'll re-install those 2 packages and try again. I'll report back here.

Did you restart the service afterwards?

sudo service cups restart

You can try as well:

sudo systemctl enable org.cups.cupsd.service

&

sudo systemctl start org.cups.cupsd.service

Yes, yesterday after re-installing cups I did specifically ...

sudo systemctl restart org.cups.cupsd.service

... as well as ...

sudo systemctl status org.cups.cupsd.service

Sorry I didn't mention that. Still got same errors after trying again to install the printer at the OFFICE.

Have you checked this topic here?

Thank you. Well, I just read your link.

I DO belong to the lp group. I just checked. Additionally, I installed the printer at HOME without issue, also an HP, this morning. So, whatever that may mean. :slightly_smiling_face:

(I'm not sure if I'll make it to the OFFICE today to try that printer again to see if anything has changed. Clearly, that's a question now that I had success installing a different model at HOME today.)

At HOME, the HP OfficeJet Pro 8710 installed just fine.
Back at the OFFICE, the HP OfficeJet Pro 7740 still won't install.

Seems so weird. Never have had an issue before. And was working in Manjaro just fine a few days ago.

(Need to work on other things at the moment, but will have to turn my attention back to this eventually so I can print at the office.)

I wonder where the printer info is stored when a printer is installed. Wonder if I could go there and make sure and delete any previous remnants. (Just brainstorming.)

I realize this is a work-around instead of a fix, but for the moment so that I can print at the office this is what I did to get around the issue ......

I happen to have another laptop with another distribution of Linux on it at the office that has the printer in question installed on it.

1β€” I stopped cups from running. So, sudo systemctl stop org.cups.cupsd.service

2β€” I copied the appropriate printer .PPD file from /etc/cups/ppd/ (from the other laptop) and placed it into the same location on my main laptop.

3β€” I copied the <Printer ..... </Printer> node from inside the /etc/cups/printers.conf file (from the other laptop) and pasted it to the end of the same file on my main laptop.

4β€” I started cups back up. So, sudo systemctl start org.cups.cupsd.service

5β€” I opened the typical Gnome printer management windows and there the printer was. I tested printing and all worked fine.

This is unsatisfactory, clearly, since it doesn't fix the printer installation issue that's only happening with the HP printer model at the office (since the last update). Actually, it turned into an installation issueβ€”I couldn't even print to the already-installed printer (after the last update), so deleted the printer with the intention of re-installing it, but then couldn't re-install.

Maybe something will come to light in the future. For now, this is my "fix".

EDIT: With this work-around, I wasn't able to print double-sided. ... The "solution" of downgrading cups, libcups and cups-filters, detailed below, resolved installing and printing and printing double-sided.

I too is experiencing the same with my epson printer. I have deleted and re-installed everything for the printer. Still I am unable to get anything printed from within manjaro.
My Printer is networked connected. Tested with other devices and they can all printer ok.
My PC is setup to allow dual boot. I am able to print ok from the other linux distr, so the connection is ok. It is just failing to print from manjaro..
NB. the message in the printer queue Status is ' Filter Failed'. In cups printer status it's "Can't detect file type".. I have no idea how to proceed from here

I've had the same problem with an HP3700 series printer - stopped working after upgrade (CUPS 2.2.11 to 2.3.0). I solved it in my case by installing the downgrade script and reverting to CUPS 2.2.11. Printer installed and functioning as before.

Please note that if you do this to make sure you downgrade libcups then cups itself. Remember to lock the downgrades against automatic upgrades when the script asks you. This procedure uses the command line and might seem intimidating to those users without experience - don't worry it's all straightforward!

I'm sure that the more experienced members could find a better fix but I went for the most simple and obvious!

1 Like

Forum kindly sponsored by