Printing with HP Officejet

I've been trying to hook up an HP Officejet printer to my Pinebook Pro via USB without success.

Under Applications I apparently have CUPS web interface installed and I have installed the HP Device Manager from the repositories.

I keep getting the following message: "This site can't be reached."

Can anyone suggest what I could try?

Airprint,, there are 2-3 debian wiki pages
There are almost no arm filter drivers, all are x86
Bottom line, connect printer to network, if printer
is not network capable there is a git for ipp over usb
When picking ppd, generic, NOT generic-pdf
(unless it is pdf printer, it is not)
ppd will be 'drvless' or 'ippeve', either will work
If printer is more than 10 years old, it may not be airprint capable

1 Like

Please check if your printer is listed here.
Hp linux support

If its listed then install hp linux printer support application.

Run this command
sudo pacman -S hplip
After it is installed then run
This will take you to printer installation wizard.

If you need more help then please follow instructions from here

Hope this will solve your problem with your printer.

When I run the above I get the following error message: error: /usr/lib/python3.8/site-packages/PyQt5/ undefined symbol: _ZTI18QOp
enGLTimeMonitor, version Qt_5

Which version of hplip did you install?

For me, a newer version helped:

Well, hplip-minimal does have armv6h in the arch line,
so maybe it would work
If the printer is not 'old' and is connected to the network,
that is what airprint is for, thanks to apple and ipad/iphone
With cups it is not that hard to set up airprint, if preconditions are met
a little more detail
airprint was designed for ipad/iphone, these devices are seldom
connected to anything by usb, mostly network,,,
so if the printer is ONLY usb, probably not airprint capable
And, there are many, many models of printer called office-jet
Which model???? They vary quite a bit,,, not a mind-reader
The question is, Can I use this SPECIFIC MODEL to print from my ipad?

Sounds like you are on KDE Plasma edition.

You need to install python-es2-pyqt5then.

It's a relatively recent Officejet 7510. On Ubuntu I use my local wireless network to connect to it.

I installed HP Device Manager 1:3.20.2-1

I tried but got the following message:

sudo pacman -S python-es2-pyqt5
[sudo] password for quadrantids:
resolving dependencies...
looking for conflicting packages...
:: python-es2-pyqt5 and python-pyqt5 are in conflict. Remove python-pyqt5? [y/N]

So I aborted. Should I have continued?

The message "this site can't be reached" refers to the cups daemon not running.

In the Hp Device Manger run "Setup Device" and these are the settings I search for to find my wifi connected HP Officejet 3830 in a fresh install of Manjaro KDE/PlasmaScreenshot_20200319_030641

Manual discovery with the HP IP address works also.

Yes. You should replace it.

I did as Strit said and now I can run hp-setup.

It then correctly identifies my printer but says that there is no pdd found for the officejet 7510 and asks to click on the button to the right to select one.
I then find the correct pdd (the path at the top of the window: ROOT>usr>share>ppd>HP) which is: hp-officejet_7510_series.ppd.gz .
But I get no further.

Here's what I can see in Konsole at that point:
Searching for device...
Found device: hp:/net/OfficeJet_7510_series?ip=
error: No PPD found for model officejet_7510 using old algorithm.
error: No appropriate print PPD file found for model officejet_7510_series
error: No PPD found for model officejet_7510 using old algorithm.
error: No appropriate print PPD file found for model officejet_7510_series
Traceback (most recent call last):
File "/usr/share/hplip/ui5/", line 1317, in NextButton_clicked
File "/usr/share/hplip/ui5/", line 1011, in addPrinter
print_sts = self.setupPrinter()
File "/usr/share/hplip/ui5/", line 1050, in setupPrinter
if not os.path.exists(self.print_ppd[0]): # assume foomatic: or some such
TypeError: 'NoneType' object is not subscriptable
Aborted (core dumped)

This sounds like it's compressed.
Try extracting it and choose the extracted version.

I'll bet that won't work, and to show why.....
Open ppd with editor, on 1st page will be line *cupsFilter, (or *cupsFilterN,,,1,2,3)
then a quoted line("") The last element in that list is the ACTUAL filter
Find where it is, then "file /path/to/filter". (often /lib/cups or /usr/lib/cups/...)
Is it aarch64 or arm7hf? I really doubt that it will be, likely i386
If you are actually using bonjour/avahi to find printer, the ppd you want
is generic- ipp everywhere or generic- driverless
Lots of info on the debian wiki, OR you can waste lots of time and fail
I can give ubuntu lots of credit here, it auto discovers properly,
the ppd will be drvless or ippeve, the generic ones referenced above
IOW, airprint without manual setup hassle

I extracted the file and searched for cupsFilter and found this:

*cupsFilter: "application/vnd.cups-raster 0 hpcups".

Using the path you suggested I found the file hpcups and opened it with Kate. I can't past the first line here. It begins with ELF and then further into the line one can read : lib/ld-linux-aarch64

I'm guessing this means that the PPD is therefore a valid file for my Pinebook Pro.

However, having extracted the ppd to my desktop I cannot now paste it back into the folder from which it came. I suppose I need to do this as sudo but I can't remember how to do this.

I guess HP has open sourced its drivers, You could re-install
The "file" command tells much info about a particular file
eg: cd Desktop ; file hpcups
The ppd, when installed, ends up in /etc/cups/ppd ,, uncompressed
You could try just copying it there

I'm having difficulty finding out how to do this: I can't simply copy and paste into the destination because I am refused access.
I understand I need to use the terminal as sudo and the mv command.

The ppd file is currently in my folder called Documents and I understand I need to move it to ROOT > etc > cups > ppd

What would I have to write in Konsole?

sudo cp *.ppd /etc/cups/ppd/ should do it.

Thank you, but I've given up on KDE and have now flashed xfce. Will try again with the printer later and confirm.

Forum kindly sponsored by