Problem launching an application via a starter from the desktop

Hi, I got some trouble with my computer. Here is the detail:
When my computer is on, I tried to open an app by double clicking the icon of it, an error occurs, and says "can't launch ***, need a file manager service(such as Thunar)".
But, if I launch the file manager(by the shortcut I set) and change to the Desktop dir, double clicking the icon works, the app launched.
I don't know what caused the problem, can anybody help me?:grinning:
Any suggestions are appreciated.

We need more information about your system and your issue.

Which application do you want to start?
Which DE are you using? (I assume Xfce)
Is the application startable from terminal/whisker menu without thunar running?
What is the content of the *.desktop starter?

Changed title from "Problem with Thunar" to "Problem launching an application via a starter from the desktop", as this seems to be an issue with the application or the starter and not thunar

1 Like

Thanks for replying.
Just now I tried to set my system language to en_US to see whether I can record a GIF with english error message, but it seems that the problem was gone.
Thanks again.

For the future: Do not use gifs, provide information if possible in text form. Please answer the question someone asks. Please read also this post for future topics:

A simple reboot after update/install probably was sufficient in your case. But I can not know for sure.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by