Problem with clementine

I can 't update Manjro. I rebuilt the mirror list, and other commands done from users, but nothing works since the update from Mars.

pacman-optimize && sync
A criar md5sum da base de dados antiga...
==> A gerar tarball de /var/lib/pacman/local...
==> A criar e calcular a soma md5 da nova base de dados...
==> A sincronizar a base de dados com o disco...
==> A verificar integridade...
==> A colocar a nova base de dados no lugar...

==> ConcluĂ­do. A base de dados do pacman foi optimizada.

don't work for me

i use kodi and vlc and clementine. I think i will have no sound at all?

@bardo you have to

 sudo pacman -R gstreamer0.10-good-plugins

because new version 1.10 appears 02/04/2017 and is being upgraded to 1.12

1 Like

that file is not trhe sound or control volume? if is, i will be able to hear sound in clementine and kodi or vlc?
Thanks.

sudo pacman -R gstreamer0.10-good-plugins
[sudo] password for bardo:
a verificar dependĂȘncias...
error: falhou ao preparar a transação (nĂŁo foi possĂ­vel cumprir as dependĂȘncias)
:: farstream-0.1: ao remover gstreamer0.10-good-plugins quebra a dependĂȘncia 'gstreamer0.10-good-plugins

you have to force

sudo pacman -R gstreamer0.10-good-plugins --force

dont works

1 Like

invalid option
sudo pacman -R gstreamer0.10-good-plugins --force
erro: opção invålida '--force'
Thanks

-- force does not apply to -R (Remove) . It is applicable for -S and -U only.

@bardo Instead try this

sudo pacman -Rns gstreamer0.10-good-plugins farstream-0.1
OR
sudo pacman -Rns gstreamer0.10-good-plugins farstream

1 Like

@bardo could you return
liste of packages orphaned

sudo pacman -Qqdt
1 Like

sudo pacman -Qqdt
[sudo] password for bardo:
automoc4
bzr
dcraw
deepin-iconthemes-manjaro
doxygen
efl
elfutils
enca
farstream-0.1
fontforge
gamin
gegl
geoclue
gimp-ufraw
gnutls28
gobject-introspection
gpgmepp
grunt-cli
help2man
intltool
lib32-gconf
lib32-glew1.10
lib32-gperftools
lib32-gtk3
lib32-jansson
lib32-js17
lib32-json-c
lib32-libappindicator-gtk2
lib32-libcurl-gnutls
lib32-libgcrypt15
lib32-libgnutls28
lib32-libjpeg6-turbo
lib32-libnm-glib46
lib32-libpng12
lib32-libudev0
lib32-libvpx
lib32-nettle4
lib32-rtmpdump
lib32-sdl2_image
lib32-sdl_image
lib32-sdl_mixer
lib32-tcp_wrappers
libbaloo4
libgee06
libindicator-gtk3
libkactivities4
libkcddb4
libkdcraw4
libkexiv2_4
libkface4
libkipi4
libksane4
libmygpo-qt
libopenshot
liborcus
libpgf
libpng12
librpcsecgss
manjaro-features
marble
mercurial
nettle4
nodejs-bower
numix-themes-archblue
pth
python-babel
python-notify2
python-pybluez
python-simplejson
python2-crypto
python2-gobject
python2-netifaces
python2-pexpect
pywebkitgtk
qca-qt4
qextserialport
qt4-gstreamer
qtwebkit
quazip
ragel
sparsehash
strigi
vala
vte
webkitgtk
websocketpp
wqy-microhei
wxgtk2.8
xcursor-chameleon-pearl-deepin

sudo pacman -Rns gstreamer0.10-good-plugins farstream-0.1
a verificar dependĂȘncias...
:: xfce4-mixer requer opcionalmente gstreamer0.10-good-plugins: for OSS and PulseAudio support

Pacotes (4) gstreamer0.10-ffmpeg-0.10.13-2 gstreamer0.10-good-0.10.31-11.1
farstream-0.1-0.1.2-5 gstreamer0.10-good-plugins-0.10.31-11.1

Tamanho Total Removido: 13,96 MiB

:: Deseja remover estes pacotes? [S/n]

Is this correct to say Yes?

@bardo For now say Yes and proceed . U can always install gstreamer0.10 from AUR if required by any other package

1 Like

ok. Is installing the updates. I hope kodi, vlc and clementines works well.
thanks

@bardo
you have to always check
package orphans --> remove ( be careful not to do with -Rsn , because more can go out )
then check -Syu , and if others orphan appears -Qqdt

1 Like

@bardo U got huge list of unwanted software on ur manjaro setup.

Once done with update, rebooted and every thing working fine pls execute below command to remove leftover packages which are not required by any package

sudo pacman -Rns $(pacman -Qdtq)

I do this always after successful update to have clean manjaro setup. Next time onwards this will also reduce ur package download count.

1 Like

thanks
If not RNS how i remove?

Thanks. I will do after this update.

Dear @stephane @bardo

Installed package list shud always be a collection of Explicitly installed packages + packages installed as dependency irrespective of the fact that package is coming from repos or AUR.

pacman -Qdtq generates a list of packages not required by any other installed package (Explicit + dependency). Here installed package cud be from repo or AUR.

2 Likes

Forum kindly sponsored by