Problem with maximizing, minimizing

  1. The problem with maximizing, minimizing, when maximizing or minimizing the window is creating lag, what could I do?
  2. When closing, it is put to sleep when I open it, it opens so hard. What can I do
inxi -Fxxxz
System:    Host: zone Kernel: 5.5.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.1 
           info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81EV v: Lenovo ideapad 530S-15IKB serial: <filter> Chassis: type: 10 
           v: Lenovo ideapad 530S-15IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 7PCN35WW date: 09/25/2018 
Battery:   ID-1: BAT0 charge: 32.9 Wh condition: 40.0/45.5 Wh (88%) volts: 8.0/7.7 model: CPT-COS L17C4PB0 type: Li-poly 
           serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 780 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 789 2: 799 3: 800 4: 800 5: 708 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.7 driver: modesetting compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.5.7-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: 3000 bus ID: 02:00.0 
           chip ID: 8086:3166 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 12.93 GiB (2.7%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPMUW-512G-1101 size: 476.94 GiB speed: 15.8 Gb/s 
           lanes: 2 serial: <filter> rev: 20210001 scheme: GPT 
Partition: ID-1: / size: 273.91 GiB used: 9.49 GiB (3.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 165.29 GiB used: 3.44 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p4 
           ID-3: swap-1 size: 26.37 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 40.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 241 Uptime: 9h 31m Memory: 15.43 GiB used: 2.55 GiB (16.6%) Init: systemd v: 242 Compilers: gcc: 9.2.1 
           Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37 

@sami - posting with a new name and with the same apparent issue as all the other topics you opened, will not bring you happiness. I will tell you once again, as i told you back then


Then start over from where you left off with the GPU drivers

With all the information provided so far, you should have had the laptop running with no issue.

1 Like

ok I understood how but, I do not know how, I did as you said but, it does not work ok ... I say.

Ok, do each step one by one:

  1. Update the BIOS
    https://support.lenovo.com/ro/en/downloads/ds503006
    it seems you will require Windows, maybe you can make use of https://www.hirensbootcd.org/usb-booting/ on a USB and boot in their "Windows"
  2. Fully update your system:
    sudo pacman-mirrors -f && sudo pacman -Syyu
  3. Reboot the system if there where updates
  4. Remove the installed free drivers:
    sudo mhwd -r video-linux
    sudo mhwd -r video-vesa
    if happens that you installed them previously
  5. Install the proper video drivers:
    sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime
  6. Reboot the system and go trough this, make sure you get the point and why is advantageous
    Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)
  7. set Compositor to OpenGL3.1 and reduce the animations (speed and their number)

With that said, hope you get it working.

I did exactly as you said but, after I did the fans go to the maximum, I don't know why.

You probably need to install the Nvidia drivers for your graphics card!

Through the GUI:

  1. Open the Manjaro Settings Manager and go to the "Hardware Configuration" tab.
  2. Uninstall whichever configuration is currently installed by right clicking on it and selecting the "remove" option
  3. Install the video-hybrid-intel-nvidia-440xx-prime configuration

Through the CLI:

  1. Get current MHWD configuration: mhwd -li
  2. Remove the installed configuratin: mhwd -r pci <video driver from previous command>
  3. Install the Nvidia Prime 440 Configuration: sudo mhwd -i pci video-hybrid-intel-nvidia-440xx-prime

Investigate why, in what conditions, running trough iGPU or dGPU, switch them. I gave you the exact link where it explains how to do that.

Totally justified and required to repet the exact same thing that was already mentioned ... :wink:

image

[sudo] password for zone: 
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

So with this driver only warming up the laptop why?

Probably not the best option, maybe you need to use Optimus-Switch instead. Also, consider this:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by