Problem with the disk

Why are the partition table and logical disk being created on a 32-bit system, but on a 64-bit system, when trying to create a partition table, this does not happen; also when trying to create a partition, a partition table falls?
Is there a problem with the driver for the disk?

Drives: ST500DM002-1BD142 and ST1000VX000-1ES162

Sorry for bad english.

I don't really understand what the problem is?

What program do you use to create partition tables and partitions?
Manjaro 64-bit or Manjaro 32-bit (or both)?
And what is your goal?


We really need much more information before we can help you.

Please post:

inxi -Fxxxz

sudo blkid -o list

sudo parted -l

Please post the input/outputs of all requested commands via the terminal as text, (not as pics).

Information on how to properly post hardware specs and logs:

Please format any terminal output with three backticks before and after, as shown in this picture:

$ inxi -Fxxxz
  Host: manjaro Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: KDE Plasma 5.14.4 tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> Chassis: 
  type: 3 serial: <filter> 
  Mobo: Gigabyte model: 970A-DS3P v: x.x serial: <filter> UEFI: American Megatrends 
  v: FD date: 02/26/2016 
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 42215 
  Speed: 1630 MHz min/max: 1400/3500 MHz boost: enabled Core speeds (MHz): 1: 1495 
  2: 1552 3: 1404 4: 1403 5: 1405 6: 1393 
  Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: Micro-Star MSI driver: N/A 
  bus ID: 01:00.0 chip ID: 1002:6939 
  Display: server: X.Org 1.20.3 driver: vesa compositor: kwin_x11 
  resolution: 1280x1024~N/A 
  OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.1 compat-v: 3.1 
  direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: AMD Tonga HDMI Audio [Radeon R9 285/380] vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aad8 
  Sound Server: ALSA v: k4.19.13-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 480.55 GiB used: 399.2 MiB (0.1%) 
  ID-1: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  speed: <unknown> rotation: 7200 rpm serial: <filter> rev: KC43 
  ID-2: /dev/sdc type: USB vendor: Kingston model: DataTraveler G3 size: 14.79 GiB 
  serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / size: 11.76 GiB used: 399.2 MiB (3.3%) fs: overlay source: ERR-102 
  System Temperatures: cpu: 22.9 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 228 Uptime: 1h 33m Memory: 15.68 GiB used: 1.65 GiB (10.5%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: konsole inxi: 3.0.28 
$ sudo blkid -o list
device         fs_type label    mount point        UUID
/dev/loop0     squashfs         /run/miso/sfs/livefs 
/dev/loop1     squashfs         /run/miso/sfs/mhwdfs 
/dev/loop2     squashfs         /run/miso/sfs/desktopfs 
/dev/loop3     squashfs         /run/miso/sfs/rootfs 
/dev/sdc2      vfat    MISO_EFI (in use)           8FC1-FD6D
/dev/sdc1      iso9660 MJRO1802 (in use)           2019-01-03-18-10-47-00
sudo parted -l
Error: /dev/sdb: unrecognised disk label
Model: ATA ST500DM002-1BD14 (scsi)                                        
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: unknown
Disk Flags: 

Model: Kingston DataTraveler G3 (scsi)
Disk /dev/sdc: 15,9GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2143MB  2148MB  4194kB  primary               esp

The goal is to install Manjaro 64 bit. When you try to create a partition, the partition table crashes; when you try to create a partition table, nothing happens.

Used gparted when creating a partition table, nothing happens. I used fdisk to create a gpt partition table (also msdos), after I left with the operations I had done, but the partition table was still not created.

Do you have any output?
Did you try with cfdisk (msdos) and/or cgdisk (gpt)?

Start gparted from terminal and post any potential output.

Also, you already have partition tables on /dev/sda and /dev/sdb.
Do you want to create a new one (losing data in the progress)?

Now drive / dev / sdb is empty and without partition table. I'm trying to create a table (device -> create partition table) and nothing happens (both with msdos and gpt):

Too few arguments.
libparted : 3.2
/dev/sdb: unrecognised disk label
/dev/sdb: unrecognised disk label

Does parted work?
Start it and type mklabel msdos or mklabel gpt depending on what you want.

Have you tried rebooting after each attempt? (I guess you did, but I had to ask..)

Maybe try a specialized ISO, like Gparted or UBCD etc..

On 32-bit systems, markup is successful. But I need to install Manjaro x64 UEFI.
Is there a driver problem or not?

Do you mean you have successfully partitioned the drive and it still not seen by the 64bit Manjaro installer?

Manjaro x64 sees it, but during installation it does not see the EFI fat32 partition (/boot/efi not found)

Can you see the partitions in Calamares installer?

I solved the problem. SATA ports 4/5 were in IDE mode, switched them to as Sata type in BIOS

Thanks to all.


You are welcome!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by