Problem with Windows 10 ISO on USB

Hi,

so I wanted to switch back to Windows 10 because I'm having tons of problems using any Linux distro for some reason, so I'm trying to put the installation ISO of Windows 10 on my USB (a 15 GB one) but there's always a problem, even while following the post suggested by the Manjaro Wiki itself ([HowTo] Use Manjaro to create a bootable Windows USB).
While using the WoeUSB software I receive a message stating that the ISO exceeds the maximum single file size of 4 GB (the windows 10 ISO is 4.9 GB), so I tried to use the CLI procedure but with that when I try to boot from the USB nothing happens and Manjaro starts instead.

Here the complete procedure I did on both the attempts:

Istantanea_2019-11-01_16-55-05

CLI procedure terminal:

[david@manjaro ~]$ lsblk -la
NAME  MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0   7:0    0         1 loop 
loop1   7:1    0         0 loop 
loop2   7:2    0         0 loop 
loop3   7:3    0         0 loop 
loop4   7:4    0         0 loop 
loop5   7:5    0         0 loop 
loop6   7:6    0         0 loop 
loop7   7:7    0         0 loop 
sda     8:0    0 931,5G  0 disk 
sda1    8:1    0 931,5G  0 part 
sdb     8:16   0 931,5G  0 disk 
sdb1    8:17   0 931,5G  0 part /
sdc     8:32   0 931,5G  0 disk 
sdc1    8:33   0 931,5G  0 part 
[david@manjaro ~]$ lsblk -la
NAME  MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0   7:0    0         1 loop 
loop1   7:1    0         0 loop 
loop2   7:2    0         0 loop 
loop3   7:3    0         0 loop 
loop4   7:4    0         0 loop 
loop5   7:5    0         0 loop 
loop6   7:6    0         0 loop 
loop7   7:7    0         0 loop 
sda     8:0    0 931,5G  0 disk 
sda1    8:1    0 931,5G  0 part 
sdb     8:16   0 931,5G  0 disk 
sdb1    8:17   0 931,5G  0 part /
sdc     8:32   0 931,5G  0 disk 
sdc1    8:33   0 931,5G  0 part 
sdd     8:48   1  14,4G  0 disk 
sdd1    8:49   1  14,4G  0 part 
[david@manjaro ~]$ sudo dd if=/dev/zero of=/dev/sdd bs=1M count=10 oflag=sync
[sudo] password di david: 
10+0 record dentro
10+0 record fuori
10485760 bytes (10 MB, 10 MiB) copied, 0,660068 s, 15,9 MB/s
[david@manjaro ~]$ sudo fdisk /dev/sdd

Welcome to fdisk (util-linux 2.34).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Device does not contain a recognized partition table.
Created a new DOS disklabel with disk identifier 0x7f3ce906.

Comando (m per richiamare la guida): o
Created a new DOS disklabel with disk identifier 0x78a86c37.

Comando (m per richiamare la guida): n
Partition type
   p   primary (0 primary, 0 extended, 4 free)
   e   extended (container for logical partitions)
Select (default p): 

Using default response p.
Numero della partizione (1-4, default 1): 
First sector (2048-30218841, default 2048): 
Last sector, +/-sectors or +/-size{K,M,G,T,P} (2048-30218841, default 30218841): 

Created a new partition 1 of type 'Linux' and of size 14,4 GiB.

Comando (m per richiamare la guida): t
Selected partition 1
Hex code (type L to list all codes): c
Changed type of partition 'Linux' to 'W95 FAT32 (LBA)'.

Comando (m per richiamare la guida): a
Selected partition 1
The bootable flag on partition 1 is enabled now.

Comando (m per richiamare la guida): w
The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.

[david@manjaro ~]$ sudo mkfs.vfat -F 32 /dev/sdd1
mkfs.fat 4.1 (2017-01-24)
[david@manjaro ~]$ mkdir ~/winiso
[david@manjaro ~]$ sudo mount -o loop windows.iso ~/winiso
mount: /home/david/winiso: WARNING: device write-protected, mounted read-only.
[david@manjaro ~]$ mkdir ~/winusb
[david@manjaro ~]$ cd ~/winiso
[david@manjaro winiso]$ cp -r * ~/winusb
[david@manjaro winiso]$ sync
[david@manjaro winiso]$ cd ~
[david@manjaro ~]$ sudo umount ~/winiso ~/winusb
umount: /home/david/winusb: not mounted.
[david@manjaro ~]$ rm -f ~/winiso ~/winusb
rm: impossibile rimuovere '/home/david/winiso': È una directory
rm: impossibile rimuovere '/home/david/winusb': È una directory

Reading through your terminal output - it makes me reallize - you didn't mount your usb device to ~/winusb.

The cleanup command is missing the recursive flag on the rm command - I have fixed the guide

rm -rf ~/winiso ~/winusb
2 Likes

Yeah sorry I did a mistake, it was the third time I was trying to do this. Right now I get an error message that I got before, saying I don't permissions to copy the files:

[david@manjaro ~]$ sudo mount /dev/sde1 ~/winusb
[david@manjaro ~]$ cd ~/winiso
[david@manjaro winiso]$ cp -r * ~/winusb
cp: impossibile creare il file regolare '/home/david/winusb/autorun.inf': Permesso negato
cp: impossibile creare la directory '/home/david/winusb/boot': Permesso negato
cp: impossibile creare il file regolare '/home/david/winusb/bootmgr': Permesso negato
cp: impossibile creare il file regolare '/home/david/winusb/bootmgr.efi': Permesso negato
cp: impossibile creare la directory '/home/david/winusb/efi': Permesso negato
cp: impossibile creare il file regolare '/home/david/winusb/setup.exe': Permesso negato
cp: impossibile creare la directory '/home/david/winusb/sources': Permesso negato
cp: impossibile creare la directory '/home/david/winusb/support': Permesso negato

I thought this was caused by the "read-only" state that I got in every attempt but I can't find the right way to make it read and write.

EDIT:
I've tried with adding sudo too but using that it just gets stuck with no response, last time if I remember correctly it stated that the file was too large just like in WoeUSB, I'm running it again to generate again the error.

Try using WoeUSB and select NTFS for filesystem.

I will take another look at the guide - test the manual way with NTFS

Your permission issues is because you - forgot to mount the iso in a previous step.

You have copied all the files from the ISO to a folder in your home - and maybe you have mixed in sudo in the creation of the folders or the copying or you you have switched the folder mounts.

In any case - the solution is to unmount your device and use sudo to remove the folders.

sudo umount /dev/sde1

Remove the folders

sudo rm -rf /home/david/winusb /home/david/winiso

Then you have a clean state and can try again - if the NTFS selection in WoeUSB fails you.

4 Likes

It seems to be working fine now, thank you very much!

I hope to eventually fix all the performance problems I'm having with manjaro to come back on it one day.

Edit: grammar fix.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by