Problema in login screen

Yesterday i turned on my computer and manjaro showed a terminal screen. There was no way to get login window. I managed to get login screen only after I runned some instructions in this terminal screen, but in the login screen appears some errors and i'm not able to access at my desktop. I read some topics with similiar problems but no one of this worked for me.

This is the login screen:

This is my inxi -Fxxxz output:

Someone can help me to solve this or i have to format? Despite having recovered the data I would like to avoid formatting.

See if this will help, by running this command from TTY:
sudo pacman-mirrors -f5 && sudo pacman -Syyu plasma5-themes-breath
Once it finishes reboot the system.

1 Like

Reinstall sddm theme - ( sudo pacman -S sddm-breath-theme )


What exactly have you run?
Have you just updated (before last shutdown)?

The comands i runned was:

systemctl enable sddm.service
systemctl start sddm.service

After that i get the screen login that i posted in the question.

No, I haven't updated anything. But I didn't use the computer. Those who used it did not know how to provide details.

Can you get to desktop session from TTY using startx as user?
If yes, try changing the Login theme from settings.

It accesses the desktop, but continues to remain black with an error window.

Thank you for suggesting the commands to use to restore the login screen. I now have access to the desktop but it remains black with an error screen. I tried to follow the directions in another topic but I didn't solve it, in this topic it was suggested to use the command sudo pacman -S plasma and install the various components, I try to execute the command, the various downloads begin but to end returns "Errors have occurred, no packages have been updated".

The error window in desktop:

"Plasma cannot be started"
"All shell packages missing. this is an installation issue please contact your distribution."

This suggests there might be some package changes made and installing all plasma group packages conflicts. Or the system is on a partial update condition.

  1. Verify proper packages update, as suggested from the start
  1. Try login to a new user from TTY.

Re-installing maybe needed, unfortunately. The system needs some care and caution on maintaining... :disappointed:

Anyway, post TTY/terminal messages and commands, so we know how to better interpret them.
Read basic info on troubleshooting
How to provide information about your issues

Trick question: Is the system's DE Plasma/KDE?

I haven't solved it, but thanks anyway.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by