Problemas de instalación de paquetes.

Hola gente, soy totalmente nuevo en Linux, y es la primera vez que lo uso.
Estoy buscando por muchos sitios, pero no doy con la tecla, y supongo que siendo novato en este sistema aún más, pero espero que seáis considerados, y me ayudéis.
Mi distro es la Garuda, se que no es quizá el mejor sitio para preguntar, pero por algún lado tengo que empezar.
Bien, que me enrollo, el caso es que cuando quiero instalar algunos programas, el instalador me lanza el mensaje

Error al confirmar la transacción: no se pudieron ejecutar los <>

Lo primero que hice fue actualizar todo lo que hubiera pendiente por ahí, y después buscar como un loco, y hay algunas soluciones, pero ninguna la entendí bien, así que no me han funcionado, porque creo que no eran para mi, inclusive, tuve que reinstalar el sistema por culpa de eso.

Total, hay un par de programas que necesito, pero no puedo tener por ese error.
Me ayudáis?, muchísimas gracias, y hasta ahora.

Hi!
Como intentas instalar los paketes, terminal o gráfico, repos o AUR

  • Si estás intentando instalar por la terminal:
    ejecuta el comando para instalar el paquete/programa en cuestión (pacman -S paquete) y pega aquí todo lo que te dice la terminal (copia y pega directamente de la terminal).

  • Si es mediante instalador gráfico, intenta instalar el paquete/programa y copia y pega aquí todo lo que te dice el instalador.

Hola chicos, perdón por el retraso.
Lo intento instalar por el instalador gráfico.
Y el mensaje que aparece es el mencionado.

No se pudieron ejecutar los <>

Perdón, no se puso la palabra en el otro mensaje.

¿Cual instalador? Hay varios...

¿Tampoco su comunidad puede ayudarte?

Uso Pamac v9.5.6-1, y bueno, yo es que no se inglés, y sus foros están en dicho idioma, podría intentar usar un traductor en linea, pero por experiencia propia cuesta mucho de que te entiendan.
Vine aquí por que esa distribución se basa en Manjaro, pero vamos, que si impepinablemente tengo que acudir al foro de ellos, me voy,

Por cierto, otra vez no me deja escribir el mensaje completo, entre los signos < y > va la palabra hooks.

Encontré esto, que quizá te pueda ayudar:

https://archived.forum.manjaro.org/t/conflicto-catfish-y-zeitgeist-no-se-pudieron-ejecutar-los-hooks/144559/5

En su caso era un error con el paquete pacman y lo solucionó con el comando:

sudo pacman -R $(pacman -Qq | grep pamac) && sudo pacman -Sy pamac-gtk

1 Like

Hola, probé el comando que me facilitas, hubo un pequeño error, no encontraba pacman-gtk, borré -gtk y se pudo reinstalar pacman, pero sigo en las mismas.
Al final he recurrido al foro de la distro, espero que con mi inglés chapurreado con el traductor me entiendan bien, seguramente sea lo mejor, porque eso de los hooks me está dando por saco, no entiendo muy bien porque algunas apps puedo instalarlas, y otras no.
En fin, espero areglarlo, si no quizá me valla a otra distro.
Gracias man, de nuevo.

Arreglado!.
Me han respondido en otro foro, parece que esa distro se tiene que instalar con formato de archivos btrfs, por lo que me dicen, aunque como dije, no tengo ni idea de linux, seguí una guía y esta en ext4 (hubiera dejado que se instalara de por si con el asistente, pero tengo una partición que no quería perder, me hubiera sentado bastante mal.
El caso es que, tenía que desinstalar timeshif con

sudo pacman -Rnsc grub-btrfs timeshift-autosnap

Gracias, y saludos

1 Like

Forum kindly sponsored by