Problems after Resume from Suspend

Hi, I am trying Manjaro following years with Mint. My hardware is a Dell XPS L702X which, whilst a laptop, is used as a desktop ie it is plugged into the mains permanently and the battery is not installed. I am using the Gnome desktop.

My problems occur with 2 applications after a suspend and resume:-
Firstly Evolution Contacts (synced with Google via Online Accounts) displays the following when it is refreshed -
_"Unable to perform search." _
"This query did not complete successfully. Cannot connect to the service’s server."

Secondly Money Manager Ex fails to launch. A screen is displayed for a split second, then - nothing. Launching it from a terminal results in the following:

[jjd@Dell-xps ~]$ mmex
17:03:56: Debug: 2016-09-11 - 2017-09-04
17:03:56: Debug: 2016-09-11 - 2017-08-22
17:03:56: Debug: 2016-09-11 - 2017-08-13
17:03:56: Debug: 2016-09-11 - 2017-08-08
17:03:56: Debug: 2016-09-11 - 2017-06-07
17:03:56: Debug: 2016-09-11 - 2017-05-30
17:03:56: Debug: 2016-09-11 - 2017-05-01
17:03:56: Debug: 2016-09-11 - 2017-05-01
17:03:56: Debug: 2016-09-11 - 2017-05-01
17:03:56: Debug: 2016-09-11 - 2017-03-12
17:03:56: Debug: {
"item@Home Page" : true,
"item@Bank Accounts" : true
17:03:56: Debug: Loading file:/tmp/mmex_jjd_tmp/index.html
User-Agent: Linux 4.10.17-2-MANJARO x86_64

Segmentation fault (core dumped)

Both applications perform correctly after a reboot, butr as soon as the systems suspends the problems recur.
I am also evaluating Antergos and these issues do not happen with that OS. I would prefer Manjaro but need to resolve them to use it as my main system.

Thanks for any assistance.


Your problem seems to be related to your internet connection not being instantly re-connected, OR those apps are expecting to have a pre-existing socket still open upon resume from suspend.

Try shutting down those apps before suspend to see if it solves the problem.
Another way to test is just disconnect the internet (airplane mode or unplug cat5 cable) for the same lenght of time you would expect to suspend, and then see if that works upon reconnecting.

It may be that Manjaro is not shutting down the internet connection on suspend, therefore the applications think they should be able to carry on as before when resumed. A proper shutdown would signal that those connections can't be relied upon and the apps would then re-establish them properly upon resume.

There are threads similar to this dating from 2013 on the internet that suggest there is a need to restart network-manager upon resume.

We also had a thread here in these forums:

You might try the trick mentioned in the very last post on that thread.

You forgot to tell us how you are connected to the internet. Cat5 or Wifi?

1 Like

Thanks for your response. I am using a wired network connection. It does seem to be related to the internet connection - but for some reason the incidences of the error have reduced dramatically today. I think that it followed turning Aeroplane Mode on. Why that should affect it baffles me, but for now I will monitor it and if there are no further problems for a few days I will mark this as solved.
Again, thanks for your help.

I was wrong re Aeroplane Mode - Still got the problems on resume. Also experienced Google issues re "Err_Connect" and "suspicious activity" notifications. Solved everything by turning off IP6 in Network Manager. No issues at all since then.

Hope this helps any other users who encounter resume problems.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by