Problems installing Manjaro 17 KDE on my Dell Latitude E5550 laptop

Will enabling uefi secure boot on cause problems? Just wanted to know before I change from secure boot off.

Will I be able go easily change back to uefi boot mode off if I needed?

Those settings are OS-agnostic. virtually welded to your motherboard. Unless you do something drastic like attempt to reformat the bios with a fragmented image or something, they will continue to be accessible and changeable no matter whats installed (or not) on your HD.

If you booted/installed the .iso in EFI mode it will not boot using traditional bios.

Secure boot being ON is usually a source of issues. If it is off, then that is most likely not the culprit.
(Please pay attention though .. the option may be "disable secure boot" and hence require "yes/on")
If the manufcturer [nefariously] coupled the two together.. you may need to disable and install in traditional mode.
This can be achieved using similar boot key sequences [like f2 for device selection] and selecting the USB in 'legacy' or 'bios' (not EFI).
There are slight losses to be had by ditching EFI, such as cap RAM and benefits of multiple boot options, so while not a HUGE deal, I am hoping we can move forward still using EFI.
Again, if the BIOS (may be a good idea to check if it has updates) was hard-coded by the manufactirer to be somewhat obstructive we may have to work with what we have. Canonical (ubuntu) literally pays to be recognized as 'secure'. We do not have such funds..nor intentions AFAIK. And could likely be the cause of this discrepancy.

Okay, I've tried secure boot enabled and attempted reboot, but was unsuccessful. In fact, I received the following message: Operating System Loader has no signature. Incompatible with SecureBoot

OK, we know secure boot is not the issue.
I think I'm going to call over @gohlip , as they are the resident GRUB/Boot master :wink:

If you have access to the installation, it may be helpful to have the contents of both

I'll try but I think it's more than a bootloader thingy here....

  1. First, disable secure boot (if reenabled). Always keep it disabled.
  2. Boot into Manjaro livecd in UEFI mode
  3. Verify that the livecd boot is in UEFI by

test -d /sys/firmware/efi && echo UEFI || echo BIOS

It must show "UEFI", not "BIOS".
  1. (I typed 4. it displayed 1., sigh...)

Now my train of thought is derailed. taking a break.

4. Confirm your partitions with either one of these...
> sudo parted -l 
sudo blkid
lsblk -f


5. (1. again)
Arhhhhh I write a new post.

a. First, disable secure boot (if reenabled). Always keep it disabled.
b. Boot into Manjaro livecd in UEFI mode. And always boot in uefi - all the time.
c. Verify that the livecd boot is in UEFI by

test -d /sys/firmware/efi && echo UEFI || echo BIOS

It must show "UEFI", not "BIOS".

d. Confirm your partitions with either one of these...

sudo parted -l
sudo blkid
lsblk -f

e. Chroot as follows, making sure below partitions correspond with the partition output above.

sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo mount -t proc proc /mnt/proc
sudo mount -t sysfs sys /mnt/sys
sudo mount -o bind /dev /mnt/dev
sudo mount -t devpts pts /mnt/dev/pts/
sudo chroot /mnt

f. Always do this before anything else

sudo pacman-mirrors -g
sudo pacman -Syyu

g. After doing above,

sudo pacman -S grub
sudo grub-install
sudo update-grub

[Edit] - In your case, it's better to do the full grub-install command

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug

h. type 'exit' to ...exit chroot

sudo exit

i. Check in your livecd file manager that the installed Manjaro OS (sda2) has entry in /etc/fstab for /boot/efi.
If not, create one like this

UUID=xxxxxx                       /boot/efi      vfat    defaults,noatime 0       2

where xxxxxx is UUID of sda1,

j. Do nothing else. (You may still in chroot - it's easy to mess up in chroot)
k. Reboot without livecd.

Good luck.

1 Like

did you try the manjaro architect installer?

I did everything as indicated up to the first command for chroot. However, i got command not found.

[manjaro@manjaro ~]$ sudo parted -l
Model: ATA ST500LM021-1KJ15 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2098kB 317MB 315MB fat32 boot, esp
2 317MB 491GB 491GB ext4
3 491GB 500GB 8907MB linux-swap(v1)

Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 2011MB 2011MB primary boot
2 2011MB 2016MB 4194kB primary esp

[manjaro@manjaro ~]$ sudo mount/dev/sda2/mnt
sudo: mount/dev/sda2/mnt: command not found

you missed a space
sudo mount /dev/sda2 /mnt

Edit. Oops :crying_cat_face:

thanks. Unfortunately, i got the following message:

can't find /dev/sda2/mnt in /etc/fstab

Missed another space, between /dev/sda2 and /mnt :slight_smile:

thanks yet again! okay, I was able to perform the first command:

sudo pacman-mirrors -g

However, i received multiple error messages:
Could not resolve host
failed retrieving file
failed to update multilib (download library error)
failed to synchronize any databases
failed to init transaction (download library error)

Should I resolve this first before proceeding?

By the way, Thank you all for your continued support for complete CLI and linux newbies such as me.

Try looking at your dns in your /etc/resolve.conf and maybe switch to opendns or google dns ...

Thanks for all of your help again. I performed all tasks as specified and after rebooting without the live usb, No bootable device was detected

If you have done all correctly, especially 'sudo pacman -Syyu' completed without errors,
boot up using this. Remember, using the livecd, you boot up to installed OS, not the livecd OS.

(ps: whatever, let us know if you can boot up to installed OS)

Then, at installed OS terminal,

sudo grub-install
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

That should give you a bootable device (if Manjaro is properly er.... good)

1 Like

All of you are awesome! I'm up and running. I really appreciate all of your support and tenacious efforts to help out a newbie. This was also a good learning experience for me. In fact, all of you have spurred me on to really digging in and learning Manjaro Linux and the CLI. I am never going back to MacOS X or Windows. AGAIN, THANKS​:hugs::hugs::hugs::hugs:


Nice :slight_smile:
Click on the :ballot_box_with_check:checkmark under the post that solved it for you so others can find it more easily.
Welcome to the club. :beers:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by