Problems with Kernel 5.7 and Nvidia hybrid

Hello everyone,

After the last stable update (I'm using Manjaro Gnome) I also upgraded my kernel to 5.7.9-1.
The problem is it seems there's some problem when loading the Nvidia drivers with this kernel.
I had this problem before, but I didn't bother fixing because it was with the RC kernel.
Everything works fine in kernels 5.6.19 and earlier.

The Xorg.0.log looks like this:

[     5.792] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[     5.795] (II) Module modesetting: vendor="X.Org Foundation"
[     5.795]    compiled for 1.20.8, module version = 1.20.8
[     5.795]    Module class: X.Org Video Driver
[     5.795]    ABI class: X.Org Video Driver, version 24.1
[     5.795] (II) LoadModule: "fbdev"
[     5.796] (WW) Warning, couldn't open module fbdev
[     5.796] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     5.796] (II) LoadModule: "vesa"
[     5.797] (WW) Warning, couldn't open module vesa
[     5.797] (EE) Failed to load module "vesa" (module does not exist, 0)
[     5.798] (II) NVIDIA dlloader X Driver  440.100  Fri May 29 08:21:27 UTC 2020
[     5.798] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     5.799] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     5.799] (WW) Falling back to old probe method for modesetting
[     5.799] (II) systemd-logind: releasing fd for 226:0
[     5.802] (II) Loading sub module "fb"
[     5.802] (II) LoadModule: "fb"
[     5.802] (II) Loading /usr/lib/xorg/modules/libfb.so
[     5.804] (II) Module fb: vendor="X.Org Foundation"
[     5.804]    compiled for 1.20.8, module version = 1.0.0
[     5.804]    ABI class: X.Org ANSI C Emulation, version 0.4
[     5.804] (II) Loading sub module "wfb"
[     5.804] (II) LoadModule: "wfb"
[     5.804] (II) Loading /usr/lib/xorg/modules/libwfb.so
[     5.807] (II) Module wfb: vendor="X.Org Foundation"
[     5.807]    compiled for 1.20.8, module version = 1.0.0
[     5.807]    ABI class: X.Org ANSI C Emulation, version 0.4
[     5.807] (II) Loading sub module "ramdac"
[     5.807] (II) LoadModule: "ramdac"
[     5.807] (II) Module "ramdac" already built-in
[     5.811] (EE) Screen 0 deleted because of no matching config section.
[     5.811] (II) UnloadModule: "modesetting"
[     5.811] (EE) Device(s) detected, but none match those in the config file.
[     5.811] (EE) 
Fatal server error:
[     5.812] (EE) no screens found(EE) 
[     5.812] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[     5.812] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     5.812] (EE) 
[     5.814] (EE) Server terminated with error (1). Closing log file.

I'm using the video-hybrid-intel-nvidia-440x-prime in my Dell Inspiron 7560-A30S laptop.
The system specs are below.
Can anyone point me in the right direction to solve this problem?

System:    Host: bitz-dell Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: Gnome 3.36.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 7560 v: N/A serial: <filter> 
           Mobo: Dell model: 09WC1G v: A01 serial: <filter> UEFI: Dell v: 1.1.6 date: 07/19/2017 
Battery:   ID-1: BAT0 charge: 11.3 Wh condition: 11.3/42.0 Wh (27%) model: LGC-LGC3.553 DELL 8YPRW79 status: Full 
           Device-1: hidpp_battery_0 model: Logitech M570 charge: 30% status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Amber Lake rev: 9 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23209 
           Speed: 700 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Dell driver: nvidia v: 440.100 bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.8 driver: modesetting,nvidia resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: e000 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 v: 8.048.03-NAPI 
           port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-8:9 
Drives:    Local Storage: total: 1.03 TiB used: 263.36 GiB (25.1%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-75Z10T0 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: LITE-ON model: CV3-8D128-11 SATA 128GB size: 119.24 GiB 
Partition: ID-1: / size: 58.06 GiB used: 37.13 GiB (63.9%) fs: ext4 dev: /dev/sdb5 
           ID-2: swap-1 size: 17.17 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 39.0 C mobo: 37.0 C sodimm: 36.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 266 Uptime: 43m Memory: 15.54 GiB used: 3.62 GiB (23.3%) Init: systemd Compilers: gcc: 10.1.0 
           clang: 10.0.0 Shell: bash v: 5.0.18 inxi: 3.0.37 

you should check in log

sudo journalctl -b0 -f drm
sudo journalctl -b0 -f nvidia

I have used the commands but they gave me an error.

hmcezar@bitz-dell ~]$ sudo journalctl -b0 -f drm
[sudo] senha para hmcezar: 
Failed to add match 'drm': Argumento inválido
[hmcezar@bitz-dell ~]$ sudo journalctl -b0 -f nvidia
Failed to add match 'nvidia': Argumento inválido

I went to the journalctl manual and tried to fix them but I think I couldn't.

[hmcezar@bitz-dell ~]$ sudo journalctl -b -1 -f -u nvidia
-- Logs begin at Fri 2019-06-21 08:59:02 -03. --
^C
[hmcezar@bitz-dell ~]$ sudo journalctl -b -1 -f -u drm
-- Logs begin at Fri 2019-06-21 08:59:02 -03. --
^C

I'm using -b -1 because it was the last boot (when I tried kernel 5.7) that I had the problem. Now I'm in 5.6.19 and it's fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by