Pulse audio cannot find my soundcard

In settings > hardware > audio my sound card cannot be recognised. It can also not be recognised pulse audio volume control.

This happened after my computer randomly froze.

Image of pulse audio not recognising any output device

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

1 Like

Thanks for your reply,

Here is the output from, inxi -Fxxxza --no-host : https://pastebin.com/S5pWizH7

And the output from dmesg : https://pastebin.com/gTXW3Ri4 (so it seems there is something wrong with the audio device)

P.S. Also added some more information on my profile

1 Like

It looks like you have more than just sound problems... You seem to have a hardware issue.

What's the output of lspci and is this a brand new machine still under warranty???

:scream:

1 Like

I got this PC half a year ago and it has been working all good, i recently switched to manjaro and this all occurred after a freeze.

The output is:

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Desktop)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake PCH SATA AHCI Controller (rev 10)
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #6 (rev f0)
00:1c.6 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #7 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a308 (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile] (rev c3)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

I should have asked for an lsusb as well as it's not a PCI device...

Sorry!

:sob:

1 Like

The output to that is:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 5986:110d Acer, Inc Integrated Camera
Bus 001 Device 004: ID 17ef:608c Lenovo Lenovo Calliope USB Keyboard
Bus 001 Device 003: ID 1bcf:08a0 Sunplus Innovation Technology Inc. 
Bus 001 Device 002: ID 0781:5581 SanDisk Corp. Ultra
Bus 001 Device 007: ID 0cf3:e500 Qualcomm Atheros Communications 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can you:

  • add pcie_aspm=off to the grub boot parameters
  • reboot
  • provide another dmesg

Please?

1 Like

How can i access the grub boot parameters?

  1. Be careful if you've never done this.

  2. Verify everything twice

  3. Execute:

    sudo nano --backup /etc/default/grub
    
  4. look for a line starting with GRUB_CMDLINE_LINUX_DEFAULT=

  5. Add Space pcie_aspm=off before the last " on that line

  6. Ctrl+X Y and then Enter to save

  7. Execute:

    sudo update-grub
    
  8. Reboot

STOP and don't do anything if you get stuck!

:innocent:

1 Like

Heres the new output: https://pastebin.com/H8WuVp78

Found it: You're affected by a bug

And you should follow this answer:

:innocent:

1 Like

Ill try follow it, thanks for helping me all this way <3

Hey,

I didn't have the v5.5.11-1 kernel option available so i went with the v5.5.19-1 however following those steps with this kernel didn't seem to do the trick.

You shoould be on 5.6 already: it's been out for a couple of months now.

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux56
    sudo reboot
    
  • as 5.6 is newer than 5.5 it should detect it automatically. If it doesn't leave another message...

:innocent:

1 Like

I executed that after switching to TTY2, I got the message that I was already using 5.6 ofcourse and then i rebooted. Nothing has changed.

So you're still on 5.5???

  • reboot
  • choose advanced options in the grub menu
  • Choose kernel 5.6
1 Like

Im on 5.6, I said: I got the message that I was already using 5.6 ofcourse

Please be much more specific! :smiling_imp:

Could you elaborate on this then:

  • Did pamac install sof-firmware not work?
  • Did it not make a difference?
  • What did not work???

:stuck_out_tongue_winking_eye:

1 Like

I followed all the steps,

No errors or anything and after a reboot nothing seemed to have gotten fixed, maybe - thinking about it again - I didn't enable v5.5.19-1 . I'll try enable it in TTY2.

Forum kindly sponsored by