Pulse audio cannot find my soundcard

No don't: it's 5.5 minimum...

I'm all out of ideas by now: Try to download a new ISO and burn to USB and boot that and see if that works...

:sob:

1 Like

But a new Iso will require me download all software again and I will lose my current filesystem, will it not?

Don't install anything, just boot it and see if it works there.

However, if it does work there, I'm going to tell you to back up all your data and reinstall indeed...

Like I said:

:sob:

1 Like

Just to add, I can here the backspace beep in the TTY2...

:sob:

1 Like

Not asking for any help on this reply but, I'm just gonna explain how confused I am. My computer froze on manjaro and now my audio stopped working. I just went to check windows and it's also stopped there

:man_facepalming:

That would have been very helpful information 6 hours ago... It looks like you've got a hardware problem! (and why we had all these weird hardware errors not directly related to sound earlier)

Manjaro freezing was not the problem but the symptom of the disease: something broke!

Please:

  1. Take a full data backup right now!
  2. Have your PC serviced!

:scream:

1 Like

Oh I just checked now sorry, I'll try take a look but any ideas why this could have happened out of the blue?

Without physical access to the hardware? Diagnosing a hardware problem???

Unlikely!

:stuck_out_tongue_winking_eye:

1 Like

what was running on system when it froze?
was anything being installed updated ?

suggest check your system BIOS settings in case audio devices were disabled there

then boot from Manjaro Live USB and check if audio is working there

if audio is not working on Live USB, get ALSA information - sudo alsa-info.sh --upload
and post link to uploaded data at alsa-project

1 Like

and in his dmesg, he had tons of these:

[ 2805.827816] pcieport 0000:00:1c.6: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
[ 2805.827821] pcieport 0000:00:1c.6: AER:   device [8086:a33e] error status/mask=00001000/00002000
[ 2805.827826] pcieport 0000:00:1c.6: AER:    [12] Timeout              

to the point the dmesg was unreadable, so I had him add pcie_aspm=off as a kernel parameter to get it back to be readable, so it's my considered opinion the freeze was hardware-related, not the other way around.

Your opinion, master?

:innocent:

1 Like

It froze when i zoomed out in visual studio code. And here is the link: http://alsa-project.org/db/?f=2a3e4a25f4b35aa094d63811f8608621fbecf845

ALSA data shows that a Modprobe option for snd_hda_intel has been added to system

!!Modprobe options (Sound related)
!!--------------------------------

snd_hda_intel: dmic_detect=0

this modprobe option disables detection of the internal microphone array
it was needed for kernel v5.4 and earlier that did not support sof-firmware for the internal dmic
once the dmic is disabled, other audio subdevices will work with snd_hda_intel driver

use this command to find name of the .conf file added for Modprobe option
grep -i 'snd_hda_intel' /etc/modprobe.d/*.conf

delete the Modprobe option file and reboot

system should able to detect onboard microphones and the other audio devices

sof-firmware appears to be installed - ALSA data is showing driver 'snd_sof_intel_hda'

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by