Pulse audio equalizer stops working

Hello.

I need a software based equalizer so my bass doesn't wake up my roommates so I'm using pulseaudio-equalizer and pulseaudio-equalizer-ladspa.

My issue is that it seems to randomly turn off by itself. It will work again if I disable then re-enable it. This happens almost every time that I pause a youtube video in chromium or refresh the page.

Yes, the keep setting button is checked in pulseaudio-equalizer-ladspa. This issue persists in the console based pulseaudio-equalizer.

Is it related to this?
https://wiki.archlinux.org/index.php/PulseAudio#Back-end_configuration

Audio issues are the most common issue I've had in Linux, across all 3 of my systems. Another issue, which maybe related, when adjusting the volume via the tray application, sometimes there will be static in the speakers.

System:    Host: AMMOBOX Kernel: 4.19.1-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.2 
           tk: Qt 5.11.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: G1.Sniper Z97 v: x.x serial: <filter> UEFI: American Megatrends v: F6 
           date: 05/30/2014 
CPU:       Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64028 
           Speed: 1901 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 1447 2: 1517 3: 1374 4: 1655 5: 1566 6: 1507 7: 1345 
           8: 1426 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: eVga.com. driver: nvidia v: 410.73 bus ID: 01:00.0 
           chip ID: 10de:13c2 
           Display: x11 server: X.Org 1.20.3 driver: nvidia compositor: kwin_x11 resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 410.73 direct render: Yes 
Audio:     Device-1: Intel 9 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-2: NVIDIA GM204 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbb 
           Sound Server: ALSA v: k4.19.1-1-MANJARO 
Network:   Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Gigabyte driver: alx v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 1969:e091 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 3.64 TiB used: 150.92 GiB (4.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: BB6Q 
           scheme: GPT 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> rev: 2B6Q 
           scheme: GPT 
           ID-3: /dev/sdc vendor: HGST (Hitachi) model: HDN724030ALE640 size: 2.73 TiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: A5E0 scheme: GPT 
Partition: ID-1: / size: 440.28 GiB used: 150.92 GiB (34.3%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.15 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 29.0 C mobo: N/A gpu: nvidia temp: 51 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 245 Uptime: 3h 58m Memory: 15.59 GiB used: 3.35 GiB (21.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.27

They are supposed to be alternatives to one another. It is possible they are colliding.

I uninstalled pulseaudio-equalizer and pulseaudio-equalizer-ladspa, restarted. Then installed the AUR pulseaudio-equalizer-aptx, which worked. I did have to start that application everytime I restarted, but it worked.

I want to use pulseaudio-equalizer-ladspa. In the Audio Volume Settings > Audio Volume > Applications, when Chromium plays audio, it will show what audio device it's using, it defaults to "Built-in Audio Analog Stereo". But it shold be using "LADSPA Plugin Multiband EQ on Built-in Audio Analog Stereo". How do I fix that, maybe remove the "Built-in Audio Analog Stereo" option altogether?

For boots do this:
https://wiki.archlinux.org/index.php/PulseAudio#Load_equalizer_and_dbus_module_on_every_boot

Thank you cscs! This isn't in the wiki word-for-word, but here's what fixed it:

At the bottom of /etc/pulse/default.pa add:

load-module module-ladspa-sink
load-module module-dbus-protocol

Then restart pulse.

pulseaudio -k && pulseaudio -D
1 Like

This issue reappeared the following day, so I had to abandon pulseaudio-equalizer-ladspa & pulseaudio-equalizer for the AUR pulseaudio-equalizer-aptx. That fixed the issue, but then, 2 weeks later, I had been getting static when using the volume control in YouTube. So I recently switched from KDE to xfce to test. I'm getting the same static in xfce. Turns out my original issue, that I posted about, may have been fixed in PulseAudio 12 and it was specific to KDE. But, it didn't answer why I was getting the bug post-v12. No way to test that atm.

Now I'm using PulseEffects, since that's the only recommended Arch equalizer and still getting that static.

There's also a hardware solution to this:

Headphones.

:wink:

2 Likes

ever find a working solution to this? i have the same problem where the pulseaudio-equalizer will revert to the default “Built-in Audio Analog Stereo” every time i pause audio/video playback and its incredibly annoying having to keep the pulseaudio eq gui open all the time and have to toggle off/on for it to work again over and over

This trick...

...worked brilliantly for me in my KDE Stable Tower, for exactly one Stable-Update cycle. Ie, from the subsequent Update onwards til & including today, it never worked again [my file edits do remain intact ok]. It never worked in my KDE Stable Lappy. Consequently, in both, i still have to do what you wrote, & what i've had to do for years. Tis frustrating.

EDIT: Not exactly what you wrote; in KDE i can simply swap back & forth to LADSPA in the Sound Plasmoid [so i do not need to keep the EQ GUI open]. Still irritating though!

i know, i did actually add that to default.pa , its working now but im expecting it to break eventually like it did for @dc327 and for you . i did notice in default.pa some entries that look like they would conflict with what i added, when/if this stops working i will play around some more and figure it out.
to be continued.....

well that certainly makes a hell of a lot more sense than opening pulseaudio-equalizer and toggle off/on. thanks

check default Pulseaudio sink:
cat ~/.config/pulse/*default-sink

can just hack the relevant text file to change name to correct sink
or use pactl set-default-sink (NAME)

not usually needed, but to be totally sure default is set every time Pulseaudio is started, add extra line to end of default.pa configuration:
set-default-sink (NAME)

@dglt - if you intend to do a lot of configuration changes to Pulseaudio,
suggest copy default.pa file to home folder
cp /etc/pulse/default.pa ~/.config/pulse/default.pa
customised configuration in home folder is used instead of system configuration next time pulseaudio loaded.
makes it a bit easier to edit, or drop back to default if needed

dead on, i updated today and now its doing it again, and editing the default.pa does nothing now. guess i'll work on getting this working because this can be pretty annoying, especially with many interruptions

this is the puzzling part, the default is set to ladspa like i want yet it still loads the built-in analog stereo and i need to keep switching every time i pause playback in audio/video

I don't use the ladspa version just the normal one and absolutely no problems what so ever, its the only version that does not crackle every time i open a page, pulse-effects works fine and also auto-starts (its in the settings menu), fine as long as the eq start .config is not in pulse default.pa. but is a no no as it will not port to my front headphones

i tried pulse effects, pulseaudio eq ladspa, tried non ladspa version. i only have issues like this on my kde install(other settings dont save sometimes). on my gnome setup it remembers settings. i think i'll jump back into it tommorow and maybe just uninstall pulse and any affiliated configs and reinstall to start fresh and see if i can figure it out. i'll try the non ladspa version first after i re-install, i get the same crackle sometimes while changing volume.

This is my /home/kdemeoz/.config/pulse/767768ed550c47be8b6ddf861e71e3bf-default-sink full contents:

ladspa_output.mbeq_1197.mbeq

Is that good or bad / right or wrong, do you know, pls?

Two plebeian questions please:

  1. Do you mean edit the file version /home/kdemeoz/.config/pulse/default.pa, or the /etc/pulse/default.pa one?
  2. I don't understand what you mean by (NAME) - whose or whats?

I've also tried it, several times over the past several months. My quest is different to yours though; i'm not fighting to eliminate a crackle, but simply to achieve my desired control for good granular bass & treble. My dislike of pule-effects each time [apart from its waaaaaaaaay excessive GUI complexity] is that its bass response is... pathetic. The LADSPA EQ beats it completely, & gives me a very satisfying audio experience... pity about its intransigence to repeatedly forget it's supposed to be my default.

I use this found on the internet added at the bottom of the default.pa

.ifexists module-dbus-protocol.so
load-module module-dbus-protocol
.endif

load-module module-equalizer-sink sink_name=equalized

set-default-sink equalized

Interesting thanks.

Same as my question to @nikgnomic; which file location?

Does your code supplement, or otherwise replace, the current edit per earlier in this thread:

load-module module-ladspa-sink
load-module module-dbus-protocol

@Kadee apologies for my excess brevity

for:
cat ~/.config/pulse/*default-sink

the "~/" works for you same as "/home/kdemeoz/" but also works for other usernames
the "*" wildcard is needed for the long hex id code that differs for each user

looks like you got the right file, but name does not look right

@Robin0800 has worked this on a different module to specifying the sink_name option

The Pulseaudio documentation for module-ladspa-sink shows a complete example with required options (and looks to be using the mbeq-1197 plugin)

so suggest as starting point, use:

load-module module-ladspa-sink sink_name=ladspa_out master=alsa_out plugin=mbeq_1197 label=mbeq control=11.621622,10,4.594594,2.702703,0,0,-1.621622,-0.270270,-5.405406,-3.513514,-8.648648,-5.675676,-4.054054,1.351351,9.189189

and

set-default-sink ladspa_out

(not sure if module-dbus-protocol even relates to running ladspa-sink-module)

That example ladspa sink will work but very unlikely to be correct numbers listed in the bit starting "control=..."
need a comma separated list of 15 numbers for the 15 eq settings
values can be between -70 and 30, but shouldn't be needing
first value is for lowest frequency 50Hz
This what same plugin looks like in a JACK gui showing all the frequency bands:

Don't worry about having another copy of default.pa in home folder if only trying to add an equalizer. If user only needs to add 2 or 3 modules, just edit /etc/pulse/default.pa
2nd configuration in home is only worthwhile if want to try deeper hacking of Pulseaudio

The usual suggestion on Pulseaudio problems is to use pavucontrol or pavucontrol-qt
but it doesn't show the sink and source defaults.
Fallback options in settings are not same as default

basically its the same, my main priority is getting the eq settings to hold, and if it should fix the crackling at the same time, great. im gonna uninstall everything related to pulseaudio including both default.pa and reinstall and go from there, i'll let you know if i figure it out.

i agree, pulse effects = :poop:

Forum kindly sponsored by