Pulseaudio Equalizer (LADSPA) - GUI

The above when installed in KDE is different as opposed to being installed in XFCE or Cinnamon.
The leftmost element on the toolbar should be,as per XFCE and Cinnamon, a small drop down menu offering "Reset defaults - Keep Settings" and "Quit".
Oddly,with KDE it only mirrors the rightmost icon that deals with Minimise,maximise,always on top and close etc. There is no option anywhere for Reset - keep settings and quit.

I have it installed in my KDE Plasma, but I am using two things you may not have on your system, i.e.:

  1. The gtk3-nocsd package from the AUR, which disables GTK client-side decorations.

  2. The KDE Global Menu.

As such, the three menu items you speak of are shown in my Global Menu here, as per the screenshot below.

2020.04.19_12:16_-_PulseAudio_Equalizer

1 Like

Thank-You Aragorn. I shall check that out later when I get to my main PC. Is your install persistent across reboot or do you have to restart it each time. Again a situation that doesnt occur with XFCE or Cinnamon!

Nope,sadly not. All I gain is a pretty top bar on the application. The 3 part menu section is still absent.

github page for this package has recently posted a request for maintainer(s)
so reporting an issue there may not get much attention

1 Like

It's an installed system. :wink:

If your're not satisfied with it, remove and install PulseEffects. It's also in GTK, but at least it's shown in the right way with the default theme and has way more plugins.

Have you seen the amount of stuff that gets installed with that? :open_mouth:
I just need an equalizer to balance my defective hearing when using Headphones.

For some reason the Equalizer isnt appended to the default.pa in /home/user/config/pulse section -with KDE. I copied and pasted from Cinnamon,so now at least Pulse initializes at each Start-up,Reboot.

That is strange. On my system it always starts automatically without requiring any user input. :thinking:

hi. i have installed also that equalizer and everytime i start my pc i must also go and start it and enable it. is there any solution to start it in the background and enabled? thanks.

What Desktop Environment?

kde plasma. is very annoying issue. other than that i have no problem with manjaro. works perfectly.

Fwiw, i have this bash script autorun at Plasma SU:

#!/bin/bash
 
#killall pulseaudio
#kstart pulseaudio &

### 19/12/18:   Kadee -- Per https://archived.forum.manjaro.org/t/pulse-audio-equalizer-stops-working/64653/44 i replaced the above with the following, coz it properly supports retaining the PulseAudio LADSPA Equaliser as the active default sound device.

systemctl restart --user pulseaudio.service

...and...

I appended this to my /home/kdemeoz/.config/pulse/default.pa:

####### Kadee 8/11/18:   From https://archived.forum.manjaro.org/t/pulse-audio-equalizer-stops-working/64653/5?u=kdemeoz, to stop audio returning to “Built-in Audio Analog Stereo” from my preferred “LADSPA Plugin Multiband EQ on Built-in Audio Analog Stereo”, each time i stop a sound source playing.
# "Then restart pulse: `pulseaudio -k && pulseaudio -D` "
load-module module-ladspa-sink
load-module module-dbus-protocol

Consequently, for the past few years now, my audio thru my ladspa EQ is sweeeeeeeeeeeeeet. Bass, we wants our baaaaaaaaaaaaaaaaaaaaass, my precious.

2 Likes

that bash file where do i move? sorry but i am newbie.

  1. Create the file [eg, in your /home/nikos/bin directory].
  2. Make it executable.
  3. Add it to the startup, eg:

20200513-151401

Alternatively to the preceding graphical method, you can simply symlink it from its location [eg, /home/nikos/bin/PulseAudio_kill_&_restart.sh] into /home/nikos/.config/autostart-scripts.

1 Like

nope the pulseaudio equalizer wont start. i did all steps and still i must turn the equalizer manually on.
in a different thread i found that someone run this "system settings>>startup and shutdown>>autostart>>add program>>enter the command>>ok" during kde loads the enviroment. how i run that one?

Look at my picture above.

Instead of the Script button, use the Program button.

Note however -- i already told you mine works correctly & as you can see in the picture i do not autostart the EQ GUI. Because of the method already given, PulseAudio is automatically sending all audio through the EQ sink. I only need to manually open the EQ GUI in the rare case i need to change the settings.

tl;dr -- i do not know why this is not working for you, but i doubt autostarting the EQ GUI will help you. However, it costs nothing to try it, & for your sake i hope i am wrong.

PS: After doing my earlier changes i do hope you logged out/in, or even rebooted?

1 Like

yea i done that and it didnt work. i created a bin folder then created the .sh file with everything you posted earlier. then i edited the default file by running sudo nano /etc/pulse/default.pa
and added what u posted. yes i log out

That is NOT what i told you. I gave you a path to your home directory. You need to copy the root file there, then edit that version, which then takes precedence over the root one, AND then persists after system updates. Your root changes will be lost, next update.

2 Likes

Forum kindly sponsored by