Pulseaudio Equalizer (LADSPA) - GUI

I didn't manage to make it work. I managed to work the default equalizer but there are no presets there.

check out what is happening to sinks for playback with - pacmd dump| grep sink

look for the default-sink at the end of this text
for system to play through the equalizer this should be
set-default-sink ladspa_output.mbeq_1197.mbeq

to set default-sink so all audio playback uses equalizer, add this line to configuration file ~/.config/pulse/default.pa
echo 'set-default-sink ladspa_output.mbeq_1197.mbeq' >> ~/.config/pulse/default.pa

1 Like

Fwiw, & for OP's comparison... mine on Lappy [need to check Tower later]:

$ pacmd dump| grep sink
load-module module-always-sink
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq sink_master=alsa_output.pci-0000_00_1b.0.analog-stereo plugin=mbeq_1197 label=mbeq control=3.0,7.0,7.3,7.0,3.0,-1.0,-6.6,-6.3,-4.5,-4.0,3.1,7.9,9.6,9.9,6.8
set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 0xd1ec
set-sink-mute alsa_output.pci-0000_00_1b.0.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1b.0.analog-stereo yes
set-sink-volume ladspa_output.mbeq_1197.mbeq 0xd1ec
set-sink-mute ladspa_output.mbeq_1197.mbeq yes
suspend-sink ladspa_output.mbeq_1197.mbeq yes
set-default-sink ladspa_output.mbeq_1197.mbeq

everytime i boot my system it shows that

load-module module-always-sink
set-sink-volume alsa_output.pci-0000_05_04.0.analog-surround-40 0x10000
set-sink-mute alsa_output.pci-0000_05_04.0.analog-surround-40 no
suspend-sink alsa_output.pci-0000_05_04.0.analog-surround-40 yes
set-default-sink alsa_output.pci-0000_05_04.0.analog-surround-40

After i turn on the equalizer it shows that

load-module module-always-sink
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.pci-0000_05_04.0.analog-surround-40 plugin=mbeq_1197 label=mbeq control=6.1,3.7,-2.0,-3.7,-5.0,-10.0,-11.5,-11.5,-10.0,-5.0,-2.7,-1.0,-1.3,2.4,5.7
set-sink-volume alsa_output.pci-0000_05_04.0.analog-surround-40 0x10000
set-sink-mute alsa_output.pci-0000_05_04.0.analog-surround-40 no
suspend-sink alsa_output.pci-0000_05_04.0.analog-surround-40 yes
set-sink-volume ladspa_output.mbeq_1197.mbeq 0x10000
set-sink-mute ladspa_output.mbeq_1197.mbeq no
suspend-sink ladspa_output.mbeq_1197.mbeq yes
set-default-sink ladspa_output.mbeq_1197.mbeq

but after i restart is loosing ladspa as default. i tried the

echo 'set-default-sink ladspa_output.mbeq_1197.mbeq' >> ~/.config/pulse/default.pa

but no success. my sound options on the panel are all off cant do anything there and ladspa eq is not on.

The problem is that is forget that ladspa is default. the untouched default.pa look like that at the end with ladspa eq on

### Make some devices default
#set-default-sink output
#set-default-source input

ok i fixed it. i added at the end of the default.pa

load-module module-always-sink
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.pci-0000_05_04.0.analog-stereo plugin=mbeq_1197 label=mbeq control=6.1,3.7,-2.0,-3.7,-5.0,-10.0,-11.5,-11.5,-10.0,-5.0,-2.7,-1.0,-1.3,2.4,5.7

and now with every boot i get ladspa eq on by default! thank you guys for the help!

1 Like

Make sure you did that edit in your user config's copy, not the root master in /etc/pulse, otherwise as i mentioned earlier, your hard-won victory will be lost again next time pulse is updated.

1 Like

yea i edit that one. thank you sir

:scream: :woman_facepalming:

miss/madam

pulseaudio default sink appears to be set to use ladspa_output when it is available
but the equalizer sink is not available when system boots

suggest use command options mentioned in pulseaudio-equalizer -h

to start with fixed settings i only needed - pulseaudio-equalizer enable-config

but if that is not enough, maybe add a startup item - /usr/bin/pulseaudio-equalizer enable

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by