PyCharm Community "Out of memory" for no reason

I am learning how to code in Python and the IDE a lot of people were recommending was Jetbrains' Pycharm Community Version, so I installed it and fell in love with it. Today I was booting up Manjaro as usual, and opening PyCharm so I can code. Then PyCharm started getting unresponsive and the window's name changed from "PyCharm Community" to "Out of Memory". I waited a bit and then tried to close the program which made my whole system unresponsive and created artifacts all over the screen. What's weird is that the computer was literally on idle (only Okular was running) and this is the first time I've had an error with PyCharm

Edit: Reinstalling and uninstall+installing the programm didnt fix this

System: Host: mainpc Kernel: 4.19.133-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=aa84227e-17e4-46d9-b2fa-ea4d36ad5ff9 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Desktop Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0 serial: UEFI: American Megatrends
v: 1.D0 date: 11/08/2019
CPU: Topology: Quad Core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP arch: Zen family: 17 (23)
model-id: 11 (17) stepping: N/A microcode: 8101016 L2 cache: 2048 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 30002
Speed: 2999 MHz min/max: N/A Core speeds (MHz): 1: 2999 2: 2996 3: 2999 4: 3083
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Micro-Star MSI driver: amdgpu
v: kernel bus ID: 27:00.0 chip ID: 1002:15dd
Display: x11 server: X.Org 1.20.8 driver: amdgpu FAILED: ati unloaded: modesetting alternate: fbdev,vesa
compositor: kwin_x11 resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.27.0 4.19.133-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.1.3 direct render: Yes
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel v: kernel
bus ID: 27:00.1 chip ID: 1002:15de
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus ID: 27:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k4.19.133-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel
port: f000 bus ID: 22:00.0 chip ID: 10ec:8168
IF: enp34s0 state: down mac:
Device-2: TP-Link TL-WN822N Version 4 RTL8192EU type: USB driver: rtl8192eu bus ID: 1-2:2 chip ID: 2357:0108
serial:
IF: wlp18s0f0u2 state: up mac:
Drives: Local Storage: total: 948.31 GiB used: 23.52 GiB (2.5%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW128HEGR-000L2 size: 119.24 GiB block size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: rev: 4L1QCXB7 scheme: GPT
ID-2: /dev/sda vendor: Fujitsu model: MHZ2160BH G2 size: 149.05 GiB block size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s serial: rev: 000B scheme: MBR
ID-3: /dev/sdb vendor: Seagate model: ST9250315AS size: 232.89 GiB block size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s rotation: 5400 rpm serial: rev: SDM1 scheme: MBR
ID-4: /dev/sdc vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: R013 scheme: GPT
Partition: ID-1: / raw size: 118.95 GiB size: 116.58 GiB (98.01%) used: 23.52 GiB (20.2%) fs: ext4 dev: /dev/nvme0n1p2
Sensors: System Temperatures: cpu: 37.4 C mobo: N/A gpu: amdgpu temp: 37 C
Fan Speeds (RPM): N/A
Info: Processes: 202 Uptime: 8m Memory: 6.81 GiB used: 1.21 GiB (17.7%) Init: systemd v: 245 Compilers: gcc: 10.1.0
Shell: bash v: 5.0.18 running in: yakuake inxi: 3.0.37

Here are my specs for anyone wondering!

Forum kindly sponsored by