Pycharm could not store GitHub access token on Manjaro KDE-18.0.3-stable-x86_64

I am a new user of Manjaro and I am working on Python programming.

I installed Manjaro KDE-18.0.3-stable yesterday, got everything set up correctly on my computer and the PyCharm worked well. But when I logged in the GitHub account, closed the Settings and opened it again, there will be a "Missing access token" marked in red besides the username. Also, there was a message in the Konsole after reopening the Settings, which was:

Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files

I have tried Mnajaro Deepin-18.0.2-stable-x86_64, Manjaro XFCE-18.0.3-stable-x86_64 and Ubuntu 18.04.2-LTS and everything works well, there were no "Missing access token" and such message in the Konsole and I could commit and push to my project.

Information of my computer:
Surface Pro 6
CPU: Inter Core i5-8350U
8GB RAM, 256 GB

I believe the JetBrains applications will try to use KWallet (in KDE/when it's available), so you might want to check your KWallet settings.

Thanks.

In Manjaro Deepin, after inputting the token, there will be a pop-up of password input window for accessing the keyring.
But on KDE version, there is no such window. Furthermore, I could not find PyCharm ask for the authentication to the KWallet in the KWalletManager.

I switched to another computer, things still went wrong.

I just exported settings (including GitHub account infomation) from PyCharm, and imported them on the Manjaro KDE. It still showed Missing access token.
Maybe the PyCharm does not support the KWallet somehow... I suppose I should keep use Manjaro Deepin.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by