QCA9377 - Network-Manager idle disconnect issue

Hey folks,

since my manjaro beginnings I have a WLAN problem, but I managed to live with it. Now I just want to have it solved..

After I do something on my system which doesn't require me to interact with it (e.g. Discord call, watching a education stream, etc.), I won't recieve any packages (0b/s) after a time of around 10 to 20 minutes. If I open the network-manager applet it normally reestablishes the connection. Don't get me wrong I'm connect 100% of the time, but I still get no internet periodically.

So far I've tested a different kernel, reinstalled my drivers and restarted the network manager service more often than I can remember.

I added


to my NetworkManager.conf.

inxi -Fxxxz output:

System:    Host: Patrik-Laptop Kernel: 5.6.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire A515-51G v: V1.19 serial: <filter> 
           Mobo: KBL model: Charmander_KL v: V1.19 serial: <filter> UEFI: Insyde v: 1.19 
           date: 04/24/2018 
Battery:   ID-1: BAT1 charge: 42.3 Wh condition: 42.3/48.9 Wh (87%) volts: 16.9/15.2 
           model: LG 004B384234314341 type: Li-ion serial: <filter> status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
           6: 800 7: 800 8: 801 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.8 driver: intel compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.6.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8168 v: 8.048.02-NAPI port: 3000 bus ID: 02:00.1 
           chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On 
           driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 185.05 GiB (8.8%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: ACM1 scheme: GPT 
           ID-2: /dev/sdb vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: 1P10 scheme: GPT 
Partition: ID-1: / size: 48.60 GiB used: 24.57 GiB (50.6%) fs: ext4 dev: /dev/sdb6 
           ID-2: /home size: 239.85 GiB used: 12.26 GiB (5.1%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 7.63 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 278 Uptime: 12h 40m Memory: 7.65 GiB used: 2.52 GiB (32.9%) Init: systemd v: 245 
           Compilers: gcc: 9.3.0 Shell: zsh v: 5.8 running in: terminator inxi: 3.0.37

I have seen many posts about problems with network manager, but I do not know what my actual problem is. Hopefully, someone can finally open my eyes.

It's likely a power saving issue.

I'd start with a couple of things to limit power saving:

Disable Network Manager's WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

A setting of "0" will totally disable power saving features in the WiFi adapter.

A setting of "2" or "1" will be less aggressive, but still leave power saving enabled.

Reboot after creating (or editing) any Network Manager configuration file.

If tlp is installed then another good troubleshooting step is to temporarily disable the tlp power manager:

sudo systemctl mask tlp && sudo systemctl mask tlp-sleep

Reboot after masking those services.

If there is no improvement you can re-enable tlp by repeating those commands using "unmask" instead of "mask".

Masking tlp is not a solution it is merely a troubleshooting step to find out if a tlp power saving option is affecting your wifi. If that is the case you will need to find the power setting and disable it in tlp's configuration file.


Seems like the first steps has worked. Thank you so much. I knew it had something to do with power managment, but I had no idea how to change it.

1 Like

So glad that worked for you, and you're very welcome.

That probably won't be the last issue you have with that adapter. It seems rather endless the stream of issues it suffers from.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by