QCA9377 wifi not available after update

Hello,

I just updated my whole system, and my wifi broke: the wireless option isn't available anymore in the networkmanager.

I tried downgrading the version of networkmanager, but it didn't change anything. I'm using the XFCE desktop.

Here are a few outputs you might want to see:

$ lspci -k
...
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 30)
	Subsystem: Foxconn International, Inc. QCA9377 802.11ac Wireless Network Adapter
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci

$ inxi -N
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter driver: ath10k_pci 

Notice there's no wlp3s0 link:

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 54:ab:3a:2c:8d:07 brd ff:ff:ff:ff:ff:ff
$ uname -a
Linux paul-pc 4.14.87-1-MANJARO #1 SMP PREEMPT Sat Dec 8 15:56:41 UTC 2018 x86_64 GNU/Linux

Do you have any idea what could be the cause of the issue? Do you need more info?

Thanks a lot

Please search the forum for this phrase. There are multiple recent threads regarding the exact same issue. Needless to say, downgrading Network Manager isn't the answer:

https://archived.forum.manjaro.org/search?q=QCA9377

If none of the existing threads help please post back with what you have tried.

1 Like

Thank you for your answer, you were right, I guess I've got to better learn how to search the forum..

I had to downgrade linux-firmware to get things working, yet I suppose this issue has to be fixed somehow.

Here's what I've done to downgrade:

$ wget https://archive.archlinux.org/packages/l/linux-firmware/linux-firmware-20180825.fea76a0-1-any.pkg.tar.xz
$ pacman -U linux-firmware-20180825.fea76a0-1-any.pkg.tar.xz

Thanks again!

2 Likes

Excellent. Well done both for finding the solution, and for posting your solution for others to find in future. :slight_smile:

I'm using linux-firmware 20181026.[...]-1 on my laptop with Linux 4.19 and it works fine. I had a similar issue a while ago when I was using Linux 4.14 and I also went for a downgrade of linux-firmware back then.

Now that you have a working internet connection, maybe you could consider upgrading to Linux 4.19 and check out if your network interface works correctly without the downgrade on 4.19. (And of course, verify is everything else is working correctly too.)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by