Qualcomm Atheros QCA6174 isn't working on Manjaro 19.0

If the adapter can still not be raised after that then this leaves:

Reset your bios to the factory default.

Is a bios update available? If so you should update your bios.

Update the ath10k firmware, (search on how to install the newest firmware from kvallo on github).

Test the real time kernels, as they are sometimes free of regressions that have recently happened on the mainline Manjaro kernels. You could also switch branches and test the newest 5.6 kernel.

Same as here, but now with wlan0 instead of wlp1s0

Looks like problem is in NetworkManager, because after recent update I found that USB-modem is working not properly until systemctl restart NetworkManager, but reinstalling didn't help

Then try downgrading NM or switch to connman.

Still no connection with connman. Gonna try to reinstall athk_10 firmware

Just tried kvalo's firmware, doesn't work for me. I'm stumped

Try installing networkmanager-iwd from the AUR.

Test the real time kernels.

@tbg I have read that the problem can be in Windows ACPI table (I have dualbooted Windows on the same drive). Is it true?

Still no solution. Weird.

Have you disabled fastboot in windows?

Yes, I disabled it

Prevent bluetooth & dependent modules from starting:

sudo echo 'install bluetooth /bin/false' | sudo tee /etc/modprobe.d/bluetooth_ban.conf           

Reboot and test wifi.

You can delete the file /etc/modprobe.d/bluetooth_ban.conf if there is no improvement (or leave it in place if not using BT).

UberLambda/ath10k-QCA6174-pkgbuild

ath10k-QCA6174-git

This is an Arch/Manjaro PKGBUILD that builds the newest Qualcomm Atheros QCA6174 firmware from the version at:

Here is a link explaining how to build and then install the PKGBUILD:

A network adapter not being detected properly (or a hard block) can sometimes be hard to correct. Changing the BIOS settings may help in this situation (as well as power cycling). If available, a BIOS update may also help correct these problems. Below are several methods that may help with raising your adapter.

Resetting the BIOS back to the factory default settings may help with adapter detection. This also sometimes helps to remove a hard block. Boot into the BIOS settings utility and reset the BIOS back to the factory default. Save the default settings, and power down the laptop.

Disconnect any other network devices that do not require troubleshooting. This includes LAN cables, USB to Ethernet adapters, and USB phone tethering.

Power down the laptop and remove the battery and power plug. Let the laptop sit without power for a few minutes. Then, hold down the power button for approximately 30 seconds. Pressing the power button will help drain all left over power from the unit’s motherboard.

Then reattach the AC power (no battery), and restart. Boot into your bios, then reset the bios to the factory defaults, save the default settings. See if it will boot correctly with the factory default settings. If not, you may have to change a few settings in the BIOS (such as secure boot) to get Manjaro to boot correctly. After rebooting your adapter may be properly detected and initialized.



Be sure the following boot parameter is in place (do not remove it).

The following command will add a GRUB kernel boot parameter to /etc/default/grub:

sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test your connection for improvement.

*sed magic courtesy of @dalto

Tried everything from 3 previous posts, nothing helps :frowning:

So you've been saying for over 50 posts, but without terminal outputs words are meaningless. Only terminal outputs can confirm if you've performed a procedure correctly.

The ath10k firmware has been reported as buggy and apparently Arch has patched it, but it may take some time for this to reach the stable branch. In the mean time you could try this:

Rename the /usr/lib/firmware/ath10k/QCA6174/ board-2.bin files:

sudo mv /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin.bak
sudo mv /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin.bak

Replace /usr/lib/firmware/ath10k/QCA6174/board.bin files with:

http://www.killernetworking.com/support/K1535_Debian/board.bin

Download the file from http://www.killernetworking.com/support/K1535_Debian/board.bin to your ~/Downloads directory.

Then (on your user account, not root):

cd ~/Downloads
sudo cp ~/Downloads/board.bin /usr/lib/firmware/ath10k/QCA6174/hw2.1/board.bin
sudo cp ~/Downloads/board.bin /usr/lib/firmware/ath10k/QCA6174/hw3.0/board.bin

Reboot.

If your wifi is still not working correctly then add an ath10k driver option file to /etc/modprobe.d:

echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k.conf 

I hope that helps until the ath10k firmware bug is fixed.

(Edit)

A user I recommended this to yesterday confirmed that replacing the firmware did indeed fix their QCA6174 problems.

This fix was reported to have helped on another ath10k thread I was assisting with today:

Disable Network Manager's WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

A setting of "0" will totally disable power saving features in the WiFi adapter.

A setting of "2" or "1" will be less aggressive, but still leave power saving enabled.

This change can be reversed by deleting the newly created file with the following command:

sudo rm /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot after creating (or removing) any Network Manager configuration file.



Another user I helped yesterday had success downgrading wpa_supplicant from an older version from their package cache. If you have no older versions in your package cache you could also replace wpa_supplicant with the iwd package as a comparable fix.

You can easily test iwd in place of wpa_supplicant by following the steps below:

sudo pacman -S iwd 
sudo systemctl stop wpa_supplicant
sudo systemctl mask wpa_supplicant
sudo systemctl enable --now iwd.service
sudo systemctl daemon-reload
sudo systemctl restart NetwokManager.service

If you would like to return to using wpa_supplicant simply reverse the process:

sudo systemctl stop iwd.service
sudo systemctl mask iwd.service
sudo systemctl unmask wpa_supplicant
sudo systemctl enable --now wpa_supplicant
sudo systemctl daemon-reload
sudo systemctl restart NetworkManager.service

IWD is now used by default on new Arch Linux installs as wpa_supplicant's replacement. I use iwd myself and find it superior in many ways. Give it a try.

1 Like

Finally! You are the savior! Thank you so much for your patience! After almost a month my WiFi is working now!

There you go. After only a paltry 55 posts an answer is finally found. Be thankful you don't own a broadcom adapter, some of my broadcom threads go 150-170+ posts long. Haha... :rofl:

Sooner or later, if you toss enough stuff at the wall something will usually stick.

Thank you for the compliments, and glad things worked out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by