Qualcomm Atheros QCA6174 isn't working on Manjaro 19.0

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=6032e900-6c4a-491e-835d-0650e900a94c udev.log_priority=3 acpi_backlight=vendor"
GRUB_CMDLINE_LINUX=""

I do not see the grub boot parameter:

pcie_aspm=off

The above parameter often helps with this adapter as mentioned on the thread I linked.


Run either of the following commands to refresh your IP address:

If you are running dhcpd as your dhcp client you can run this command:

dhcpcd -k $(hwinfo --netcard | grep "Device File" | cut -d " " -f5) && dhcpcd $(hwinfo --netcard | grep "Device File" | cut -d " " -f5)

If you are running dhclient you can run this command:

sudo /sbin/dhclient -v -r  $(hwinfo --netcard | grep "Device File" | cut -d " " -f5) && sudo dhclient -v -1 $(hwinfo --netcard | grep "Device File" | cut -d " " -f5) 

If you don't know which client you are using then the first command is most likely the one you want to use. Running either command should be fine as it should have no effect if the service is not being used.

Test your connectivity after running the commands.

I tried it, nothing changed.

dhcpcd -k $(hwinfo --netcard | grep "Device File" | cut -d " " -f5) && dhcpcd $(hwinfo --netcard | grep "Device File" | cut -d " " -f5)

sending commands to master dhcpcd process
sending commands to master dhcpcd process

sudo /sbin/dhclient -v -r $(hwinfo --netcard | grep "Device File" | cut -d " " -f5) && sudo dhclient -v -1 $(hwinfo --netcard | grep "Device File" | cut -d " " -f5)

RTNETLINK answers: Resource temporarily unavailable
Listening on LPF/wlp1s0/7e:82:16:0e:0a:fe
Sending on   LPF/wlp1s0/7e:82:16:0e:0a:fe
Sending on   Socket/fallback
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 5
send_packet: Network is down
dhclient.c:2456: Failed to send 300 byte long packet over wlp1s0 interface.
receive_packet failed on wlp1s0: Network is down
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 11
send_packet: Network is down
dhclient.c:2456: Failed to send 300 byte long packet over wlp1s0 interface.
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 14
send_packet: Network is down
dhclient.c:2456: Failed to send 300 byte long packet over wlp1s0 interface.
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 17
send_packet: Network is down
dhclient.c:2456: Failed to send 300 byte long packet over wlp1s0 interface.
DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 14
send_packet: Network is down
dhclient.c:2456: Failed to send 300 byte long packet over wlp1s0 interface.

I now notice from your earlier outputs that you are running a docker container. This can cause networking conflicts at times. Try disabling auto-start of the docker daemon and reboot.

Ok, but before docker installation situation was the same

Try this:

sudo -u $USER /bin/bash -lc 'nmcli networking off' && sleep 1 && sudo systemctl stop NetworkManager && sudo ip link set $(hwinfo --wlan | grep "Device File" | cut -d " " -f5) down && sudo rmmod ath10k_pci && sleep 1 && sudo rmmod ath10k_core && sleep 5 && sudo modprobe ath10k_core && sleep 2 && sudo modprobe ath10k_pci && sleep 2 && sudo ip link set $(hwinfo --wlan | grep "Device File" | cut -d " " -f5) up && sleep 2 && sudo systemctl start NetworkManager && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli networking on' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi off' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

This command totally broke my connection (even with USB modem), it was hard to repair it :slight_smile: But first time output was
Not enough information: "dev" argument is required.

Was that the full output:

When running diagnostic commands you are best not to run the commands with phone tethering or USB ethernet connected, Disconnect extraneous neyworking devices, reboot, run diagnostic commands, then save the output of the commands. More work, but is far more precise way of doing things when trouble shooting.

Remove connected network devices, then reboot.

Then run:

hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" 

Then post the output.

Model: "Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter"
  Driver: "ath10k_pci"
  Device File: wlp1s0
  Link detected: no
    Driver Status: ath10k_pci is active
    Driver Activation Cmd: "modprobe ath10k_pci"
  Model: "Lite-On Bluetooth Device"
  Hotplug: USB
  Driver: "btusb"
  Speed: 12 Mbps
    Driver Status: btusb is active
    Driver Activation Cmd: "modprobe btusb"

Try this command, it has your adapter's specific ID:

sudo -u $USER /bin/bash -lc 'nmcli networking off' && sleep 1 && sudo systemctl stop NetworkManager && sudo ip link set wlp1s0 down && sudo rmmod ath10k_pci && sleep 1 && sudo rmmod ath10k_core && sleep 5 && sudo modprobe ath10k_core && sleep 2 && sudo modprobe ath10k_pci && sleep 2 && sudo ip link set wlp1s0 up && sleep 2 && sudo systemctl start NetworkManager && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli networking on' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi off' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

Looks like it fails somewhere there, because i had an error No network named wlp1s0 during script running, but before script wlp1s0 presented in inxi -Fxxxz

Found somwthing interesting: rfkill blocked my wifi:

● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Tue 2020-03-03 21:18:29 MSK; 1min 38s ago
     Docs: man:NetworkManager(8)
 Main PID: 824 (NetworkManager)
    Tasks: 3 (limit: 4915)
   Memory: 15.9M
   CGroup: /system.slice/NetworkManager.service
           └─824 /usr/bin/NetworkManager --no-daemon

Mar 03 21:18:35 hackfeed NetworkManager[824]: <info>  [1583259515.7929] manager: (wlan0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
Mar 03 21:18:35 hackfeed NetworkManager[824]: <info>  [1583259515.7947] rfkill1: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:01.3/0000:01:00.0/ieee80211/phy0/rfkill1) (driver ath10k_pci)
Mar 03 21:18:35 hackfeed NetworkManager[824]: <info>  [1583259515.8163] supplicant: wpa_supplicant running
Mar 03 21:18:35 hackfeed NetworkManager[824]: <info>  [1583259515.8217] device (wlan0): interface index 3 renamed iface from 'wlan0' to 'wlp1s0'
Mar 03 21:18:35 hackfeed NetworkManager[824]: <info>  [1583259515.8232] manager: rfkill: Wi-Fi now disabled by radio killswitch
Mar 03 21:18:48 hackfeed NetworkManager[824]: <info>  [1583259528.6248] manager: NetworkManager state is now ASLEEP
Mar 03 21:18:50 hackfeed NetworkManager[824]: <info>  [1583259530.1357] manager: (A4:45:19:46:92:A3): new Bluetooth device (/org/freedesktop/NetworkManager/Devices/4)
Mar 03 21:18:50 hackfeed NetworkManager[824]: <info>  [1583259530.6960] agent-manager: agent[d85bb4cfefd934ce,:1.78/org.kde.plasma.networkmanagement/1000]: agent registered
Mar 03 21:19:38 hackfeed NetworkManager[824]: <info>  [1583259578.6875] audit: op="radio-control" arg="wireless-enabled" pid=1569 uid=1000 result="success"
Mar 03 21:19:46 hackfeed NetworkManager[824]: <info>  [1583259586.5271] audit: op="radio-control" arg="wireless-enabled" pid=1569 uid=1000 result="success"

This is the same issue as in the linked thead. Please apply the fix that cured that problem.

Also post:

rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Just retried NetworkManager .state file removing - nothing cnahged

Did you reboot?

Add ipv6.disable=1 net.ifnames=0 to /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1 net.ifnames=0"

Reboot

Did it, nothing changed, except inxi -Fxxxz Network section:

IF: wlan0 state: down mac: <filter>

Yes, but now we can try raising the adapter using it's original designation wlan0. The adapter usually gets renamed during the boot process, and there appears to be a problem for some reason with the proper adapter identification.

Now try this:

sudo -u $USER /bin/bash -lc 'nmcli networking off' && sleep 1 && sudo systemctl stop NetworkManager && sudo ip link set wlan0 down && sudo rmmod ath10k_pci && sleep 1 && sudo rmmod ath10k_core && sleep 5 && sudo modprobe ath10k_core && sleep 2 && sudo modprobe ath10k_pci && sleep 2 && sudo ip link set wlan0 up && sleep 2 && sudo systemctl start NetworkManager && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli networking on' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi off' && sleep 1 && sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

If the adapter can still not be raised after that then this leaves:

Reset your bios to the factory default.

Is a bios update available? If so you should update your bios.

Update the ath10k firmware, (search on how to install the newest firmware from kvallo on github).

Test the real time kernels, as they are sometimes free of regressions that have recently happened on the mainline Manjaro kernels. You could also switch branches and test the newest 5.6 kernel.

Same as here, but now with wlan0 instead of wlp1s0

Looks like problem is in NetworkManager, because after recent update I found that USB-modem is working not properly until systemctl restart NetworkManager, but reinstalling didn't help

Forum kindly sponsored by