(Qualcomm Atheros QCA6174) WiFi is too slow on Manjaro 20 KDE

Hey,
I just migrated from Windows 10 to Manjaro on my machine. I have a 250 mbps connection, when I connect to my WiFi Network (5Ghz), on windows I get around 100 mbps speed when testing from www.speedtest.net. However, when I tried testing the same from Manjaro I get speed of 5 mbps max.

Here is the output for inxi -Fxxxz

System:    Host: ms-manjaro Kernel: 5.6.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.4 
           tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GT72S 6QF v: REV:1.0 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-1783 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E1783IMS.118 
           date: 05/16/2016 
Battery:   ID-1: BAT1 charge: 82.8 Wh condition: 85.5/86.6 Wh (99%) volts: 12.4/11.1 model: MSI BIF0_9 type: Li-ion 
           serial: N/A status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i7-6820HK bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43214 
           Speed: 900 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 891 2: 900 3: 901 4: 900 5: 900 6: 880 7: 900 8: 895 
Graphics:  Device-1: NVIDIA GM204M [GeForce GTX 980 Mobile] vendor: Micro-Star MSI driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:161a 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fbb 
           Sound Server: ALSA v: k5.6.7-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks driver: ath10k_pci 
           v: kernel port: d000 bus ID: 03:00.0 chip ID: 168c:003e 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: c000 
           bus ID: 05:00.0 chip ID: 1969:e0a1 
           IF: enp5s0 state: down mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:6 chip ID: 0cf3:e300 
Drives:    Local Storage: total: 119.24 GiB used: 49.23 GiB (41.3%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVPV128HDGM-00000 size: 119.24 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: BXW7300Q scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Samsung model: MZVPV128HDGM-00000 size: 119.24 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: BXW7300Q scheme: GPT 
Partition: ID-1: / size: 102.75 GiB used: 24.73 GiB (24.1%) fs: btrfs dev: /dev/nvme0n1p3 
           ID-2: /home size: 116.87 GiB used: 24.49 GiB (21.0%) fs: ext4 dev: /dev/nvme1n1p1 
           ID-3: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 74.5 C mobo: N/A gpu: nvidia temp: 59 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 276 Uptime: 3m Memory: 31.32 GiB used: 1.89 GiB (6.0%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           Shell: zsh v: 5.8 running in: yakuake inxi: 3.0.37 

I have also tried making a conf file: /etc/modprobe.d/ath10k_pci.conf with the following lines:

options ath10k_pci nohwcrypt=1
options ath10k_core nohwcrypt=1
options ath10k_core skip_otp=y

However, there's no luck trying to increase the speed :sob:

PS: I have disabled IPv6 for the network too.

Update 1: 2.4 GHz connection does give a far better speed but it's nowhere near the speed I get on Windows. Moreover, the ping is still too high. It looks like there is an issue mostly when connecting to 5 Ghz

Hello,
Did you try the different firmware approach?

Unfortunately, it didn't solve the issue :sob:
Here is the snapshot of the speed that I got:
image
I don't know if this helps, but my ping is unusually high too. I usually get a ping <10 in Windows.

The first thing to do is test at least 4 alternate kernels back to 4.14 (test at least 1 real time kernel).

Also be sure your bios is up to date.

1 Like

I am on a laptop and it's screen doesn't work, so I have hooked up an external monitor. So I cannot switch kernels.... Anything else that I can try?

I don't understand why that would prevent you from switching kernels. You can do that quite easily using Manjaro Settings Manager.

1 Like

To boot into another kernel I do need to use GRUB right? I cannot see my grub screen since it is displayed on my laptop screen. So when I boot up the first thing I can see is the SSDM.

Too bad that there is no search option here, because this question might have been asked before :wink:

1 Like

I tried the following Kernels:

  1. 5.6.4_rt3
  2. 5.6.7
  3. 5.5.19
  4. 5.4.35
  5. 4.19.118
  6. 4.14.177

However, none of them had any effect on the WiFi speed. The speed is still the same. :slightly_frowning_face:

PS: I tried connecting to the 2.4 GHz connection, that does give a far better speed but it's nowhere near the speed I get on Windows. Moreover, the ping is still too high. It looks like there is an issue mostly when connecting to 5 GHz.

image

Try setting a lower chanel (40 or below) on the 5Ghz band in your router settings.



Disable Network Manager's WiFi power saving features with the following command:

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

A setting of "0" will totally disable power saving features in the WiFi adapter.

A setting of "2" or "1" will be less aggressive, but still leave power saving enabled.

This change can be reversed by deleting the newly created file with the following command:

sudo rm /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot after creating (or removing) any Network Manager configuration file.



You can also try this:

Add ipv6 disable & pcie_aspm=off via grub boot parameters.

The following command will add these GRUB kernel boot parameters to /etc/default/grub:

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ ipv6.disable=1 pcie_aspm=off "/g' -i /etc/default/grub

After adding the boot parameter(s) and saving your changes, run:

sudo update-grub 

Reboot, and test your connection for improvement.

*sed magic courtesy of @dalto


If the change does not improve your connectivity you can restore the file to its original state with:

sudo cp /etc/default/grub.bak /etc/default/grub


Is your bios is up to date?

2 Likes

Looks like setting the Channel Bandwidth to 40 MHz did the trick :slight_smile:

Thanks a ton! :+1:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by