Qualcomm Atheros QCA9377 802.11c Network Card Questions

Hello i'm brazilian user of manjaro and decided to ask the forum because i'm having problems with this network card, the manjaro configuration manager can identify it but apparently it is not enabled, can you help me?
Sorry for not specifying correctly.
Follows print of the command dmesg | grep ath10k:
edit: I'm using the kernel 5.2.8-1-MANJARO now.

This could help.


We will need more info to help you. Unless running a newer kernel is absolutely necessary I would recommend performing your troubleshooting on kernel 4.19.

Please post the output of the following commands:

inxi -Fxxxz  && inxi -Fxxxz  | grep -q ANJ || echo check required && ls /usr/share/xsessions/ && head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11
hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  
lsmod | sort 
journalctl -b -1 | grep -iE NetworkManager| grep '(regdom\|qos\|discon\|error\|seg\|fail\|broke\|reason\|warn\|change\|deauth)'

If the output is large you can use a service such as pastebin to host the info and then post the link to your logs.

Sorry for the lack of information, I'm a beginner so "nobada" as we speak here in Brazil.
Following are the outputs of commands in sequence:

If not bother, if you think the problem could explain me? I like to learn :slight_smile:

At a cursory glance at your outputs it looks as if your wifi is enabled. I will study the logs further.

Some history please.

Did this happen after updating or was the adapter unable to connect from the start.

Have you tried pinging various addresses.

ping -c5                                                                                

ping -c5 google.com 

ping -c5

ping -c5 localhost

Are you running Manjaro in a Virtual Machine?

Hello again, No, I'm using manjaro on my own machine, a user from an arch telegram group commented to me that he downloaded the driver from a repository on github (kvalo - https://github.com/kvalo/ath10k-firmware/blob/master/QCA9377/hw1.0/WLAN.TF.1.0/firmware-5.bin_WLAN.TF.1.0-00023-QCATFSWPZ-1) replacing the default with it, after i did that the instabilities no longer show up, but thanks for your time and help.

Ya that's a pretty standard solution. I would have gotten round to that eventually. I have to screen out the lazy blaggarts by requesting a bunch of outputs first though. :smile:

Glad you got it fixed up.

Thanks, I learned that I have to put more things in describing a problem. By the way there is no deadline for this to be corrected by default? Before my wifi connection was unstable, did not deliver full speed besides the signal was bad.

For sure giving a good in depth description of your issue goes a long ways to getting your issue solved quickly. I will apply the check mark to your post then others will know your help request has been solved. Threads die a natural death after going dormant for a while.

I managed to solve this way, so far the steps are as follows:
1- Download the driver on this page Kvalo - Firmware QCA9377 (leave the name as firmware-5.bin)
1.1- If you have a backup folder you can do this if it doesn't work and want to go back to default: cp /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin
2- sudo cp /home/$HOME/Downloads/firmware-5.bin /lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin
3- sudo update-grub
4- Restarts the machine

If these steps do not work out you can try this:
Qualcoom Atheros Troubleshooting Guide - Forum Manjaro

Thanks to everyone who took the time to help me!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by