Qualcomm WiFi suddenly not working

I can also report that, when booting from a live USB, wifi works flawlessly.

So it's not a hardware issue.

Have you tried removing your stored SSID/password and reconnecting to the wifi?

My USB was disconnecting randomly after the upgrade. I wasn't sure if it was caused by the upgrade, or my router. I removed my stored password, rebooted both the PC and router/modem and all was well again.

1 Like
1 Like

rodneyck, good thought about the stored SSID/passwords, but unfortunately that had no effect.

I should be more clear in my description of the problem: the system doesn't even try to connect. I don't even see a list of nearby SSIDs.

1 Like

FadeMind, I'm on 4.19 and firmware-6.bin is present. So it seems like that shouldn't be the issue?

This may be another Atheros firmware issue. Unfortunately it doesn't have an easy solve like the qca9377. Switching the firmware between version 4, 5, or 6 hasn't seemed to help with this adapters issues.

one thing I can suggest is to put your laptop into suspend, then resume and see if the status changes. The problems with this adapter just started cropping up recently but no fixes have started working yet.

See this current thread:

If you adapter works on the live disk then that tends to indicate a kernel change or a change in network manager is responsible. Test as many different kernels as possible.

Installing networkmanager-noscan from the AUR might be another possible option.

2 Likes

which live iso did you test with? a slightly older one or one you just downloaded? and is it a kde iso?

1 Like

I tested with the manjaro-kde-18.0.2-stable ISO.

did you do an update the night before and go to use it and wifi didnt work? possibly see which update could of cause it and see if you can downgrade?

Perhaps try downloading the newest firmware from github.

Do not overwrite the old firmware in /lib/firmware. Either rename or move the old firmware to a backup location.

That's the funny thing. I reboot after every update, and just like every time before, I rebooted after yesterday's update. And everything came up fine, and continued working for hours.

It was only this morning, when I booted my laptop, that the problem occurred. And nothing I've done has made it even do a search for nearby SSIDs (aside from booting the live USB).

Have you tried deleting the connection in Network Manager and then recreating it?

Have you tried running any ping commands (disconnect LAN).

ping -c5 8.8.8.8

ping -c5 google.com

ping -c5 127.0.0.1 

ping -c5 localhost

Please post the outputs.

1 Like

tbg, unfortunately new firmware didn't fix it.

Here are the ping outputs you requested:

[jwalsh@jw-dx13 ~]$ ping -c5 8.8.8.8
connect: Network is unreachable
[jwalsh@jw-dx13 ~]$ ping -c5 google.com
ping: google.com: Name or service not known
[jwalsh@jw-dx13 ~]$ ping -c5 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.050 ms
64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.132 ms
64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.121 ms
64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.128 ms
^C
--- 127.0.0.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 31ms
rtt min/avg/max/mdev = 0.050/0.107/0.132/0.035 ms
[jwalsh@jw-dx13 ~]$ ping -c5 localhost
PING localhost(localhost (::1)) 56 data bytes
64 bytes from localhost (::1): icmp_seq=1 ttl=64 time=0.055 ms
^C
--- localhost ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.055/0.055/0.055/0.000 ms
[jwalsh@jw-dx13 ~]$ 

Did you make the firmware executable and reboot?

Sorry, but the forum connection is so poor that I don't think I can provide support ATM. The forum is stalling and failing to connect all day on my end.

cat /etc/resolv.conf

I did reboot, but didn't make the file executable. The existing ones did not appear to be.

sudo chmod +x /path/to/firmware

Making the firmware executable had no effect.

Does it matter that dmesg shows it as hw3.2, but there is no 3.2 firmware?

After trying everything suggested here, plus everything I could Google, plus everything I could think of, nothing brought back wifi capability.

So, I backed up my drive, wiped it, and reinstalled.

Then I ran the latest update and....

Everything is still working!

So, unless something changes in the near future, I'll assume it was either related to the recent systemd issues, or just one of those things (let's call it bit rot...).

Thank you for all the help!

1 Like

Forum kindly sponsored by