R8153 - Ethernet connection drops

I have been experiencing problems with my Ethernet connection after some recent updates. My laptop starts with working network, it then loses connection after a couple of minutes. On restart it gets stuck on 'A stop job is running for Network Manager' and hangs.

I was able to find that the problem was caused by tlp. Everything worked fine with version 1.2.2-1.1 but stopped working with version 1.3.1-2. However, after the new updates from the beginning of the week, the problem occurs even if I manually downgrade tlp to 1.2.2 and I also don't want to do partial upgrades.

I've tried disabling tlp with sudo systemctl mask tlp but the problem still persists.
I am running on kernel 5.5, tried switching to 5.4 and 4.19 but still didn't work.

Additional information:

The Ethernet cable is connected through a USB adapter.

Output from inxi -Fxz


System:    Host: Pug Kernel: 5.5.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter> 
           Mobo: Dell model: 0D0T05 v: A00 serial: <filter> UEFI: Dell v: 1.12.0 date: 06/27/2019 
Battery:   ID-1: BAT0 charge: 87.8 Wh condition: 87.8/97.0 Wh (91%) model: SMP DELL GPM0365 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.7 driver: modesetting resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.4 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.5.2-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks driver: ath10k_pci 
           v: kernel port: 3000 bus ID: 3b:00.0 
           IF: wlp59s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:4 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 2-2.4:3 
           IF: enp0s20f0u2u4 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 103.44 GiB (21.7%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 512GB size: 476.94 GiB 
Partition: ID-1: / size: 29.67 GiB used: 18.85 GiB (63.5%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 430.00 GiB used: 84.59 GiB (19.7%) fs: ext4 dev: /dev/nvme0n1p4 
           ID-3: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 66.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2488 fan-2: 2488 
Info:      Processes: 260 Uptime: 37m Memory: 15.29 GiB used: 3.84 GiB (25.1%) Init: systemd Compilers: gcc: 9.2.0 Shell: bash 
           v: 5.0.11 inxi: 3.0.37
  1. 90% of all Ethernet problems can be solved by changing the cable. Try that first. ¯\_(ツ)_/¯

  2. What is the output of:

    systemctl status tlp
    
  3. Have you tried changing the switch to 100mbps? (or if impossible: the NIC?)

:innocent:

Is your LAN connection through a docking station? If so, be sure the firmware is up to date.

Some other alternatives might be to install Connman or switch to dhclient.



You can also try enabling dhclient:

Dhclient is likely already installed, but just to be sure issue:

sudo pacman -S dhclient --needed

To create a config file which sets Network Manager to use the stand-alone dhclient program run this command:

echo -e "[main]\ndhcp=dhclient" | sudo tee /etc/NetworkManager/conf.d/dhclient.conf

NetworkManager is now set to call dhclient, which can sometimes conflict with dhcpd.

To disable the dhcpd service run these commands:

sudo systemctl stop dhcpcd.service

sudo systemctl mask dhcpcd.service

sudo systemctl daemon-reload

sudo systemctl restart NetworkManager.service

Then, manually refresh your IP address assigned by your DHCP client:

Run the following command to refresh your IP address:

sudo /sbin/dhclient -v -r  $(hwinfo --wlan | grep "Device File" | cut -d " " -f5) && sudo dhclient -v -1 $(hwinfo --wlan | grep "Device File" | cut -d " " -f5) 

Then test your connectivity.

  1. If I don't install the latest packages there is no problem with the connection, so I don't think it's the cable.

 ● tlp.service - TLP system startup/shutdown
   Loaded: loaded (/usr/lib/systemd/system/tlp.service; enabled; vendor preset: disabled)
   Active: active (exited) since Wed 2020-03-04 11:11:38 GMT; 19s ago
     Docs: https://linrunner.de/tlp
  Process: 1043 ExecStart=/usr/bin/tlp init start (code=exited, status=0/SUCCESS)
 Main PID: 1043 (code=exited, status=0/SUCCESS)

Mar 04 11:11:37 Pug systemd[1]: Starting TLP system startup/shutdown...
Mar 04 11:11:38 Pug tlp[1043]: Applying power save settings...done.
Mar 04 11:11:38 Pug tlp[1043]: Setting battery charge thresholds...done.
Mar 04 11:11:38 Pug systemd[1]: Started TLP system startup/shutdown.
  1. No luck with that.

The cable is connected through an ethernet to USB adapter, not a full docking station.
I've tried switching to the dhclient but the problem persists.

Possibly related. I get the following error in systemd on startup:

[FAILED] Failed to start Load Kernel Modules
See 'systemctl status systemd-modules-load.service' for details

Output from systemctl status systemd-modules-load.service:

● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2020-03-04 11:38:59 GMT; 1min 6s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 336 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 336 (code=exited, status=1/FAILURE)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

I am considering switching to ConnMan over the weekend to see if that helps.

  1. The service is still running. You have not stopped it. try:

    sudo systemctl disable tlp
    
  2. Meaning "I can't do that" or "I tried, but fixing the speed at 100Mbps didn't make a difference"?

:innocent:

This sounds like same problem as this thread USB ethernet dongle stopped working

I was really disappointed to see it not fixed with latest updates. Linux networking not working should be high priority

Please post:

systemctl list-unit-files --state=failed --no-pager
1 Like

Hi there,
I have a very similar issue. I also have the RTL 8153 USB dongle, but instead of losing the connection permanently I just get constant pop-ups of "Network connection disconnected/connected".

Pretty much exactly every 540 seconds I get the following log in journalctl -u NetworkManager -b :

Mar 04 16:12:31 adequate NetworkManager[717]: <error> [1583356351.0075] dhcp4 (enp0s20f0u2u3): error -113 dispatching events
Mar 04 16:12:31 adequate NetworkManager[717]: <info>  [1583356351.0076] dhcp4 (enp0s20f0u2u3): state changed bound -> fail
Mar 04 16:12:31 adequate NetworkManager[717]: <info>  [1583356351.0077] device (enp0s20f0u2u3): DHCPv4: trying to acquire a new lease within 90 seconds
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.8876] device (enp0s20f0u2u3): DHCPv4: grace period expired
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.8877] device (enp0s20f0u2u3): state change: activated -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.8889] manager: NetworkManager state is now DISCONNECTED
Mar 04 16:14:00 adequate NetworkManager[717]: <warn>  [1583356440.8921] device (enp0s20f0u2u3): Activation: failed for connection 'Wired connection 1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.8963] device (enp0s20f0u2u3): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9080] dhcp4 (enp0s20f0u2u3): canceled DHCP transaction
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9081] dhcp4 (enp0s20f0u2u3): state changed fail -> done
Mar 04 16:14:00 adequate NetworkManager[717]: Source ID 11739 was not found when attempting to remove it
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9145] policy: auto-activating connection 'Wired connection 1' (29fc6989-20a1-37a2-8bc3-24cb9817d5e8)
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9172] device (enp0s20f0u2u3): Activation: starting connection 'Wired connection 1' (29fc6989-20a1-37a2-8bc3-24cb9817d5e8)
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9176] device (enp0s20f0u2u3): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9182] manager: NetworkManager state is now CONNECTING
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9185] device (enp0s20f0u2u3): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9194] device (enp0s20f0u2u3): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9198] dhcp4 (enp0s20f0u2u3): activation: beginning transaction (timeout in 45 seconds)
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9580] dhcp4 (enp0s20f0u2u3): option dhcp_lease_time      => '900'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option domain_name          => 'xxxx'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option domain_name_servers  => 'xxxx'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option expiry               => '1583357340'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option ip_address           => 'xxxx'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option ntp_servers          => '128.253.180.21'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9581] dhcp4 (enp0s20f0u2u3): option requested_broadcast_address => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_domain_name => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_domain_name_servers => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_domain_search => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_host_name  => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_interface_mtu => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_ms_classless_static_routes => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_nis_domain => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_nis_servers => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9582] dhcp4 (enp0s20f0u2u3): option requested_ntp_servers => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_rfc3442_classless_static_routes => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_root_path  => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_routers    => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_static_routes => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_subnet_mask => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_time_offset => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option requested_wpad       => '1'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9583] dhcp4 (enp0s20f0u2u3): option routers              => 'xxxx'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9584] dhcp4 (enp0s20f0u2u3): option subnet_mask          => '255.255.254.0'
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9584] dhcp4 (enp0s20f0u2u3): state changed unknown -> bound
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9607] device (enp0s20f0u2u3): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9646] device (enp0s20f0u2u3): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9649] device (enp0s20f0u2u3): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9655] manager: NetworkManager state is now CONNECTED_LOCAL
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9667] manager: NetworkManager state is now CONNECTED_SITE
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9669] policy: set 'Wired connection 1' (enp0s20f0u2u3) as default for IPv4 routing and DNS
Mar 04 16:14:00 adequate NetworkManager[717]: <info>  [1583356440.9687] device (enp0s20f0u2u3): Activation: successful, device activated.
Mar 04 16:14:01 adequate NetworkManager[717]: <info>  [1583356441.1615] manager: NetworkManager state is now CONNECTED_GLOBAL
Mar 04 16:21:30 adequate NetworkManager[717]: <error> [1583356890.9676] dhcp4 (enp0s20f0u2u3): error -113 dispatching events

etc, etc.

Do any of you have these same log messages?

I'll try some of the debugging steps listed here like trying to disable tlp or downgrade tlp or networkmanager.

My problem does not depend on the ethernet cable I use. Also, I just noticed it today after installing the 2020-03-03 stable update yesterday. Notably, I'm on kernel 4.19.107 and I don't have the failure issue with systemd-modules-load.service.

I hope these two issues are actually related and I'm not just cluttering this thread. (edit: looks like I didn't upgrade either tlp or NetworkManager when I started seeing this problem, so it may be unrelated to this thread. The only packages I upgraded that I think look suspicious were wpa_supplicant and the Linux kernel)

The result of systemctl list-unit-files --state=failed --no-pager

0 unit files.. :thinking:

I got same result 3 times. Interestingly, when I first plugged the ethernet back in I couldn't make it crash. After disabling wifi and rebooting, I could lock the network 'manager' within 10 seconds each time. I'm also using the RTL8153 usb dongle.

Strangely enough, downgrading NetworkManager to 1.22.6-1 seems to make my issue go away. Maybe my issue wasn't related to yours after all.

NetworkManager downgrade does not change my issue. Neither does TLP downgrade

  1. I tried disabling tlp but I still lose connection.
  2. I tried setting the speed at 100Mbps in the connection manager, but it didn't help.

The solution to the thread that you have linked was how I originally solved the same problem. However, when more updates were introduced, downgrading the tlp package stopped working.

The output is:

0 unit files listed.

Just to be absolutely clear:

now does not show any failures any more?

@tbg if above is true, this padawan has a hunch that turning off power management in the driver config would solve the issue, but I'll :bowing_man: to your wisdom, master. :grin:

You could try this:

Disable Active-State Power Management (ASPM) via a kernel boot parameter:

If you are unfamiliar with how to add a kernel boot parameter it can be done easily by using the following command:

sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pcie_aspm=off"/g' -i /etc/default/grub && sudo update-grub 

Press ENTER again if the grub update process does not start scrolling onscreen.

The grub update process takes a little while to complete, and this is perfectly normal.

Once the grub update process is complete, reboot.

1 Like

You should also mask tlp-sleep.service.

sudo systemctl mask tlp && sudo systemctl mask tlp-sleep.service

Then reboot.

Also there have been numerous different users posting different (but related) issues on this thread. I don't recall the topic of kernel versions being discussed fully. I would recommend testing every kernel version including 4.14 on upwards. This also includes the real time kernels as the last to test.

Kernel 5.5 may bring improvements, if not consider switching branches to test kernel 5.6 for a remedy.

He started with masking it, but did not disable... (did trust, but did not verify) :grin: :wink:

1 Like

I 'upgraded' my system to unstable branch with kernel Linux yogibear 5.6.0-2-MANJARO #1 SMP PREEMPT Mon Mar 2 08:53:18 UTC 2020 x86_64 GNU/Linux

Problem still exists :thinking:

Forum kindly sponsored by