r8168 - Cannot start LAN connection

I just installed kde 18.0.4 from a usb. The install worked for everything except that I have no network access.

There's nothing wrong with the networking. I'm using the same computer but with the live 18.0.4 and asking the question right now on the forum.

Here's the inxi from when I boot from the hard drive (after the install)

$ inxi -Fxxz

System:    Host: ethelbert Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: 970A-G46 (MS-7693) v: 2.0 serial: <filter> 
           BIOS: American Megatrends v: 2.8 date: 01/08/2016 
CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 64031 
           Speed: 1399 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 1399 2: 1396 3: 1487 
           4: 1435 5: 1421 6: 1533 7: 1400 8: 1396 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X] vendor: Micro-Star MSI 
           driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati 
           unloaded: modesetting,radeon alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: 
           renderer: Radeon RX 570 Series (POLARIS10 DRM 3.27.0 4.19.28-1-MANJARO LLVM 7.0.1) 
           v: 4.5 Mesa 18.3.4 direct render: Yes 
Audio:     Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: AMD Ellesmere [Radeon RX 580] vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 01:00.1 chip ID: 1002:aaf0 
           Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
           driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 5.46 TiB used: 515.30 GiB (9.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WD30EFRX-68EUZN0 size: 2.73 TiB 
           speed: 6.0 Gb/s serial: <filter> 
           ID-2: /dev/sdb vendor: Western Digital model: WD30EFRX-68EUZN0 size: 2.73 TiB 
           speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 321.54 GiB used: 5.81 GiB (1.8%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 2.36 TiB used: 509.50 GiB (21.1%) fs: ext4 dev: /dev/sda3 
           ID-3: swap-1 size: 11.61 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 21.6 C mobo: N/A gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1023 
Info:      Processes: 212 Uptime: 37m Memory: 11.74 GiB used: 978.1 MiB (8.1%) Init: systemd 
           v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 running in: konsole inxi: 3.0.32 

Here's the networking card when I boot from the hard drive after the install

$ sudo ip link show enp4s0

2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether <filter> brd ff:ff:ff:ff:ff:ff

Here's the networking from the live usb

$ ip link show enp4s0

2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether <filter> brd ff:ff:ff:ff:ff:ff
  • I have checked the system settings: the network settings look the same: no proxy
  • I have checked the system settings: the network connections look the same: wired connection 1: ipv4 method: automatic, ipv6: (not used) automatic
  • no bluetooth

How do I enable the networking?

Thanks

Syv

Boot into your machine (Not live usb) and remove the r8168 driver through mhwd.
Open Manjaro Settings Manager, Hardware configuration, Network Controller, right click on the RTL8111/8168/8411 driver, remove it.
or
sudo mhwd -r pci network-r8168
reboot

:smiley:

3 Likes

Perfect!

Thanks, it's working now

BTW, how do I mark it solved?

Syv

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by