R8168 Ethernet - problem resuming from suspend

Hi, sometimes I use my Ethernet cable instead of Wi-Fi but I noticed this issue where when I put on standby my computer and I resumed it. The Ethernet connection breaks and I have to reboot my PC if I want it back

You need to post your system specs:

inxi -Fxxxz

If you are using the r8168 driver uninstall it. Search the forum and you will find many many posts on why and how to do this.

I would also recommend installing and testing alternate kernels.

System:    Host: aurnytorainks-pc-family Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Gnome 3.34.2 
           wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: A88M-G/3.1 serial: <filter> UEFI: American Megatrends v: P1.40 date: 05/05/2016 
CPU:       Topology: Quad Core model: AMD Athlon X4 860K bits: 64 type: MCP arch: Steamroller rev: 1 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31953 
           Speed: 3488 MHz min/max: 1700/4000 MHz boost: enabled Core speeds (MHz): 1: 2789 2: 2876 3: 2094 4: 2869 
Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: PC Partner Limited 
           driver: amdgpu v: kernel bus ID: 01:00.0 chip ID: 1002:67ef 
           Display: x11 server: X.Org 1.20.6 driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
           compositor: gnome-shell resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon RX 460 Graphics (POLARIS11 DRM 3.35.0 5.4.6-2-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.3.1 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] FCH Azalia vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:14.2 
           chip ID: 1022:780d 
           Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X] vendor: PC Partner Limited 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aae0 
           Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8168 v: 8.047.05-NAPI 
           port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: d000 bus ID: 05:00.0 chip ID: 8086:24f3 
           IF: wlp5s0 state: up mac: <filter> 
           IF-ID-1: br-0b7e1cda1ee1 state: down mac: <filter> 
           IF-ID-2: br-b6030c8bf562 state: down mac: <filter> 
           IF-ID-3: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.58 TiB used: 796.30 GiB (49.1%) 
           ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680 size: 465.76 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: AH10 scheme: GPT 
           ID-2: /dev/sdb vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> rev: R013 
           scheme: GPT 
           ID-3: /dev/sdc vendor: Seagate model: ST1000DX001-1NS162 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC41 scheme: GPT 
Partition: ID-1: / size: 211.10 GiB used: 81.26 GiB (38.5%) fs: ext4 dev: /dev/sdb3 
           ID-2: /home size: 915.89 GiB used: 714.77 GiB (78.0%) fs: ext4 dev: /dev/sdc1 
           ID-3: swap-1 size: 7.59 GiB used: 271.0 MiB (3.5%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 39.0 C mobo: 27.0 C gpu: amdgpu temp: 33 C 
           Fan Speeds (RPM): fan-1: 1229 fan-2: 0 fan-3: 1124 fan-4: 0 fan-5: 2339 gpu: amdgpu fan: 1145 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.38 
Info:      Processes: 244 Uptime: 4h 10m Memory: 7.71 GiB used: 6.53 GiB (84.6%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: zsh v: 5.7.1 running in: tilix inxi: 3.0.37

Uninstall the r8168 driver.

I think I found it. I have to uninstall the linux-latest-r8168 package ?

Better to uninstall through Manjaro Settings Manager or the terminal.

sudo mhwd -i pci network-r8168
2 Likes

Alright, thanks!
I went with the command sudo mhwd -r pci network-r8168 because I removed the unnecessary drivers.
I've rebooted my PC, and looks like it works

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by