R8168 Ethernet - setting network address not working

Boot into Windows 10 and confirmed the Ethernet is working.

sudo rfkill unblock all

I used this command too.

Should I try:
modprobe r8169

When I reset the Network - it usually does the job, meaning i am connected :slight_smile:

lspci | grep -i net
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 79)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)

System: Host: Dell Kernel: 5.4.24-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1
Desktop: KDE Plasma 5.18.3 Distro: Manjaro Linux
Machine: Type: Portable System: Dell product: Vostro 14-5459 v: 1.0.4 serial:
Mobo: Dell model: 01KK0Y v: A00 serial: UEFI [Legacy]: Dell v: 1.0.4
date: 01/07/2016
Battery: ID-1: BAT0 charge: 18.9 Wh condition: 20.7/44.5 Wh (47%) model: SIMPLO Dell
status: Charging
Device-1: hidpp_battery_0 model: Logitech M705 charge: 85% status: Discharging
CPU: Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP arch: Skylake
rev: 3 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20810
Speed: 690 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 2120 2: 2358 3: 2372
4: 1829
Graphics: Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel
bus ID: 00:02.0
Device-2: NVIDIA GM108M [GeForce 930M] driver: N/A bus ID: 01:00.0
Display: x11 server: X.Org 1.20.7 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.6 Mesa 19.3.5
direct render: Yes
Audio: Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k5.4.24-1-MANJARO
Network: Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0
IF: wlp2s0 state: up mac: 00:db:df:5d:7a:96
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
v: 8.048.00-NAPI port: d000 bus ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 20:47:47:77:36:bf
Drives: Local Storage: total: 232.89 GiB used: 129.97 GiB (55.8%)
ID-1: /dev/sda vendor: Crucial model: CT250MX200SSD1 size: 232.89 GiB
Partition: ID-1: / size: 28.71 GiB used: 22.02 GiB (76.7%) fs: ext4 dev: /dev/sda5
Sensors: System Temperatures: cpu: 43.0 C mobo: 29.8 C
Fan Speeds (RPM): cpu: 0
Info: Processes: 179 Uptime: 1d 2h 53m Memory: 7.66 GiB used: 2.05 GiB (26.8%)
Init: systemd Compilers: gcc: 9.2.1 clang: 9.0.1 Shell: bash v: 5.0.16 inxi: 3.0.37

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 20:47:47:77:36:bf brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:db:df:5d:7a:96 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.105/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp2s0
valid_lft 85846sec preferred_lft 85846sec
inet6 fe80::8d13:325a:506c:502f/64 scope link noprefixroute
valid_lft forever preferred_lft forever

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
link/ether 20:47:47:77:36:bf brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
link/ether 00:db:df:5d:7a:96 brd ff:ff:ff:ff:ff:ff

You could try modprobing:

sudo modprobe -r r8168 && sudo modprobe r8169

You would probably be better off to completely uninstall the r8168 driver.

To completely uninstall the r8168 driver, run the following command:

sudo mhwd -r pci network-r8168

Reboot.

2 Likes

tbg,
the-brilliant-guru

kudos, mate

1 Like

Or not so fast...

Now all of a sudden when I go upstairs and would like to use WiFi.... KDE wallet asks for the password and when I key in my correct password for the connection it doesn't work at all.

What gives?

If the Network Manager popup prompt will not accept WiFi password, then try these workarounds.

One work-a-round is to install nm-connection-editor, and then enter password through the connection editor.

You can also try these steps:

Select your wifi connection in Network Manager and apply these settings:

“All users may connect to this network”

“Automatically connect to this network when it is available”

“Store password for all users (not encrypted)”

Then, reboot.

Note:

Storing your password unencrypted is a slight security risk if others have physical access to your computer.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by