R8168 - Wake on Lan disabled at boot

I'm a bit confused...
Trying to uninstall the aur package i only find, that pamac and yay say it's not installed

should i retry installing it and see if wol works?

How did you install the driver?

I see now i am an idiot! XD

That's only the headers and not the package.
So i'll try again

yes, install driver after headers.

So it seems to be insalled, but do i have to worry about this output by yay?

Error! Bad return status for module build on kernel: 5.4.2-1-MANJARO (x86_64)
Consult /var/lib/dkms/r8169_aspm/v4.15.3/build/make.log for more information.

I did not expect it would build on the newest kernels. Use kernel 4.19.

So after reinstalling, i found, that it saddly does not work...

so i guess i'll uninstall the aur package...

Thank you for your help!
But i think i'll have to go to sleep, since it's 3:04am here.
good night.

1 Like

As this was working earlier in the year with the r8169 kernel module the likely suspects are the kernel and firmware. If you've tested most of the kernels, that likely leaves the linux firmware as the change responsible.

If you are on the stable branch you will need to install downgrade.

sudo pacman -S downgrade

Then downgrade the linux-firmware:

DOWNGRADE_FROM_ALA=1 downgrade linux-firmware

Choose the firmware version you wish to test from the list.

Select a package by its number to install.

Test different versions of firmware until you hopefully find one that works.

Well i tried out all old firmware packages, and none of them seem to work...

Does that mean, that WOL just wont work on my machine, r what?

Because the problem ( i think) is still, that wol keeps deactivating at suspend, shut down and reboot....

Did you try it with a startup service with the r8169 module yet. If it still won't start I don't really know what else to suggest other than making sure your bios is up to date.

Perhaps your hardware is simply incompatible, or perhaps kernel 5.5 might help.

What exactly do you mean with a startup device?

A systemd service to load your WOL option at boot.

Is your bios up to date?

That could be the issue if it's not.

When you were testing the different firmware did you reboot or simply suspend. You must reboot after every firmware change.

I think so but i'm not 100% sure.

would the wol-systemd package from the AUR be advisable, or should i set it up myself

Jup. rebooted every time. Suspend was just for testing if the magic packet wakes him up.

But if it is loaded at boot, if i understand it correctly, wol still shouldn't work, because it seems to be disabled at shutdown. so what good would a enabling at boot do?

I'm not on my computer ATM. I'd have to check the systemd/udev versions I have on file for WOL. Perhaps give the package from the AUR a try (I'm unfamiliar with it).

Sorry, but I can't help much for the rest of the day. Last minute Christmas stuff to attend to.

Be sure your bios is up to date, that is very important.

cat /etc/systemd/system/wol.service

Description=Wake-on-LAN for enp2s0

ExecStart=/usr/bin/ethtool -s enp2s0 wol g


I have it like that. Just rename interface and then systemctl enable --now wol.service

So it does not seem to work...

Then merry Christmas!
And thanks allot!

1 Like

I also tried this, and after reboot it is disabled again...

is there some way to disable the disabling at shutdown?

It doesn't disable at shutdown. With g flag set NIC should listen for magic packet when PC is off. It resets at next boot, unless turned on again . At least that's how it should work. Merry Xmas back. We are 2 days away tho. :stuck_out_tongue:

Btw, (from Arch): When using TLP for suspend/hibernate, the WOL_DISABLE setting should be set to N in /etc/default/tlp to allow resuming the computer with WoL. <-- But you probably checked that already.

Can you even set g flag? Or the only problem is making it persistent?


Forum kindly sponsored by