[R8168] Wake On Lan with Realtek RTL8111

Hi all,

I'm really struggling in enabling Wake On Lan after shutdown on my PC which has a Realtek RTL8111 on board NIC.

I actually thought my issue was because of the kernel module, so I already posted in the Kernel forum section, but I'm actually lost now so I'd like to cover every possible step in order to find the cause.

So, sticking to the facts, here's the situation:

  • When booting Windows I can successfully wake the PC from the shutdown state.
  • When booting in Linux I can successfully wake the PC from the suspended state, but NOT from the shutdown state
  • The kernel module loaded is r8168; r8169 got automatically blacklisted during setup
  • I'm running Manjaro Cinnamon, so I have installed NetworkManager and I already set 802-3-ethernet.wake-on-lan: magic. AFAIK this means that I should not use ethtool that is not even installed in my PC; I already tried it anyway to no avail
  • I did my homework and read the wiki; however none of the suggestions about loading r8168 module with s5wol=1 is apparently doing anything. I'm saying this because in /sys/module/r8168 there's no parameters directory

I honestly don't know what else to try. My only feeling, coming from a newbie, is that I should enable that kernel module parameter, but I really cannot find a way to do that. Any hint would be greatly appreciated.

Hate to say it, but maybe your system is just one of those systems that doesn't work with this feature. If you've tried all the solutions suggested on the Archwiki and nothing worked, you just may be one of the unfortunates that this option does't seem to work for.

It's been a while since I've searched this issue, but I seem to recall that there were many cases where it wasn't possible to enable this in Linux.

I hope your not one of those, and that you find your answer.

Temporarily blacklisting the r8168 driver is a good idea. Test out the r8169 kernel module. The r8169 driver has been the driver with less problems lately. Simply change the contents of any Conf file in /etc/modprobe.d that has r8169 to r8168. That's all you need to do to switch divers once you reboot.

...And we have a winner!

It looks like using r8169 instead of r8168 did the trick, so I'm going to stick with it now. Thanks for the hint!

Whoops, sorry. Totally missed it!

No problem, just a hint. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by