Radeon 6770 OpenCL/OpenGL + Blender Woes

TL;DR I have a Radeon 6770 and I'm using the free driers. Is my GPU really too old to work properly as mentioned here and here? Blender shows interesting graphical glitches like this when I render (for a second or two):

image
image

Longer version: I'm dual-booting. On Windows, I'm using a proprietary Windows driver. Blender works fine; on Manjaro, it crashed whenever I save/export (after some work, it now saves/exports fine, but shows weird GPU glitches like the screenshot above, for a few seconds.)

I am a noob, and I tried several things, so here's an information dump.

  • On Windows, Blender reports that I have OpenCL 1.2; on Linux, it reports Open CL 1.1
  • I ran sudo mhwd -a pci free 0300 and it said Skipping already installed config 'video-linux' for device: 0000:01:00.0 (0300:1002:68ba) Display controller ATI Technologies Inc Juniper XT [Radeon HD 6770], which means the right driver is installed
  • A friend suggested I install several packages; notably: radeontool, lib32-opencl-mesa, lib32-vulkan-radeon. I had previously installed opencl-mesa and vulkan-radeon
  • After installing those packages, I reached the current problem, albeit Blender now mentions OpenCL (previously, it said OpenCL isn't supported)

Here's a partial dump from system-info from Blender:

OpenGL:
===========================================
renderer:	'AMD JUNIPER (DRM 2.50.0 / 5.4.43-1-MANJARO, LLVM 10.0.0)'
vendor:		'X.Org'
version:	'3.3 (Core Profile) Mesa 20.0.7'
extensions:
OpenCL device capabilities:
Number of platforms: 1
Platform #0
	Platform Name: Clover
	Platform Vendor: Mesa
	Platform Version: OpenCL 1.1 Mesa 20.0.7
	Platform Profile: FULL_PROFILE
	Platform Extensions: cl_khr_icd
	Number of devices: 1
		Device: #0
			Device Name: AMD JUNIPER (DRM 2.50.0 / 5.4.43-1-MANJARO, LLVM 10.0.0)
			Device Vendor: AMD
			Device OpenCL C Version: OpenCL C 1.1 
			Device Profile: FULL_PROFILE
			Device Version: OpenCL 1.1 Mesa 20.0.7
			Device Extensions: cl_khr_byte_addressable_store cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics
			Device Max clock frequency (MHz): 850
			Device Max compute units: 10
			Device Max work group size: 256

The same thing on Windows reports OpenGL 4.5.

sudo dmesg | grep radeon shows:

 [  10.491359] [drm] radeon kernel modesetting enabled.
[   10.491403] radeon 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xd0000000 -> 0xdfffffff
[   10.491405] radeon 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xe1420000 -> 0xe143ffff
[   10.491407] fb0: switching to radeondrmfb from VESA VGA
[   10.491466] radeon 0000:01:00.0: vgaarb: deactivate vga console
[   10.491762] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[   10.491763] radeon 0000:01:00.0: GTT: 1024M 0x0000000040000000 - 0x000000007FFFFFFF
[   10.492098] [drm] radeon: 1024M of VRAM memory ready
[   10.492098] [drm] radeon: 1024M of GTT memory ready.
[   10.768606] [drm] radeon: dpm initialized
[   10.827973] [drm] enabling PCIE gen 2 link speeds, disable with radeon.pcie_gen2=0
[   10.854525] radeon 0000:01:00.0: WB enabled
[   10.854527] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000040000c00 and cpu addr 0x000000006861a7c9
[   10.854528] radeon 0000:01:00.0: fence driver on ring 3 use gpu addr 0x0000000040000c0c and cpu addr 0x00000000b1571102
[   10.854894] radeon 0000:01:00.0: fence driver on ring 5 use gpu addr 0x000000000005c418 and cpu addr 0x0000000033b9c1ea
[   10.854897] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[   10.854935] radeon 0000:01:00.0: radeon: using MSI.
[   10.854954] [drm] radeon: irq initialized.
[   11.818703] fbcon: radeondrmfb (fb0) is primary device
[   11.818707] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[   11.850852] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0

Perhaps most importantly, ixni -Fxxxz now shows a driver failure?:

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 6770] vendor: ASUSTeK driver: radeon v: kernel 
           bus ID: 01:00.0 chip ID: 1002:68ba 
           Display: x11 server: X.Org 1.20.8 driver: radeon FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1280x1024_60.00~60Hz, 1440x900~75Hz 
           OpenGL: renderer: AMD JUNIPER (DRM 2.50.0 / 5.4.43-1-MANJARO LLVM 10.0.0) v: 3.3 Mesa 20.0.7 compat-v: 3.1 
           direct render: Yes 

Is there any thing I can do now to improve my GPU situation, other than buying a newer card?

Your GPU has to use the radeon driver and not the amdgpu which appears to do so.

I would suggest to load the radeon module in /etc/mkinitcpio.conf like this:

MODULES=(radeon)

then run

sudo mkinitcpio -P

and blacklist the amdgpu one in /boot/grub/grub.cfg by adding module_blacklist=amdgpu and then run

update-grub

Reboot to see the results.

This file has a big warning header about it being generated. Rebooting removed my changes and everything else looks the same (inxi output, Blender).

My mistake.
I need sleep.
You need to edit /etc/default/grub
It 's in the section GRUB_CMDLINE_LINUX_DEFAULT
Then run

sudo grub-mkconfig -o /boot/grub/grub.cfg

Are you sure it's module_blacklist and not module.blacklist? I tried module_blacklist by itself, and both together. Same output from inxi. I don't know why it's not blacklisting that module. I'll look into it more.

According to this it's with the underscore:

https://wiki.archlinux.org/index.php/Kernel_module#Using_kernel_command_line_2

1 Like

So I ran lsmod and lsmod | grep amd and it doesn't list anything - so I'm pretty sure the blacklist worked. That doesn't seem to resolve the issue with the driver failing to load (or whatever that inxi error means).

Does Blender have the same issues ?

Afraid so.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by