Radeon blacklight issue

Hello community, i have an issue with my laptop. I recently installed Manjaro xfce on it. I dont know whats happened, everything worked fine and smooth, but suddenly i can not boot my laptop, getting this massage on boot up process.

failed to start load/save screen backlight brightness of backlight:acpi_video0

I tried to find a solution but nothing has worked.

Probably f***** Radeon Card problem...

System:    Host: manjaro Kernel: 4.4.19-1-MANJARO x86_64 (64 bit gcc: 6.1.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: Manjaro Linux
Machine:   System: ASUSTeK (portable) product: X550EP v: 1.0
           Mobo: ASUSTeK model: X550EP v: 1.0
           BIOS: American Megatrends v: X550EP.303 date: 03/13/2014
Battery    BAT0: charge: 34.8 Wh 99.9% condition: 34.8/37.4 Wh (93%)
           model: ASUSTek X550A26 status: Full
CPU:       Quad core AMD A4-5000 APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 11981
           clock speeds: max: 1500 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 1300 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8330]
           bus-ID: 00:01.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]
           bus-ID: 01:00.0
           Display Server: X.Org 1.17.4 driver: radeon
           Resolution: 1366x768@60.01hz
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 2.43.0 / 4.4.19-1-MANJARO, LLVM 3.8.1)
           GLX Version: 3.0 Mesa 12.0.1 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.4.19-1-MANJARO
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: USB /dev/sda model: Rainbow size: 4.0GB
           ID-2: /dev/sdb model: TOSHIBA_MQ01ABD0 size: 750.2GB
Partition: ID-1: / size: 4.0G used: 3.1M (1%) fs: overlay dev: N/A
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A gpu: 41.0,N/A
           Fan Speeds (in rpm): cpu: 2000
Info:      Processes: 163 Uptime: 51 min Memory: 469.8/5409.4MB
           Init: systemd Gcc sys: 6.1.1
           Client: Shell (bash 4.3.461) inxi: 2.3.1

This post suggest trying kernel 4.7.

Thank you for your reply.

The question ist how do i Install 4.7 Kernel from an USB stick or live CD. I currently using a live immage because i can not boot up the installed system.

Think this is the link:

Chroot into your system, then you can install the kernel using mhwd-kernel.

Perhaps change to free drivers at same time?

Wow, linux is really amazing. Nice feature.

But still it did not solve the problem.
I am getting this

i don't think the backlight issue is the one preventing you from booting.

I think it's the last line: usb 6-1:.

Possible info here on the issue: https://bbs.archlinux.org/viewtopic.php?id=38859

Do you have something plugged into a usb port?

I am going on the bottom error message........

Unplug all usb devices.

@strit beat me to it!

It is really strange. I tried to boot several times, but this usb issue happened only few times.
And i did nothing plug in.

Not even a hub on a monitor?

modprobe -r ehci_hcd

Worth a pop.

i tried it, but did not help. Now boot process stopped at "Started Accounts Service", like this normally was since the issue.

Can you access a tty (press ctrl+alt+f2 or f3 etc).

yes i can

Log in -

Check your logs for errors:

journalctl -b 

Checked logs for errors.
summary of errors:
Kernel: drm:radeon_acpi_init [radeon] ERROR Can not find a backlight controller
system-backlight 482: Failed to get backlight or LED device "backlight:acpi_video0" : No such device
systemd 1:Failed to start Load/Sav screen backlight of backlight:acpi_video0

this one several times:
systemd 1: Failed to start Light Display Manager

move on
login 639: pam_tally(login:auth): pam_get_uid; no such user

some problems with bluetoothd
some problems with processor i think
ntpd 783: unable to create socket on wlp2s0 .......

This is why you have a black screen.

What does systemctl status lightdm tell?

this tell me.

Loaded: error (Reason: file exists)
Active: inactive(dead)
Docs: man:lightdm(1)

systemd[1] lightdm.service: two services allocated for the same bus name org.freedesktop.DisplayManager, refusing operation


ls -la /usr/lib/systemd/system/lightdm*

Post output.

Forum kindly sponsored by