Random shutdown/reboots on my Manjaro system

Hello,
I have got an annoying problem with my manjaro system. Randomly my manjaro system shutdown immediately and restarts.

I did not find any log entrys in journalctl, so I have absolutely no idea, why it is happens. I thought about an hardware failure of the power supply and replaced that by a new one, but the problem is still there. I also tried BIOS updates and now have the newest BIOS for my mainboard.

Kernels I used for a long time 4.9, then tried 5.4. Right now I am at 5.5.

Sometimes this shutdown/reboots happens once a day. Sometimes one week without the problem. Sometimes it also happens 2-3 times on a day. So really strange. I also cannot say, that it only happens, when the system is on high load. Even when surfing on the internet and reading news, it already happened.

Hopefully someone here as an idea or solution for me.

Here are some system information:

System:
  Host: base Kernel: 5.5.19-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF Z370-PLUS GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2401 date: 07/15/2019 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 
  charge: 50% (should be ignored) status: Charging 
CPU:
  Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 76831 
  Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 801 6: 800 7: 800 8: 801 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ZOTAC driver: nvidia 
  v: 440.82 bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.8 driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: NVIDIA GP104 High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-6:3 
  Sound Server: ALSA v: k5.5.19-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 698.65 GiB used: 183.41 GiB (26.3%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 250GB 
  size: 232.89 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 750 EVO 500GB size: 465.76 GiB 
Partition:
  ID-1: / size: 86.01 GiB used: 34.81 GiB (40.5%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /home size: 297.87 GiB used: 148.57 GiB (49.9%) fs: ext4 
  dev: /dev/sda2 
  ID-3: swap-1 size: 15.37 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 60 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 23% 
Info:
  Processes: 315 Uptime: 7m Memory: 15.58 GiB used: 2.52 GiB (16.2%) 
  Init: systemd Compilers: gcc: 9.3.0 clang: 10.0.0 Shell: bash v: 5.0.16 
  inxi: 3.0.37 

Many thanks for your hints and help.

Search the forum - there is other topics on the matter.

you also check with powertop and tlp-stats
if something is wrong

remove if necessary tlp

have you any other port USB used ?
remove and keep keyboard and mouse to check

@stephane: What exactly should I check with powertop and tlp-stats? What should I look for?

Of course, I used several USB ports. Mouse, Keyboard, Webcam.

you dont really try to search

  1. is on AC or battery that it's happened ?
  2. have you try with minimal keyboard and mouse ?

It is a desktop computer with AC. So no battery.

I did not try with another mouse/keyboard.

Hello,
let me give a short update.
I downgraded my Kernel. Right now, I am using 4.14. And the reboot/shutdown problem did not happen for a week now.

Any idea?

Nobody a solution?

So far it seems that the following kernels work stable: 4.14 and 4.19

With 5.4, 5.6, 5.7 I have those crashes.

The solution is to run the stable kernels that you have just found. Manjaro will keep updating the other kernels for you in the meantime, so if you really want to run one of the more recent ones, you can try them again in the future. They might have improved. Either way, there's nothing wrong with sticking to 4.14 or 4.19. That's what I am doing.

Thanks, TheApoligist.
Isn't really a solution, but exactly what i am doing right now.
I uninstalled all other kernels now and stick to 4.19.
So far, 4.19 is supported that is no problem.

Have a nice weekend.

An Arch Linux kernel is never expected to run flawlessly, which is why there are so many of them.

Unless you need the disk space, there is no need to uninstall the kernels. Pacman will keep updating them for you, even if not used. Once or twice a month you can try them out to see if improved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by