RE: Manual Partitioning - boot, esp flag

Hello, I have a suggestion for your manjaro/win dual boot installing tutorial.
It took me many hours of searching to find your post where you mention that the "step 6" (creating /boot/efi partition) is not even mandatory.
I feel like it would be fair to mention that in the tutorial already.
And also to mention what to do, if manjaro installer just doesn't allow to add the ESP flag.
Because it just doesn't.
So I tried ignoring that step, and now even manjaro installer itself tells me that I should really create a /boot/efi partition with boot & esp flags. So I go back, but it still doesn't offer any esp flag it just asked for. This wasted almost whole day of my life for nothing. Other part of day wasted on Grub expecting me to understand that "driver=free" is not just about any driver, but about graphics card driver and worth trying if i'm getting just glitches on the screen when trying to boot. Would it hurt to call it gpu_driver at least? I don't get it.

Thank you for making me aware of the matter.

The guide to install Windows 10 has been amended to exclude the reference to the esp flag. As an author of a guide I rarely revisits the guide - unless I come to knowsa change is needed - all guides needs the user to provide feedback.


I have seen more than a few topics relating to a Windows update making Manjaro disappear. The reasoning for creating an EFI partition on a dual-boot system is emphasized in the guide.

As time passes - some topics and comments - correct at the time of writing - due to their technical nature - may become incorrect when software changes. So if you are looking at a topic which may be dated back several years - you should strive to always use the newest version - or at least ask :slight_smile:.


Remember - there is no stupid questions - when you start your Linux journey. If you are a hardcore Linux user - then it is a different matter - but still if your previous distribution was Ubuntu - then Manjaro will be a lot different and there will be no stupid Manjaro specific questions.

Remember - there is no stupid questions only stupid answers.

2 Likes

Baloney. There are plenty of each.

5 Likes

Not as many as you think. I hope you are pleased with your advice.

I finally managed to install it, after trying several tutorials.
What I did was instead of creating a boot partition, I added a "/boot/efi" as mounting point to the existing boot partition which windows created.
Installer shown that it already has the BOOT flag. But it didn't show if it has ESP flag, nor did it allow to add it or remove it.
I found this method in some tutorial, where they also made sure the ESP flag is there, but it's not like that anymore. The current installer neither shows ESP flag on partions, nor allows you to set them.
But I checked using "sudo parted -l" command in terminal, and it showed me that the windows's boot partition indeed has that ESP flag set, even if the installer doesn't show it. So I assumed all is ok, tried clicking "NEXT" and got no warning, so continued installing and all was OK. It boots into menu where I can choose.
But I've seen video of somebody installing previous version of manjaro, and those installers DID show the esp flag when editing the windows's boot partition. So is that some new bug introduced to current version of installer? It's very confusing, as that flag is mentioned in all tutorials. Even the installer itself tells you to set that flag, when if warns you that you made no boot partition. But it just doesn't include the ESP flag in the flag list at all. At least not on my computer... and yes, I made sure to disable all the secure boot and other stuff and made sure to use gpt uefi etc etc... still no ESP flag nowhere in the manual partition part of installing

Good. Now can we take a look at the output at your Manjaro terminal..?

sudo parted -l
cat /etc/fstab
efibootmgr -v

note: parted -l --> small 'L', not 'one' ; all disks, complete output.
Your questions make me unsure of a few things. Just want to check it out.

?????????????????????

[neviem@black ~]$ sudo parted -l
Model: ATA ADATA SU900 (scsi)
Disk /dev/sda: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  556MB   555MB   ntfs         Basic data partition          hidden, diag
 2      556MB   661MB   105MB   fat32        EFI system partition          boot, esp
 3      661MB   677MB   16,8MB               Microsoft reserved partition  msftres
 4      677MB   816GB   815GB   ntfs         Basic data partition          msftdata
 5      816GB   839GB   23,3GB  ext4
 6      839GB   1024GB  185GB   ext4

[neviem@black ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=86A7-F3A2                            /boot/efi      vfat    umask=0077 0 2
UUID=ce2a2219-2d96-408e-a0dc-2141cfeb4bfa /              ext4    defaults,noatime,discard 0 1
UUID=f7bbbd23-3f76-4861-aff2-97642e2017d8 /home          ext4    defaults,noatime,discard 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

[neviem@black ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003,0000
Boot0000* Windows Boot Manager	HD(2,GPT,7fe570dc-4c89-4385-bd4c-eaf9e41c24a9,0x109000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0003* Manjaro	HD(2,GPT,7fe570dc-4c89-4385-bd4c-eaf9e41c24a9,0x109000,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)
[neviem@black ~]$

Wait - is this a discussion thread about a tutorial, or is this a help request thread?

Okay, looks fine. I have the impression you have a problem during installation.
A $esp (EFI partition) is mandatory for uefi installation. I thought you do not have one.

You do not need to create an $esp if one exists (your uefi windows need one too) and you are reusing/sharing that. And you can have a separate (meaning additional) one as well and that is not mandatory, though preferable, IMO.

Perhaps another confusion is what mount point should that $esp be. /boot/efi or /boot.
Grub $esp must be mounted as /boot/efi.
Systemd-boot $esp must be mounted as /boot.
Refind $esp can be either.

As for the esp flag, it is an alias for the boot flag used for gpt partitions.
When the $esp is selected during installation, this flag is generated.
Boot (and esp) flags are not necessary for linux (if partition table is set and correct) but windows must have a boot flag to work.

I think OP is sharing his experience that he needs a $esp (and selecting it) during installation.
He was under the impression he doesn't need this $esp and wish to inform us it is required.
As for the flag, he is informing us that the installation does not create (add, OP says) a ESP flag.
If windows exist, there should be an existing flag (if same $esp is used, as it is in his case).
I just added here that a flag is not necessary for linux to operate (but windows need it).

But I won't worry how to pigeonhole or classify this topic.

1 Like

You no longer need to set the boot AND esp flags in calamares. Only the boot flag is required for the /boot/efi partition.

There was a change to N kpmcore4.

What implications this will have on dual boots is unknown to me. I don't do windows. It also had an effect on the manjaro ISO's.

1 Like

From parted manual/wiki

‘esp’
(MS-DOS, GPT) - this flag identifies a UEFI System Partition. On GPT it is an alias for boot.

This flag (either boot or esp) is not needed for linux.

I've mentioned elsewhere in this forum, I've set/removed boot flags on any/all/relevant/irrelevant/ partition or none in both msdos/bios-legacy and gpt/uefi systems without issue. Some people have problems without a boot flag (won't boot) mainly seen on msdos/bios-legacy but I suspect that their partitioning table is not set. Some have installed using 'erase disk' thereby removing the partitioning table.

See many other outside links in this link. that boot flag is not required for linux.

3 Likes

Originally it was my question+suggestion for an author of one tutorial, which became bit outdated (boot partition creation step was just impossible to do), so I thought i'd let author know about the issue, so s/he can update the tutorial, so that new people won't have to spend whole day just trying to install manjaro.

Forum kindly sponsored by