Read-Only USB Stick unable to format

I'll upload a video my writing skills are not so good, Just give me minute. :slight_smile:

So This What is happening. Gparted Log

Delete it first

You are formatting it.

You need to put a new partition table on it before you format it.

In gparted under "Device" menu, "Create partition table"

already tried but doesn't work

Same Error

Close gparted and try doing it from the command line:

sudo parted /dev/sdx -- mklabel gpt

Replace /dev/sdx with the correct device name. Importantly, don't use the wrong device name as that would make all your data inaccessible.

If that doesn't work, please share the full command you used as well the text output.

Here the output

[yasir@Markhor ~]$ sudo parted /dev/sdb -- mklabel gpt
[sudo] password for yasir: 
Warning: Unable to open /dev/sdb read-write (Read-only file system).  /dev/sdb
has been opened read-only.
Error: Can't write to /dev/sdb, because it is opened read-only.
Ignore/Cancel? C  

Does it have a physical write protect tab on the device?

What does the command mount | grep sdb return?

nothing

[yasir@Markhor ~]$ mount | grep sdb
[yasir@Markhor ~]$ 

So, the software flags don't show it is as read only, there is no physical switch on it to make it read only and it isn't currently mounted.

That seems bad. I am out of ideas.

Try
sudo hdparm -r0 /dev/sdb
to see if it removes the read-only. Perhaps it would.

I tried it already it's mentioned in my post.

Sorry, I overlooked it.
:blush:

1 Like

Nope!

[yasir@Markhor ~]$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 298.1G  0 disk 
├─sda1   8:1    0  90.1G  0 part /
├─sda3   8:3    0     8G  0 part 
└─sda4   8:4    0   200G  0 part 
sdb      8:16   1     8M  1 disk 
└─sdb1   8:17   1     7M  1 part 
sr0     11:0    1  1024M  0 rom  
[yasir@Markhor ~]$ sudo dd if=/dev/zero of=/dev/sdb status=progress oflag=sync
[sudo] password for yasir: 
dd: failed to open '/dev/sdb': Read-only file system

Probably fake then

http://oss.digirati.com.br/f3/

and what does this mean?

I mean - either way - it is dead.

And no amount of comments are going to change that.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by