Rebooted system during system update

Hi all,

So i have decided to install the latest update to manjaro today, but my screen kept getting locked because of auto lock while the update is being installed (power management). Soo, the laptop acted weird for a bit (i had to go through two lock screens) then it got locked again, but this time it didn't show me the lock screen, it had a text telling me the the lock screen is disabled and that i should click on ctrl+alt+f2 to go to terminal then unlock it, but i got a little bit too confident in myself and did that without reading the rest of the message.

So the laptop booted, grub was displayed, then this message appeared: (i am using 5.2.2 (latest version) but i was trying to boot into an older kernel)

Warning: /lib/modules/4.19.79-1-MANJARO/modules.devname not found - ignoring 
ERROR: resume: hibernation device 'UUID-0df1d1b6-4ab2-460c-b878-b295b339c80d' not found 
mount: new root: can't find UUID- 5253ecb1-c23c-4a23-a572-22ee02e3081c. 
You are now being dropped into an emergency shell. 
sh: can't access tty: job control turned off
[rootfs ]#

I came to manjaro forums looking for a solution, but none of them had the same kind of ... "problem" i have, so i tried them anyway but non of them worked. The problem that the other posts had was something related to the UUID being different in RESUME in grub, but take a look at this:

lsblk -fs
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash                                                  0   100% /run/miso/
loop1
     squash                                                  0   100% /run/miso/
loop2
     squash                                                  0   100% /run/miso/
loop3
     squash                                                  0   100% /run/miso/
sda1 vfat         914B-30ED                                           
└─sda
                                                                      
sda2 ext4         5253ecb1-c23c-4a23-a572-22ee02e3081c                
└─sda
                                                                      
sda3 swap         0df1d1b6-4ab2-460c-b878-b295b339c80d                
└─sda
                                                                      
sdc1 iso966 MJRO1811
│                 2019-10-15-10-44-06-00                     0   100% /run/miso/
└─sdc
     iso966 MJRO1811
                  2019-10-15-10-44-06-00                              
sdc2 vfat   MISO_EFI
│                 1279-4CF4                                           
└─sdc
     iso966 MJRO1811
                  2019-10-15-10-44-06-00

The UUID isn't different. i have ran sudo pacman -Syyuu to continue the update then rebooted but it didn't change anything, i am worried about changing anything else please help !

For those who did the same thing and are also hesitant to try anything.
Try doing the following:

  1. Boot in live usb
  2. Mount to your install by executing manjaro-chroot -a
  3. The name in terminal will become red, continue the update (if you haven't) using sudo pacman -Syyuu
  4. After the update is done installing, execute the command mkinitcpio -p linuxXX (where XX is the kernel version, eg. mkinitcpio -p linux52) you can check the available kernel versions by going to /etc/mkinitcpio.d
  5. write exit
  6. Reboot

It should reboot normally now.

EDIT: someone suggested that using mkinitcpio -P instead of the command in step 4 is better because it works for all linux installed on your machine.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by